LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 01-04-2004, 11:40 AM   #1
StaticSage
LQ Newbie
 
Registered: Mar 2003
Posts: 17

Rep: Reputation: 0
Intel Sound Card won't work on RedHat 9 (82801BA/BAM AC'97)


When I click play test sound from the soundcard detection app, I hear nothing so I click no and recieve "Automatic dection of the sound car did not work. Audio will not be available on the system." I tried to run sndconfig, but the command is not found.

lspci:
00:00.0 Host bridge: Intel Corp. 82845 845 (Brookdale) Chipset Host Bridge (rev 04)
00:01.0 PCI bridge: Intel Corp. 82845 845 (Brookdale) Chipset AGP Bridge (rev 04)
00:1e.0 PCI bridge: Intel Corp. 82801BA/CA/DB PCI Bridge (rev 05)
00:1f.0 ISA bridge: Intel Corp. 82801BA ISA Bridge (LPC) (rev 05)
00:1f.1 IDE interface: Intel Corp. 82801BA IDE U100 (rev 05)
00:1f.2 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #1) (rev 05)
00:1f.4 USB Controller: Intel Corp. 82801BA/BAM USB (Hub #2) (rev 05)
00:1f.5 Multimedia audio controller: Intel Corp. 82801BA/BAM AC'97 Audio (rev 05)
01:00.0 VGA compatible controller: nVidia Corporation NV11DDR [GeForce2 MX 100 DDR/200 DDR] (rev b2)
02:04.0 FireWire (IEEE 1394): Texas Instruments TSB12LV26 IEEE-1394 Controller (Link)
02:08.0 Ethernet controller: Intel Corp. 82801BA/BAM/CA/CAM Ethernet Controller (rev 03)
02:09.0 Modem: PCTel Inc HSP MicroModem 56 (rev 02)

I also attempted to install alsa, but it says this:
[root@localhost alsa-driver-1.0.0rc2]# ./configure --with-cards=intel8x0 --with-sequencer=yes;make;make install
checking for gcc... no
checking for cc... no
checking for cc... no
checking for cl... no
configure: error: no acceptable C compiler found in $PATH
See `config.log' for more details.
make all-deps
make[1]: Entering directory `/root/alsa-driver-1.0.0rc2'
make[1]: Nothing to be done for `all-deps'.
make[1]: Leaving directory `/root/alsa-driver-1.0.0rc2'

Please, run the configure script as first...

rm -f /snd*.*o /persist.o /isapnp.o
make[1]: Entering directory `/root/alsa-driver-1.0.0rc2/acore'
Makefile:6: ../Makefile.conf: No such file or directory
make[1]: *** No rule to make target `../Makefile.conf'. Stop.
make[1]: Leaving directory `/root/alsa-driver-1.0.0rc2/acore'
make: *** [install-modules] Error 1

I'm a total newb when it come to anything linux. I had sound running in slackware previously, but it wasn't a good distro for me to start out learning on. Please help.
 
Old 01-05-2004, 05:04 PM   #2
GAVollink
Member
 
Registered: Apr 2002
Location: St. Paul, Minnesota
Distribution: UbuntuStudio, Ubuntu
Posts: 357

Rep: Reputation: 31
If you can't compile with GCC then you are quite likely to not be able to get anything working. I really dis-like suggesting this, but if it isn't too extremely in-convenient, I would suggest re-installing RedHat with "Everything", or at very least with all development labelled packages.

While you may not be a developer, so much is distributed in source form, that it's never worth it to have a Linux without it also being a dev platform.

Last note - the AC'97 should be a kernel module thats included with RedHat. See what you get in 'lsmod'. The module is called "ac97", if it's not listed try doing an 'insmod ac97' and see what happens. AFAIK (As far as I know) OSS (not alsa) is the default sound system under RedHat, so you may need to check the web pages for OSS.
 
Old 01-05-2004, 05:24 PM   #3
StaticSage
LQ Newbie
 
Registered: Mar 2003
Posts: 17

Original Poster
Rep: Reputation: 0
Thanks a lot for the reply. I actually reinstalled already with everything, but still no sound. I'm working on upgrading the kernel and then trying. I'll post back with how that turns out.
 
Old 06-08-2006, 08:05 PM   #4
mazinoz
Member
 
Registered: Mar 2003
Location: Mansfield Queensland Australia
Distribution: Debian Squeeze. Various live CD's Win7
Posts: 359

Rep: Reputation: 32
I fixed the problem by going to menu System, Preferences, Sound and enabling what I wanted enabled. Then, System,Preferences, VOLUME CONTROL, and enabled and increased volume for what I needed.

However, all of the above suggestions are not in vain as these things are needed for playing movies etc.

Cheers

MazinOz
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Intel 82801BA/BAM USB, Intel 82801BA/BAM AC'97 Audio, and MATSHITA UJDA710 Problems treth Linux - Hardware 1 06-08-2006 08:10 PM
PCI Intel AC'97 sound card and RH 9 ? kandyco Linux - General 1 09-04-2004 05:36 AM
Help!! How do I enable the audio driver for the 82801BA/BAM AC'97 Sound Card? htnthguyen Red Hat 3 01-26-2004 06:53 PM
SuSe 9 w/ 82801 BA/BAM ac'97 Audio Munch371 Linux - Hardware 8 11-30-2003 09:23 PM
i810 Audio Module For 82801BA/BAM AC'97 Soundcard TeenGangsta2003 Linux - Hardware 1 04-05-2003 05:16 AM


All times are GMT -5. The time now is 08:57 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration