LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 06-28-2005, 07:15 PM   #1
aratis
Member
 
Registered: Oct 2003
Location: Paris, Texas
Distribution: RHEL4
Posts: 48

Rep: Reputation: 15
Installing NVIDIA Driver --- Kernel Source ???


I am attempting to install NVIDIA drivers in CentOS 4.1. I have set up my "xorg.conf" and also made a back up of the original. I reboot the system and the XServer crashes and boots me directly to the command line. Great so far. I browse to the NVIDIA driver rpm, log in as root and type "rpm -ivh NVIDIA.**.rpm". Everything works like greased pickles, until its time to do something with the kernel. This is where the installation fails because it can't find the "Kernel Source". I have looked at the "Add/Remove Programs" application in GNOME and I can't find anything that talks about the "Kernel Source".

What is this and how do I get it?

I looked on RPMFind.net and couldn't find one for RHEL4 or CentOS4.1.

Thanks in Advance.
-aratis
 
Old 06-28-2005, 09:04 PM   #2
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
ok here is what you should do. first don't try to use the rpm file, as you'll just face problems.

go to nvidia.com and download the latest linux drivers.

then type yum install kernel-devel
then type init 3
then type in /usr/sbin/setenforce 0
then type sh PATHTONVIDIADRIVERS.RUN replacing that with the path to nvidia drivers
then once it finishes type /usr/sbin/setenforce 1
then edit the file /etc/X11/xorg.conf replacing nv with nvidia and make sure you put a # before load dri, and make sure it says load glx.

then type init 5.
 
Old 06-28-2005, 11:03 PM   #3
aratis
Member
 
Registered: Oct 2003
Location: Paris, Texas
Distribution: RHEL4
Posts: 48

Original Poster
Rep: Reputation: 15
sounds great.

I will give it a sporting chance when I get home from work. I would like to ask you/anyone some questions though:

what do "init, setenforce 0, " do? I am pretty sure that the "#" before "dri" is for commenting it, but I am unsure as to what the others do. Do they have something to do with run-levels?

Also, should I do all of this in a terminal inside of gnome or another method?

Thanks A Ton!
 
Old 06-28-2005, 11:14 PM   #4
liquidtenmilion
Member
 
Registered: May 2004
Location: South Carolina
Distribution: Slackware 11.0
Posts: 606

Rep: Reputation: 31
# is for commenting, so that it doesn't load DRI, which nvidia provides itself.

init is for changing different modes so to say. Init 3 is text mode, while init 5 is graphical mode.

/usr/sbin/setenforce 0 disables SElinux, which when enabled you can't install the nvidia drivers, then setenforce 1 reenables it.(if you aren't using SElinux, then don't type those commands)

press control+alt+f1 to do this, it'll bring you to a terminal, then start off by yum install kernel-devel, then init 3 and so on.

oh, and when you are editing, make sure you do it in that terminal. i'm going to retype the steps, follow these:

make sure you have the development tools checked under Remove/Add applications(i believe)
download nvidia drivers
press ctrl+alt+f1
log in as root
yum install kernel-devel (if you followed the first step you should already have these)
init 3
/usr/sbin/setenforce 0
sh PATHTONVIDIADRIVERS.RUN replacing that with the path to nvidia drivers
then once it finishes type /usr/sbin/setenforce 1
type nano /etc/X11/xorg.conf look for something that said "load dri" comment that with a #, and make sure that load glx is uncommented. Then look for a section that says, "driver" "nv" or "driver" "vesa" and replace it with "driver" "nvidia" then press ctrl+x
then type init 5 and post if anything goes wrong.

Last edited by liquidtenmilion; 06-28-2005 at 11:20 PM.
 
Old 06-29-2005, 08:07 PM   #5
aratis
Member
 
Registered: Oct 2003
Location: Paris, Texas
Distribution: RHEL4
Posts: 48

Original Poster
Rep: Reputation: 15
Thanks a TON! I got it to go through

I had problems switching "init 3". Once I did this the system would hang up while trying to switch the drive/local disk to "read/write mode". I rebooted several times to no avail. Here are the steps I took to get it working:

-I booted to the CentOS installation cd, used F5 to get into the "Linux-Rescue" mode (!! Outstanding Tool btw !!) and switch to "init 5".

-I then rebooted to GNOME as a normal user.

-I opened a terminal window and typed "su root", then the password.

-I then typed "cp /etc/X11/xorg.conf /etc/X11/xorg.conf_old

-Then "gedit /etc/X11/xorg.conf". I commented "dri", replaced "nv" with "nvidia" and saved it as "xorg.conf"

-Rebooted Machine

-System failed to load X Windows system because I changed the "xorg.conf" and loaded the prompt.

-typed "/usr/sbin/setenforce 0"

-typed "yum install kernel-devel" (worked great!)

-typed "sh /home/user_name/Desktop/NVIDIA-**.run"

-installation failed again because "Plug and Play OS" was set to Yes instead of No in my BIOS (who would of guessed)

-rebooted, fixed BIOS, rebooted again

-repeated Setenforce, Yum, SH and everything Installed Great.

-after the installation the installer dumped me back at the command prompt. I then remembered to type "/usr/sbin/setenforce 1" and "reboot"

Once the machine rebooted for the final time everything worked out Great! I don't know what was going on with "init" but that just seemed to hang up every time I swiched it.

So it all came down to BIOS settings. I took the above steps only because it's all I could think of, and because of your (liquidtenmilion) help. I hope this helps someone else out in the future.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Trying to get 1280x800, need kernel source for nvidia driver Zonzhal Linux - Laptop and Netbook 6 03-23-2005 09:16 AM
Error installing nVidia-driver-missing kernel-source? anemic Debian 6 12-17-2004 11:52 AM
Nvidia Driver Kernel Source SparkerR Linux - Hardware 1 09-29-2004 09:29 PM
Nvidia Driver can't find kernel source Forezt Fedora 9 04-20-2004 07:35 PM
Cant locate kernel-source to build my Nvidia driver nyhm Linux - Software 3 02-16-2004 04:48 PM


All times are GMT -5. The time now is 11:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration