LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 07-30-2009, 08:26 AM   #1
sikandar
Member
 
Registered: Aug 2003
Distribution: Linux AS & RH 9
Posts: 255

Rep: Reputation: 30
Installing Firefox 3.5 on Redhat Linux AS 4 steps?


Hi,
I am struggling with installation of Firefox 3.5 on my Linux Redhat 4 update 4 but unable to bring it working.

/home/user/firefox/firefox-bin: error while loading shared libraries: libpango cairo-1.0.so.0: cannot open shared object file: No such file or directory

from where I can get the rpm of all required libs for firefox 3. thanks
 
Old 07-30-2009, 08:35 AM   #2
zQUEz
Member
 
Registered: Jun 2007
Distribution: Fedora, RHEL, Centos
Posts: 294

Rep: Reputation: 53
using the standard RHEL packages, the file libpangocairo-1.0.so.0 is available in packages:
frysk or
evolution28-pango
 
Old 07-30-2009, 10:10 AM   #3
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
1) export LD_LIBRARY_PATH=/usr/evolution28/lib
2) ./firefox

You may need some more libs, please see post # 7 here
http://www.linuxquestions.org/questi...hlight=firefox
( libdbus-1.so.3 , libdbus-glib-1.so.2 )
.....
If you don't want to compile the special dbus files,
click my name, send an email and I will attach a
package to a mail. ( 421 kB ).
.....

Last edited by knudfl; 07-30-2009 at 11:01 AM.
 
Old 07-31-2009, 04:08 PM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Thank you for email.

The package libdbus1-libs-1.1.2-2.noarch.rpm ( really : i386 ) will install the libs to
/usr/evolution28/lib/ \
libdbus-1.so.3 , libdbus-1.so.3.4.0, libdbus-glib-1.so.2 , libdbus-glib-1.so.2.1.0

I have firefox-3.5 installed to /usr/local/ , and have made a link = firefox35
to /usr/local/bin :
cd /usr/local/bin/ , su , password ,
# ln -s ../firefox/firefox firefox35

Then firefox can be started with a script ( firefox )
located in /usr/local/bin/
Code:
#!/bin/bash
export LD_LIBRARY_PATH=/usr/evolution28/lib
exec firefox35

Last edited by knudfl; 07-31-2009 at 04:11 PM.
 
Old 08-01-2009, 02:19 AM   #5
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
From your second email,.. Sat, Aug 1, 2009 at 2:03 AM, quote
Quote:
/usr/local/firefox/firefox-bin: error while loading shared libraries:
libpangocairo-1.0.so.0: cannot open shared object file: No such file
or directory
now please let me know from where I can get the rpm of pango?
Please do this : 1) su
2) yum install evolution28-*
( the star ( * ) is a wild card symbol )
... which will install
evolution28-glib2-2.12.3-6.el4
evolution28-atk-1.12.2-4.el4
evolution28-cairo-1.2.4-6.el4
evolution28-gtk2-2.10.4-22.el4
evolution28-pango-1.14.9-11.el4_7
... all required by firefox-3.x.
.....
 
Old 08-05-2009, 08:05 AM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
An answer to a third email ,
" august 5' , 2009 at 04:27:18 AM "
( which is just a reminder, same question as referred to in # 5.)

Supplementary comments :
.. If you do not pay for support from Redhat, you cannot
use 'yum' or 'up2date' to install packages.

One other choice is to use the identical packages from CentOS :
http://mirror.centos.org/centos/4.7/...6/CentOS/RPMS/
evolution28-glib2-2.12.3-6.el4.i386.rpm
evolution28-atk-1.12.2-4.el4.i386.rpm
evolution28-cairo-1.2.4-6.el4.i386.rpm

http://mirror.centos.org/centos/4.7/updates/i386/RPMS/
evolution28-gtk2-2.10.4-22.el4.i386.rpm
evolution28-pango-1.14.9-11.el4_7.i386.rpm
......

Last edited by knudfl; 08-05-2009 at 08:13 AM.
 
Old 08-05-2009, 11:04 AM   #7
sikandar
Member
 
Registered: Aug 2003
Distribution: Linux AS & RH 9
Posts: 255

Original Poster
Rep: Reputation: 30
I am going to download the rpm from the links provided and also reading the following in order to get yum working,

http://techtrouts.com/how-to-install...prise-linux-4/

Thanks for your cooperation.
 
Old 08-05-2009, 02:40 PM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 13,563

Rep: Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512Reputation: 2512
Well, no Redhat support ....
Then it is much easier to install the free version,
which is CentOS.
The current version is 5.3 ( = Redhat EL 5.3 ).

But then again, the yum solution, ref # 7
will keep you busy for some time...

.....

Last edited by knudfl; 08-05-2009 at 02:41 PM.
 
  


Reply

Tags
evolution28


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing JAVA plugin for Firefox on RedHat / Scientific Linux linder Linux - Software 6 08-02-2010 11:53 AM
DISCUSSION: Installing new accelerated Nvidia Linux Drivers in 5 EASY Steps HolyLiaison LinuxAnswers Discussion 36 03-31-2010 03:41 PM
steps on installing limewire on linux yandy30 Linux - Newbie 4 10-26-2008 04:12 PM
Help installing Firefox on RedHat 6.2! acarri Linux - Distributions 5 01-12-2006 06:11 PM
installing firefox on kde (redhat-7.2) agarwalp Linux - Newbie 1 08-17-2004 01:15 PM


All times are GMT -5. The time now is 02:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration