LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-29-2004, 06:06 PM   #1
srns
LQ Newbie
 
Registered: Sep 2004
Posts: 29

Rep: Reputation: 15
insmod complaint at boot time


Guys,

I have a Redhat 9 with 2.4.28 running.

I noticed a strange thing. I use a third party module (a driver) - say, xxx.o For some time, I didn't wanted it to be loaded. So, I renamed it as old_xxx.o. Upon rebooting, this module GOT loaded (with its new name old_xxx). Then, I moved this file to another folder.

After that, on reboot, it complains at boot time:
insmod: ........ xxx.o
insmod: .......old_xxx.o

saying missing modules or some such thing.


The strange thing is, I don't even have these modules in modules.conf.

Any help is appreciated.

Thanks..
 
Old 01-03-2005, 12:58 AM   #2
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Could be due to various reasons: manually added insmod commands in rc.local, inter-module dependencies within other kernel modules. Try to find out when exactly during the boot process the message is printed.

Quote:
- say, xxx.o
Quote:
saying missing modules or some such thing.
Potential readers of your posting might be able to help if you gave details, such as the actual module name and the full error message.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
insmod for nic card on every boot? darkhorizon Linux - Software 11 09-29-2004 07:47 PM
insmod <module> on boot HTS Programming 3 06-30-2004 11:49 AM
#insmod agpgart during boot santner Linux - Software 2 05-28-2004 10:46 AM
Insmod error on boot. zack3g Mandriva 0 05-13-2004 08:39 PM
boot time insmod error of a non-existing netcard module cyberia_2ooo Slackware 2 07-06-2003 03:51 AM


All times are GMT -5. The time now is 07:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration