LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 03-28-2010, 10:00 PM   #1
the_gripmaster
Member
 
Registered: Jul 2004
Location: VIC, Australia
Distribution: RHEL, CentOS, Ubuntu Server, Ubuntu
Posts: 362

Rep: Reputation: 38
How to set default paper size in RHEL5


It seems every application uses the US Letter as the default paper size in RHEL5. Is there a way A4 can be set as the default paper size in every application?
 
Old 03-28-2010, 11:55 PM   #2
Crowey
Member
 
Registered: Jun 2006
Location: Perth, WA
Distribution: RHEL
Posts: 36

Rep: Reputation: 16
Quote:
Originally Posted by the_gripmaster View Post
It seems every application uses the US Letter as the default paper size in RHEL5. Is there a way A4 can be set as the default paper size in every application?
Out of interest, have you tried setting the Language (under System | Administration | Language) to English (Australia)?

Its been awhile since I've installed a printer, but I always do the above and I *think* my printers default to A4 ...
 
Old 03-29-2010, 12:19 AM   #3
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
Go to the CUPS web interface (localhost://631)---you'll see options to set the defaults for your printers. (I think the behavior you are describing is not OS or applications---it's just how the printers are configured.)
 
Old 03-30-2010, 01:12 AM   #4
the_gripmaster
Member
 
Registered: Jul 2004
Location: VIC, Australia
Distribution: RHEL, CentOS, Ubuntu Server, Ubuntu
Posts: 362

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by Crowey View Post
Out of interest, have you tried setting the Language (under System | Administration | Language) to English (Australia)?

Its been awhile since I've installed a printer, but I always do the above and I *think* my printers default to A4 ...
It was already set to English (Australia).

Quote:
Originally Posted by pixellany View Post
Go to the CUPS web interface (localhost://631)---you'll see options to set the defaults for your printers. (I think the behavior you are describing is not OS or applications---it's just how the printers are configured.)
I could not find any option neither in the web interface nor the system-config-printer utility to specify the paper size.

Is there any other option I can try?
 
Old 03-30-2010, 01:33 AM   #5
pixellany
LQ Veteran
 
Registered: Nov 2005
Location: Annapolis, MD
Distribution: Arch/XFCE
Posts: 17,802

Rep: Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729Reputation: 729
In the web interface:
Manage Printers
Select the desired printer
Under "Administration", select "Set default options". The paper size is under the general category (which appears as the default on my system)
 
Old 03-30-2010, 02:13 AM   #6
Crowey
Member
 
Registered: Jun 2006
Location: Perth, WA
Distribution: RHEL
Posts: 36

Rep: Reputation: 16
Quote:
Originally Posted by the_gripmaster View Post
It was already set to English (Australia).
Cool, I was just checking ... but as far as I know, that should be all that is required.

According to CUPS site (http://www.cups.org/documentation.ph...upsd-conf.html), you can set the default page size (for new printers) in the /etc/cups/cupsd.conf file for CUPS 1.4 - but unfortunately, RHEL 5.4 is only running 1.3.7 ... which doesn't have that setting (you can see that here at http://www.cups.org/documentation.ph...upsd.conf.html)

I know that I just tried setting up a HP LaserJet 4000 series printer on one of my RHEL servers that has English (Australia) as its Default language, and the printer automatically defaulted to A4.

Sorry, that's as much as I've got for you ... will be keen to see what the problem actually is.
 
Old 03-30-2010, 08:57 PM   #7
the_gripmaster
Member
 
Registered: Jul 2004
Location: VIC, Australia
Distribution: RHEL, CentOS, Ubuntu Server, Ubuntu
Posts: 362

Original Poster
Rep: Reputation: 38
Quote:
Originally Posted by pixellany View Post
In the web interface:
Manage Printers
Select the desired printer
Under "Administration", select "Set default options". The paper size is under the general category (which appears as the default on my system)
My web interface is different. Maybe you are using an upgraded version. My version of CUPS is 1.3.7.

Quote:
Originally Posted by Crowey View Post
Cool, I was just checking ... but as far as I know, that should be all that is required.

According to CUPS site (http://www.cups.org/documentation.ph...upsd-conf.html), you can set the default page size (for new printers) in the /etc/cups/cupsd.conf file for CUPS 1.4 - but unfortunately, RHEL 5.4 is only running 1.3.7 ... which doesn't have that setting (you can see that here at http://www.cups.org/documentation.ph...upsd.conf.html)

I know that I just tried setting up a HP LaserJet 4000 series printer on one of my RHEL servers that has English (Australia) as its Default language, and the printer automatically defaulted to A4.

Sorry, that's as much as I've got for you ... will be keen to see what the problem actually is.
I guess you found out the problem. Unfortunately there is no version of cups 1.4 in the RHEL official repository, nor in CentOS
 
  


Reply

Tags
printers


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Gutenprint (Gimp) -- How to change default paper size Herbivore Linux - Software 5 01-07-2010 12:39 PM
Default paper size for new printers arizonagroovejet Linux - General 1 10-23-2009 11:36 PM
Setting default paper size for printing? Dox Systems - Brian Solaris / OpenSolaris 3 02-27-2008 04:16 PM
A Printing Question on default paper size steve_f60 Linux - General 1 08-18-2005 05:36 PM
9.2 refuses to change default paper size! thas Mandriva 0 01-12-2004 10:44 AM


All times are GMT -5. The time now is 06:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration