LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 03-19-2013, 10:04 AM   #1
rushikeshgaradade
LQ Newbie
 
Registered: Mar 2013
Posts: 7

Rep: Reputation: Disabled
how to install rpm files on centos


[root@localhost Downloads]# rpm MySQL-python-1.2.3-0.3.c1.1.el6.x86_64.rpm

i have downloaded above rpm and tried to install as shown above.folowing lines came after when i hit 'ENTER'button. Is it installed or showing something else


RPM version 4.8.0
Copyright (C) 1998-2002 - Red Hat, Inc.
This program may be freely redistributed under the terms of the GNU GPL

Usage: rpm [-aKfgpWHqVcdilsKiv?] [-a|--all] [-f|--file] [-g|--group]
[-p|--package] [-W|--ftswalk] [--pkgid] [--hdrid] [--fileid]
[--specfile] [--triggeredby] [--whatrequires] [--whatprovides]
[--nomanifest] [-c|--configfiles] [-d|--docfiles] [--dump] [-l|--list]
 
Old 03-19-2013, 10:12 AM   #2
netnix99
Member
 
Registered: Jun 2011
Distribution: redhat, CentOS, OpenBSD
Posts: 266

Rep: Reputation: 90
rpm -ivh MySQL-python-1.2.3-0.3.c1.1.el6.x86_64.rpm

-i install (the only one necessary)
-v verbose
-h put hash marks to show status

rpm -Uvh MySQL-python-1.2.3-0.3.c1.1.el6.x86_64.rpm

-U if you are upgrading a package, rather than installing

Last edited by netnix99; 03-19-2013 at 10:15 AM.
 
Old 03-19-2013, 10:15 AM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,415

Rep: Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968Reputation: 1968
that package is a standard CentOS package. as such you shouldn't download it and install it directly. Instead use yum to go fethe it and all it's dependencies automatically:

yum install MySQL-python

Job done

as for what you're actualy specifically asking, you would run

rpm -Uvh MySQL-python-1.2.3-0.3.c1.1.el6.x86_64.rpm

But this isn't a "modern" way to manage standard packages.

You should always check the manpage for any program you don't understand - "man rpm" in this case, and you'd have found plenty of examples in there.
 
1 members found this post helpful.
Old 03-19-2013, 10:22 AM   #4
rushikeshgaradade
LQ Newbie
 
Registered: Mar 2013
Posts: 7

Original Poster
Rep: Reputation: Disabled
Thank You
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Perl RPM Cannot Install on CentOS 6.3 swamprat Linux - Software 3 08-27-2012 07:46 PM
webmin rpm install on centos 5/6 rch Linux - Server 4 07-21-2011 06:17 PM
which RPM should i install for centos 5.4?? h4u General 3 08-01-2010 10:05 AM
CentOS - how to install RPM's? Micro420 Red Hat 3 08-17-2006 11:51 PM


All times are GMT -5. The time now is 02:51 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration