LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 11-22-2011, 07:04 PM   #1
wdli
Member
 
Registered: Sep 2008
Location: California
Posts: 105

Rep: Reputation: 15
How to disable NetworkManager in kickstart?


Hi,

I need to disable NetworkManager in ks. The IP addr is static but somehow NetworkManager always gets in the way to use DHCP. This leads to timeout during ks unattended installations.

How do I disable it in ks file?

I already tried:
%packages
-NetworkManager

This doesn't work.

Thanks.
 
Old 11-22-2011, 10:59 PM   #2
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
I think you're confusing the network configuration during install and after .. are you pulling your ks across the network or is it local (on the install media)?
 
Old 11-23-2011, 08:03 AM   #3
Stealthii
LQ Newbie
 
Registered: Nov 2011
Posts: 1

Rep: Reputation: Disabled
I have a similar problem. I wish to disable NetworkManager for the installed system, but I believe OP wants NetworkManager to be disabled during installation, which I'm not sure is possible (due to the nature of an installation process)
 
Old 11-23-2011, 04:46 PM   #4
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
The 'network' line in the kickstart file will determine the network configuration during and after installation, but if you don't provide all the information for a static configuration the install will use dhcp. You can override the kickstart configuration by providing arguments to anaconda in the boot options, for example the following will perform the inastallation with a static address :-

Code:
linux ksdevice=eth0 ip=x.x.x.x netmask=x.x.x.x gateway=x.x.x.x dns=x.x.x.x ks=http://...
.. even if I have this in my kickstart:

Code:
network --bootproto dhcp
You have to find the right balance between flexibility and automation, also please keep in mind that kickstart options are always changing/improving so you should read the doco matching your installation version.
 
Old 11-24-2011, 10:23 AM   #5
wdli
Member
 
Registered: Sep 2008
Location: California
Posts: 105

Original Poster
Rep: Reputation: 15
Thanks kbp. I think that's what I wanted. I used virt-install to install a VM via http and the problem is gone once I put these arguments as -x option in virt-install.

However another problem: now I have to manually start the network service after reboot, ie., I have to do "service network start" to bring up the interface. This happens even everything in /etc/sysconfig/network-scripts/ifcfg-eth0 was configured correctly by ks during the install. Any ideas?
 
Old 11-28-2011, 05:43 PM   #6
kbp
Senior Member
 
Registered: Aug 2009
Posts: 3,758

Rep: Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644Reputation: 644
What does 'chkconfig --list network' say ? .. if it's on, then grep through /var/log/boot.log or /var/log/messages for 'eth'
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable NetworkManager keith2045 Linux - Networking 10 10-17-2012 10:43 AM
centos - disable LVM via kickstart draeath Linux - Server 6 12-14-2010 10:04 AM
Kickstart Error Error opening kickstart file (null): bad address Latitude Linux - Networking 0 06-03-2009 12:20 PM
how to skip NetworkManager in kickstart ? vdx Fedora 1 03-21-2009 11:35 AM
dbx command for corrosponding commands disable or disable on gdb bshankha AIX 0 09-26-2006 10:38 AM


All times are GMT -5. The time now is 08:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration