LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   How to disable NetworkManager in kickstart? (http://www.linuxquestions.org/questions/red-hat-31/how-to-disable-networkmanager-in-kickstart-914978/)

wdli 11-22-2011 06:04 PM

How to disable NetworkManager in kickstart?
 
Hi,

I need to disable NetworkManager in ks. The IP addr is static but somehow NetworkManager always gets in the way to use DHCP. This leads to timeout during ks unattended installations.

How do I disable it in ks file?

I already tried:
%packages
-NetworkManager

This doesn't work.

Thanks.

kbp 11-22-2011 09:59 PM

I think you're confusing the network configuration during install and after .. are you pulling your ks across the network or is it local (on the install media)?

Stealthii 11-23-2011 07:03 AM

I have a similar problem. I wish to disable NetworkManager for the installed system, but I believe OP wants NetworkManager to be disabled during installation, which I'm not sure is possible (due to the nature of an installation process)

kbp 11-23-2011 03:46 PM

The 'network' line in the kickstart file will determine the network configuration during and after installation, but if you don't provide all the information for a static configuration the install will use dhcp. You can override the kickstart configuration by providing arguments to anaconda in the boot options, for example the following will perform the inastallation with a static address :-

Code:

linux ksdevice=eth0 ip=x.x.x.x netmask=x.x.x.x gateway=x.x.x.x dns=x.x.x.x ks=http://...
.. even if I have this in my kickstart:

Code:

network --bootproto dhcp
You have to find the right balance between flexibility and automation, also please keep in mind that kickstart options are always changing/improving so you should read the doco matching your installation version.

wdli 11-24-2011 09:23 AM

Thanks kbp. I think that's what I wanted. I used virt-install to install a VM via http and the problem is gone once I put these arguments as -x option in virt-install.

However another problem: now I have to manually start the network service after reboot, ie., I have to do "service network start" to bring up the interface. This happens even everything in /etc/sysconfig/network-scripts/ifcfg-eth0 was configured correctly by ks during the install. Any ideas?

kbp 11-28-2011 04:43 PM

What does 'chkconfig --list network' say ? .. if it's on, then grep through /var/log/boot.log or /var/log/messages for 'eth'


All times are GMT -5. The time now is 11:07 PM.