LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 01-28-2010, 10:54 AM   #1
ocalld
LQ Newbie
 
Registered: Dec 2009
Posts: 5

Rep: Reputation: 0
Question How to disable DHCP client requests on rhel 5.4 64bit


Hi

i want to disable all DHCP request, can i turn off the client so that if a MAC address changes a dhcp request is not automatically made?

reason for this:
I have HP blade running with an Intel NC260M mezzanine card running with virtual connect. I have experienced problems with firmware levels with this card where the virtual connect mac address is ignored and the real MAC displayed. As we are using bonds on the servers and have 6 NICs installed we have to tie down the MAC address to a bond.
A blade was replaced today without the firmware update and the real MAC appeared, a dhcp request was made and my ifcfg-eth[2-3] and resolv.conf files were over-written by the dhcp supplied.
I want to ensure that my files remain unchanged even if a MAC address is changed.

Thanks
Dan.
 
Old 01-29-2010, 09:45 AM   #2
willl_d
LQ Newbie
 
Registered: May 2007
Location: Vienna, VA
Distribution: RHEL, Fedora, Ubuntu, AIX, Mint, Solaris
Posts: 14

Rep: Reputation: 1
shouldn't your ifcfg-eth[2,3] look something like this?

DEVICE=eth2
BOOTPROTO=none <----will stop it from requesting address via DHCP
MASTER=bondname
SLAVE=yes
USERCTL=no

And your bond should be

DEVICE=bondname
BOOTPROTO=static <--will also stop the dhcp client from requesting an address.
HWADDR=some mac address...
IPADDR=whatever
NETMASK=whatever
GATEWAY=whatever

You didn't mention a distro, so I'm talking RHEL here..
 
Old 01-30-2010, 08:27 AM   #3
ocalld
LQ Newbie
 
Registered: Dec 2009
Posts: 5

Original Poster
Rep: Reputation: 0
Hi
Thanks for the reply.

We have the MAC addresses in the ifcfg-eth[0-5] files.
Two of the nics we have use the e1000e driver which causes the nics to come up in a random order on every reboot, so to control the order for 3 different bonds we have to tie down the mac address.

It's the mac address that causes the problem. If for any reason it changes, RHEL detects the new mac address and, changes the ifcfg-eth3 to ifgcfg-eth3.bak and instigates a dhcp request.

Just to confirm, this is RHEL 5.4 64bit
Thanks
Dan



Quote:
Originally Posted by willl_d View Post
shouldn't your ifcfg-eth[2,3] look something like this?

DEVICE=eth2
BOOTPROTO=none <----will stop it from requesting address via DHCP
MASTER=bondname
SLAVE=yes
USERCTL=no

And your bond should be

DEVICE=bondname
BOOTPROTO=static <--will also stop the dhcp client from requesting an address.
HWADDR=some mac address...
IPADDR=whatever
NETMASK=whatever
GATEWAY=whatever

You didn't mention a distro, so I'm talking RHEL here..

Last edited by ocalld; 01-30-2010 at 08:29 AM.
 
Old 01-30-2010, 12:17 PM   #4
DrLove73
Senior Member
 
Registered: Sep 2009
Location: Srbobran, Serbia
Distribution: CentOS 5.5 i386 & x86_64
Posts: 1,118
Blog Entries: 1

Rep: Reputation: 129Reputation: 129
What about setting config files read-only?

Also, have you tried drivers from ELRepo?

They compile kernel modules that are missing in CentOS and are binary compatible with RHEL.
 
  


Reply

Tags
dhcp


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I resolve install DB2v9.5 64bit/RHEL 5 64bit (libstdc++.so.5 is not found)? okonita Linux - Newbie 2 11-13-2008 03:15 AM
DHCP requests - OpenSuSE 11.0 Dan_D Suse/Novell 5 08-28-2008 04:05 AM
how do i disable DHCP client in solaris9? a.toraby Solaris / OpenSolaris 3 04-15-2008 08:09 AM
dhcp client requests a new address every time EdoardoC Linux - Networking 6 02-02-2005 06:02 PM
blocking DHCP requests jjfate Linux - Networking 4 06-20-2003 02:49 PM


All times are GMT -5. The time now is 03:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration