LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   How to disable DHCP client requests on rhel 5.4 64bit (http://www.linuxquestions.org/questions/red-hat-31/how-to-disable-dhcp-client-requests-on-rhel-5-4-64bit-785371/)

ocalld 01-28-2010 09:54 AM

How to disable DHCP client requests on rhel 5.4 64bit
 
Hi

i want to disable all DHCP request, can i turn off the client so that if a MAC address changes a dhcp request is not automatically made?

reason for this:
I have HP blade running with an Intel NC260M mezzanine card running with virtual connect. I have experienced problems with firmware levels with this card where the virtual connect mac address is ignored and the real MAC displayed. As we are using bonds on the servers and have 6 NICs installed we have to tie down the MAC address to a bond.
A blade was replaced today without the firmware update and the real MAC appeared, a dhcp request was made and my ifcfg-eth[2-3] and resolv.conf files were over-written by the dhcp supplied.
I want to ensure that my files remain unchanged even if a MAC address is changed.

Thanks
Dan.

willl_d 01-29-2010 08:45 AM

shouldn't your ifcfg-eth[2,3] look something like this?

DEVICE=eth2
BOOTPROTO=none <----will stop it from requesting address via DHCP
MASTER=bondname
SLAVE=yes
USERCTL=no

And your bond should be

DEVICE=bondname
BOOTPROTO=static <--will also stop the dhcp client from requesting an address.
HWADDR=some mac address...
IPADDR=whatever
NETMASK=whatever
GATEWAY=whatever

You didn't mention a distro, so I'm talking RHEL here..

ocalld 01-30-2010 07:27 AM

Hi
Thanks for the reply.

We have the MAC addresses in the ifcfg-eth[0-5] files.
Two of the nics we have use the e1000e driver which causes the nics to come up in a random order on every reboot, so to control the order for 3 different bonds we have to tie down the mac address.

It's the mac address that causes the problem. If for any reason it changes, RHEL detects the new mac address and, changes the ifcfg-eth3 to ifgcfg-eth3.bak and instigates a dhcp request.

Just to confirm, this is RHEL 5.4 64bit
Thanks
Dan



Quote:

Originally Posted by willl_d (Post 3844898)
shouldn't your ifcfg-eth[2,3] look something like this?

DEVICE=eth2
BOOTPROTO=none <----will stop it from requesting address via DHCP
MASTER=bondname
SLAVE=yes
USERCTL=no

And your bond should be

DEVICE=bondname
BOOTPROTO=static <--will also stop the dhcp client from requesting an address.
HWADDR=some mac address...
IPADDR=whatever
NETMASK=whatever
GATEWAY=whatever

You didn't mention a distro, so I'm talking RHEL here..


DrLove73 01-30-2010 11:17 AM

What about setting config files read-only?

Also, have you tried drivers from ELRepo?

They compile kernel modules that are missing in CentOS and are binary compatible with RHEL.


All times are GMT -5. The time now is 01:05 AM.