LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 06-17-2004, 09:57 PM   #1
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Rep: Reputation: 52
How to close a corrupted window


Hi folks,

RH 8.0
KDE desktop
Login as USER

A corrupted windown namely 'URL-fax - Kate' is running which can be shrinked as icon but can't be closed.

Contol Center -> Personalization - Session Manager
Under General
uncheck "Save session for future login"
Applied

having no function.

Relogin as USER, the said corrupted window popup again. Kindly advise how to fix it.

TIA

B.R.
satimis
 
Old 06-17-2004, 10:16 PM   #2
dopefish
Member
 
Registered: Nov 2003
Location: Northcliffe, WA
Distribution: Slackware 12.0
Posts: 481

Rep: Reputation: 30
Kill the task then login again, find the task with ps then kill it with kill or type xkill and click on the window.
 
Old 06-17-2004, 11:30 PM   #3
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Quote:
Originally posted by dopefish
Kill the task then login again, find the task with ps then kill it with kill or type xkill and click on the window.
Hi dopefish,

Tks for your advice. Steps taken as follows;

KDE desktop
Login as USER
Start Konsole window

1)
$ ps ax
....
15163 ? S 0:00 kdeinit: kate -session 117f00000100010518130870000001
15165 ? S 0:00 kalarmd -session 117f00000100010518127460000001871000
15168 ? S 0:00 kdeinit: kio_file file /tmp/ksocket-satimis/klauncher
.......

$ kill 15163
(the corrupted window closed immediately)

$ find ~/kde/* -name kate
find: /home/satimis/kde/*: No such file or directory

logou and relogin
The corrupted window "URL-fax - Kate" popup again

Also tried "su -" on Konsole window with the same result


2)
$ xkill -all
Select the root window with button 1....

It hung here

B.R.
satimis
 
Old 06-17-2004, 11:43 PM   #4
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
On your find command it's .kde it's a hidden directory
 
Old 06-18-2004, 12:37 AM   #5
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Quote:
Originally posted by darthtux
On your find command it's .kde it's a hidden directory
Hi darthtux,

Tried again.

$ ps ax
.......
$ kill 15843
(the corrupted window closed)

$ find ~/.kde/* -name kate
No printout

Logout and relogin the corrupted window came back again

B.R.
satimis
 
Old 06-18-2004, 12:51 AM   #6
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
If kate has a file in that directory, looking for it with find the way you've done above requires an exact match.

Try
find ~/.kde -name kate*
 
Old 06-18-2004, 02:33 AM   #7
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Quote:
Originally posted by darthtux
If kate has a file in that directory, looking for it with find the way you've done above requires an exact match.

Try
find ~/.kde -name kate*
Hi,

$ find ~/.kde -name kate*
/home/satimis/.kde/share/config/katesyntaxhighlightingrc
/home/satimis/.kde/share/config/katesessionrc
/home/satimis/.kde/share/config/katerc
/home/satimis/.kde/share/config/katepluginrc
/home/satimis/.kde/share/services/katepart.desktop
/home/satimis/.kde/share/apps/RecentDocuments/kate-040618.desktop
/home/satimis/.kde/share/apps/RecentDocuments/kate-040618a.desktop
/home/satimis/.kde/share/apps/RecentDocuments/kate-040618[2].desktop

B.R.
satimis
 
Old 06-18-2004, 01:14 PM   #8
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Remove the ones in the config directory. They will be recreated when you restart kate.
 
Old 06-18-2004, 09:13 PM   #9
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Quote:
Originally posted by darthtux
Remove the ones in the config directory. They will be recreated when you restart kate.
Hi darthtux,

Whether you suggested to remove all following files
Quote:
/home/satimis/.kde/share/config/katesyntaxhighlightingrc
/home/satimis/.kde/share/config/katesessionrc
/home/satimis/.kde/share/config/katerc
/home/satimis/.kde/share/config/katepluginrc
TIA

B.R.
satimis
 
Old 06-18-2004, 09:43 PM   #10
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Yes, you won't hurt anything
 
Old 06-21-2004, 12:43 PM   #11
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Quote:
Originally posted by darthtux
Yes, you won't hurt anything
Hi darthtux,

It looks a little bid funny to me.

I removed following files

/home/satimis/.kde/share/config/katesyntaxhighlightingrc
/home/satimis/.kde/share/config/katesessionrc
/home/satimis/.kde/share/config/katerc
/home/satimis/.kde/share/config/katepluginrc

logout and relogin

The Kate window still came back. This time it was a full window, i.e. 'Kate' started automatically. It can be closed manually

$ find ~/.kde -name kate*
/home/satimis/.kde/share/config/katesyntaxhighlightingrc
/home/satimis/.kde/share/config/katesessionrc
/home/satimis/.kde/share/config/katerc
/home/satimis/.kde/share/services/katepart.desktop
/home/satimis/.kde/share/apps/RecentDocuments/kate-040618.desktop
/home/satimis/.kde/share/apps/RecentDocuments/kate-040618a.desktop
/home/satimis/.kde/share/apps/RecentDocuments/kate-040618[2].desktop

They were still there only /home/satimis/.kde/share/config/katepluginrc' missing.

I repeated 3 times and still found the same. 'Kate' started automatically on login.

B.R.
satimis
 
Old 06-21-2004, 01:08 PM   #12
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Deleting the files just made it where you can now close it. The problem there was a corrupted config file. As far as preventing it from starting at startup, I can't help you there. I don't use KDE. You might try looking through the K menu for a save session.
 
Old 06-21-2004, 09:20 PM   #13
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Quote:
Originally posted by darthtux
Deleting the files just made it where you can now close it. The problem there was a corrupted config file. As far as preventing it from starting at startup, I can't help you there. I don't use KDE. You might try looking through the K menu for a save session.
Hi Darthtux,

Control Center -> Personalization -> Session Manager
leaving "Save Session for Future Login" unchecked without function.

A folk on a mailing list suggested to delete "/.kde" completely. I hesitate to proceed.

Anyway lot of thanks for your advice and time spent.

B.R.
satimis
 
Old 06-21-2004, 10:30 PM   #14
darthtux
Senior Member
 
Registered: Dec 2001
Location: 35.7480 N, 95.3690 W
Distribution: Debian, Gentoo, Red Hat, Solaris
Posts: 2,070

Rep: Reputation: 45
Always glad to help

Well deleting ~/.kde will cause kate not to start when kde does. The reason I didn't suggest that is that will remove all configurations for KDE that you have made. So proceed with caution.

Having said that, if you don't mind resetting your colors, wallpaper, desktop icons, etc. Then
rm -rf ~/.kde

But first I would browse through the directory and delete any files with session in the name. This may fix the problem.
 
Old 06-21-2004, 11:13 PM   #15
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,385

Original Poster
Rep: Reputation: 52
Hi darthtux,

I found the trick.

On
Control Center -> Personalization -> Session Manager
CHECK
"Save Session for Future Login"

logout and relogin KDE
Kate did not start

It is strange to me. "Save Session for Future Login" works reversely.

Tks again for your advice.

B.R.
satimie
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why NOT this Tiny Window Close ? bedi-beparwah Suse/Novell 2 06-19-2005 05:04 AM
Javascript - what to use rather than window.close() then window.open() davee Programming 2 04-11-2005 08:28 AM
X crashes when i close a window slackinblack Linux - Software 1 12-05-2004 09:32 AM
close a window with script box_l Programming 0 07-27-2004 07:57 AM
DC++ problem in WINE. Settings window corrupted. bastupungen Linux - Software 6 02-26-2004 12:21 PM


All times are GMT -5. The time now is 10:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration