LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 03-22-2012, 06:27 AM   #1
ashwin_cse
Member
 
Registered: Jul 2004
Distribution: arch, rhel
Posts: 132

Rep: Reputation: 21
How to change the format of date in thunderbird in rhel 5.8


Hi,

I am using rhel 5.8 64 bit. I have thunderbird 10.0.3 . I have language set to english india. LANG=en_IN.UTF-8 .I set the language through system-config-language . original it was en_US.UTF-8. it showed date in mm/dd/yy format in thunderbird. I wanted it to show in dd/mm/yy format. Since india uses this format. i though changing language to in english india will fix the problem. But now i get the date in format like 'friday 16 march 2012 03:50 PM'. So i think english_in is not good and is not mature enough. How do i fix this to get date in thunderbird to display as 16/02/2012 03:50PM.

with regards,
ashwin
 
Old 03-24-2012, 03:10 AM   #2
vaettchen
LQ Newbie
 
Registered: Oct 2010
Location: Bonn, Germany
Distribution: Sabayon
Posts: 3

Rep: Reputation: 0
Try LANG=en_UK.UTF-8
 
Old 03-28-2012, 02:53 AM   #3
ashwin_cse
Member
 
Registered: Jul 2004
Distribution: arch, rhel
Posts: 132

Original Poster
Rep: Reputation: 21
Quote:
Originally Posted by vaettchen View Post
Try LANG=en_UK.UTF-8
I tried system-config-language and choose Great Britain. and that solved the problem. Now i am afraid if there any side effects of this. So far so good.
 
Old 03-28-2012, 08:05 AM   #4
David the H.
Bash Guru
 
Registered: Jun 2004
Location: Osaka, Japan
Distribution: Debian sid + kde 3.5 & 4.4
Posts: 6,823

Rep: Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947Reputation: 1947
Two more points that may help you.


1) You can prefix an individual command with a variable setting, to have that setting only affect that process.

2) In this case you don't need to set the overall LANG variable. It's the LC_TIME variable that controls the date format in thunderbird.

So try launching TB with the command like this:
Code:
LC_TIME=en_UK.UTF-8 thunderbird
Make sure that the desired locale is available on your system first, of course.


More on the time format in TB here:
http://kb.mozillazine.org/Date_display_format
 
1 members found this post helpful.
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] How do I change the System Date format to DD/MM/YYYY on RHEL Workstatio 6.1 skinutter Linux - Newbie 3 09-28-2011 08:07 AM
Thunderbird date-format problem jadukor Slackware 5 05-07-2008 02:03 PM
Thunderbird Date Format dotancohen Linux - Software 9 10-15-2005 02:55 PM
All I want to do is change the date format... Slycordinator Linux - General 5 12-11-2003 01:27 AM


All times are GMT -5. The time now is 07:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration