LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 10-17-2003, 02:57 AM   #1
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Rep: Reputation: 15
How do I resolve "db4 error(16) from dbenv->remove"?


Trying to install alsa drivers. At the prompt I'm entering:
$ rpm --rebuilddb alsa-driver-...-.src.rpm

and my good friend linux returns:
error: db4 error(16) from dbenv->remove: Device or resource busy

Hmm. I'm running Red Hat 9. Trying to get a SB 16 PCI soundcard to work.

Been attacking this for a while. Have read about a bug attached to this error, but I want to be sure. If I am the prey of a bug, I'd appreciate some specific info on what to do so that I can run "rpm --rebuilddb" in the future.

I am very green in all-things-Linux, so help would be BIG. Been banging the head against the wall on this one for quite a while--thought I could work around it. Yeah, right.
 
Old 10-17-2003, 09:17 AM   #2
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Original Poster
Rep: Reputation: 15
Bump.

My kernel is 20.4.20-8. I'm wondering if I should upgrade my kernel to 20.4.20-20.9. Worried that that might just introduce new problems.

Anybody know anything about this error in these circumstances at all?
 
Old 10-17-2003, 10:24 AM   #3
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Quote:
error: db4 error(16) from dbenv->remove: Device or resource busy
It's a harmless albeit annoying bug. Ignore it.

http://bugzilla.redhat.com/bugzilla/...g.cgi?id=83281

Quote:
$ rpm --rebuilddb alsa-driver-...-.src.rpm
This command makes no sense at all.
 
Old 10-17-2003, 11:33 AM   #4
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Original Poster
Rep: Reputation: 15
Thanks, misc.

And maybe the command looks weird b/c I abbreviated the .src.rpm filename with an ellipsis. Everything else about it should be good, though--I got it directly from the doc that was telling me what to do, and if it were nonsensical I wouldn't have returned an error, right? Who knows.

I'll keep at it. Thanks again.
 
Old 10-17-2003, 12:10 PM   #5
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
Quote:
And maybe the command looks weird b/c I abbreviated the .src.rpm filename with an ellipsis.
No. The command is pure nonsense. It is a mixture of rpmbuild --rebuild foo*.src.rpm and rpm --rebuilddb.
Quote:
and if it were nonsensical I wouldn't have returned an error, right? Who knows.
No. It just accepted the first argument and ignored the src.rpm filename.
 
Old 10-17-2003, 01:35 PM   #6
dot hog
Member
 
Registered: Oct 2003
Location: Boondocks USA
Distribution: RH9
Posts: 50

Original Poster
Rep: Reputation: 15
Wow. That's some solid advice. Fault me for sticking to bad documentation--instead of going on a bug/kernel update hunt, I should've taken 2 minutes to question the command itself.

Used the rpmbuild and compiled some rpms right quick. I'm back on the path to sanity!

Thanks for the HUGE dope slap, misc.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
k3b: "error decoding audio tracks" and "could not unlock cd driver" lefty.crupps Linux - Software 7 10-13-2005 12:29 PM
"mythtv-setup" giving "Session management error: Authentication Rejected" Mitchua Ubuntu 0 10-09-2005 05:32 PM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 01:49 PM
"Can't resolve mount point ..." - Mandrake 9.2 to WinXP host funcii Linux - Newbie 3 02-27-2004 02:17 PM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 04:31 PM


All times are GMT -5. The time now is 12:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration