LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 04-18-2009, 03:27 PM   #1
bala_adi
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Rep: Reputation: 0
How can i solve this error?


error: Failed dependencies:
glibc-common = 2.5-34 is needed by (installed) glibc-2.5-34.i686
I really need to install the following package:
glibc-common-2.9-3.i386
 
Old 04-18-2009, 03:49 PM   #2
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Which version of Fedora are you using. You may be so far behind the 8 ball it is time to install a newer version. Glibc is the C library that everything uses. Going from 2.5 to 2.9 you are probably using a non-supported version of the distro.
 
Old 04-18-2009, 06:08 PM   #3
John VV
Guru
 
Registered: Aug 2005
Posts: 12,094

Rep: Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583
bala_adi seeing as this is in the Red Hat section and your glibc is 2.5-34
Are you running rehl 4 . If so you can NOT install the glibc-common-2.9-3.i386.rpm it WILL KILL the rhel 4 OS

two thinge
1) install RHEL 5.3 ( CentOS 5.3)
2) build the new glib from source BUT DO NOT INSTALL IT IN THE SYSTEM PATH
install it to some place like
/usr/local/Glib-2.9-3

then build from source the program that needs it and point " ./configure" or the "Makefile" to
-I/usr/local/Glib-2.9-3/include
-L/usr/local/Glib-2.9-3/lib
and point package config to the /usr/local/Glib-2.9-3/lib/pkgconfig

and a bunch of other things too will need to know where "/usr/local/Glib-2.9-3" is
BUT NOT THE OPERATING SYSTEM if rhel4 starts to use the new glib it WILL BREAK THINGS
 
Old 04-19-2009, 12:23 PM   #4
bala_adi
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Original Poster
Rep: Reputation: 0
First i would like to thank you for your answers.
Secondly i use Red Hat Enterprise Linux 5.3
2.6.18-128.el5
 
Old 04-19-2009, 02:24 PM   #5
John VV
Guru
 
Registered: Aug 2005
Posts: 12,094

Rep: Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583Reputation: 1583
well you will have to build glibc 2.9-3 from the source . What needs it ?
 
Old 04-25-2009, 09:26 AM   #6
bala_adi
LQ Newbie
 
Registered: Apr 2009
Posts: 3

Original Poster
Rep: Reputation: 0
I tried to build it from source but at this moment is quite difficult for me so I let someone i know to help me. Thanks for your replies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Compilation: Solve The Error mohit.saha Linux - Newbie 1 03-06-2008 06:52 AM
Error: Dns can't solve ..... Dude101 Feather 5 01-27-2008 04:56 PM
How to solve this Error message jmfa59 Linux - Newbie 3 07-03-2007 08:32 AM
rpmDB error - How to solve problem? arindom Linux - Desktop 2 12-25-2006 06:06 AM
Mandrake Move 10. Error I can't solve... dturetsky Linux - Newbie 2 03-17-2005 08:45 PM


All times are GMT -5. The time now is 07:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration