LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 04-15-2004, 06:35 PM   #1
rylan76
Senior Member
 
Registered: Apr 2004
Location: Potchefstroom, South Africa
Distribution: Fedora 17 - 3.3.4-5.fc17.x86_64
Posts: 1,477

Rep: Reputation: 87
GNU autotools in Rh 9 broken? Worked fine in 7.3...


Hi all

I am having problems compiling apache, mysql, samba and php on my new RedHat 9 install. I compiled these no problems on Rh7.3, but trying to configure the same packages on RedHat 9 produces a string of errors (a whole page's worth - complaints about missing macros and other errors.)

I already tried doing aclocal;autoconf;automake in the above packages' source directories, but even aclocal generates several errors, so logically, neither autoconf nor automake will work.

What is going on with Rh9? Why do these packages configure/compile perfectly on Rh7.3, but in Rh9 they are ALL broken?

How can I fix this? Can I "downgrade" my GNU autotools to back to Rh7.3 without breaking Rh9? Can I even use Rh7.3 autotools on Rh9?

Thanks!
 
Old 04-17-2004, 03:27 PM   #2
misc
Senior Member
 
Registered: Apr 2003
Distribution: Red Hat + Fedora
Posts: 1,074

Rep: Reputation: 53
For compatibility, Red Hat Linux 9 provides older versions of the tools in packages with different names, such as automake14 and autoconf213. You may need to install these and run the tools with their different file names, e.g. automake-1.4, autoconf-2.13
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot compile my program anymore (autotools, gnu make) sterrenkijker Programming 5 07-27-2006 05:52 AM
Using GNU autotools properly MadCactus Linux - Software 0 08-19-2004 08:36 AM
Sound worked fine during installation, but not after... Shekers Linux - Hardware 3 05-31-2004 07:16 PM
Redhat 9's autotools broken for apache, mysql, php? rylan76 Linux - Software 0 04-15-2004 04:48 PM
Gnu Autotools jinksys Programming 0 10-08-2003 01:26 AM


All times are GMT -5. The time now is 12:53 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration