LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 02-26-2004, 03:25 PM   #1
AZIMBD03
Member
 
Registered: Oct 2003
Location: Dhaka,Bangladeh
Distribution: Red Hat
Posts: 80

Rep: Reputation: 15
Unhappy GNOME desktop to Command promt???


Hi

recently I have installed rh 8.0 and I am using GNOME desktop mode...how I can turn into command promt at booting time????



Bugle
 
Old 02-26-2004, 03:47 PM   #2
320mb
Senior Member
 
Registered: Nov 2002
Location: pikes peak
Distribution: Slackware, LFS
Posts: 2,577

Rep: Reputation: 47
In Slackware the file is......./etc/inittab
Code:
#Default runlevel.
id:3:initdefault:
this should boot you to CLI instead of Gnome..........

Code:
id:4:initdefault:
the above will boot you into KDE/Gnome, whatever your default window manager is........

Last edited by 320mb; 02-26-2004 at 03:51 PM.
 
Old 02-26-2004, 11:03 PM   #3
jong357
Senior Member
 
Registered: May 2003
Location: Columbus, OH
Distribution: DIYSlackware
Posts: 1,914

Rep: Reputation: 52
5 is ussually the GUI mode... Theres some commented out stuff normally above the line that you change... It should tell you what number to put... Slack is a little different in that regard. I boot so many distro's, I can never give specific help unless I boot into that OS... But yea, thats the right of it. Change the 5 to a 3 in the last line below and save....

This is a snip from Redhat: I use init3 but changed it to look like yours. Hmmm. Try changing it to 6... That would be annoying.

# Default runlevel. The runlevels used by RHS are:
# 0 - halt (Do NOT set initdefault to this)
# 1 - Single user mode
# 2 - Multiuser, without NFS (The same as 3, if you do not have networking)
# 3 - Full multiuser mode
# 4 - unused
# 5 - X11
# 6 - reboot (Do NOT set initdefault to this)
#
id:5:initdefault:

Last edited by jong357; 02-26-2004 at 11:08 PM.
 
Old 02-27-2004, 02:54 AM   #4
AZIMBD03
Member
 
Registered: Oct 2003
Location: Dhaka,Bangladeh
Distribution: Red Hat
Posts: 80

Original Poster
Rep: Reputation: 15
Yes you are right run level 5 is GUI mode and i have changed it to 3 for multi user mode....but here is another proble i have got....in multi user mode the text of the window is not so bright...how i can make the text more bright????


Please help me


Blues
 
Old 03-02-2004, 09:08 AM   #5
markkreuzz
Member
 
Registered: Feb 2004
Location: Asia
Distribution: rh09, Gentoo,slackware.., still serving BSD
Posts: 35

Rep: Reputation: 15
hello,
try adjusting bright setting in monitor manually.

Im also wanting to know how to get to runlevel 3 when
in runlevel 5 (GUImode)...
 
Old 03-02-2004, 09:26 AM   #6
AZIMBD03
Member
 
Registered: Oct 2003
Location: Dhaka,Bangladeh
Distribution: Red Hat
Posts: 80

Original Poster
Rep: Reputation: 15
Wink

Yes I have done it already even then thanks for your advice.

Oh its very easy to get run level 3 from run level 5

First time i was in GNOME desktop then i Just clik the right button on desktop and go to "new terminal"

just type vi /etc/inittab

and I edit the following line.you should just replace 5(GUI mode) with 3(Full multi user text mode)

id:5:initdefault:


Blues
 
Old 03-03-2004, 10:13 AM   #7
markkreuzz
Member
 
Registered: Feb 2004
Location: Asia
Distribution: rh09, Gentoo,slackware.., still serving BSD
Posts: 35

Rep: Reputation: 15
hello,

i also find a way to do it much better without editing etc/inittab.
i just typed at command prompt
$init 3
and i was logout in X and now in the darkness again.
i hope this helps and others too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Loss of desktop functionality after setting new desktop from firefox in fc2/gnome. dr_zayus69 Linux - Software 3 03-09-2005 09:29 AM
how can i read pdf in command promt? hansi umayangan Linux - Software 1 09-04-2004 06:19 AM
Command Promt nerofiend Linux - Newbie 6 03-02-2004 04:55 PM
Command promt question lozz1978 Linux - Newbie 4 02-18-2004 12:02 PM
how to browse files from command promt snoop24 Linux - Newbie 2 09-15-2003 11:28 AM


All times are GMT -5. The time now is 02:58 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration