LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 03-16-2008, 01:03 AM   #1
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Rep: Reputation: 0
Unhappy Fresh install...but no internet


I just put Red Hat ES on the computer next to me. I have a DSL modem that connects to a router to 3 computers (all of which were windows xp up until an hour ago). When this computer had windows it connected just fine to the internet along with the others, now that I have converted it to linux. It does not seem to get any internet connectivity. I am very new to linux, and the reason i installed it was to learn it. Having this problem alone will help me familiarize myself more with linux more. Thank you for taking the time to read this, and please remember i really am very new to linux and dont really know anything, so details are very welcome . if you need to know any more information just ask.
 
Old 03-16-2008, 01:24 AM   #2
AceofSpades19
Senior Member
 
Registered: Feb 2007
Location: Chilliwack,BC.Canada
Distribution: Slackware64 -current
Posts: 2,079

Rep: Reputation: 57
Is the router wireless, or wired?
 
Old 03-16-2008, 03:51 AM   #3
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I assume this is a wired Cable/DSL NAT router. Most likely you didn't opt to use DHCP so your hosts don't have the gateway & dns addresses they need to reach the internet.

To check the IP address:
/sbin/ifconfig

To check the default gateway:
/sbin/route

To check the name server (DNS) addresses:
cat /etc/resolv.conf
 
Old 03-16-2008, 10:48 AM   #4
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Original Poster
Rep: Reputation: 0
sorry, it is wired, its a westell DSL 6.0 that goes to a netgear router.


i typed in the commands that you said, and this is what i got back. (no idea how to use this information to help me get internet lol)

/sbin/ifconfig:

Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU: 16436 Metric:1
RX packets: 2091 errors:0 dropped:0 overruns:0 frame:0
TX packets: 2091 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:2712177 (2.5 MiB) TX bytes:2712177 (2.5 MiB)

/sbin/route

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface

cat /etc/resolv.conf didnt do anything. it just opened up another terminal line as if i hadnt even typed it.

As far as i know i havent setup anything with DHCP. How would i go about doin that to check if this will resolve the issue.
 
Old 03-17-2008, 08:01 AM   #5
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Post the output of "/sbin/lspci -v" and "/sbin/lspci -n". You don't have any NIC device.
You just need to post the part with the controller:
Code:
...
00:0f.0 IDE interface: nVidia Corporation MCP51 Serial ATA Controller (rev a1)
00:10.0 PCI bridge: nVidia Corporation MCP51 PCI Bridge (rev a2)
00:10.1 Audio device: nVidia Corporation MCP51 High Definition Audio (rev a2)
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
00:18.0 Host bridge: Advanced Micro Devices [AMD] K8 [Athlon64/Opteron] HyperTransport Technology Configuration
...
/sbin/lspci -v | sed -n '/00:14.0/,/^$/p'
00:14.0 Bridge: nVidia Corporation MCP51 Ethernet Controller (rev a3)
        Subsystem: Hewlett-Packard Company Unknown device 2a34
        Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 23
        Memory at fe02b000 (32-bit, non-prefetchable) [size=4K]
        I/O ports at c800 [size=8]
        Capabilities: <access denied>

/sbin/lspci -n | grep '00:14.0'
00:14.0 Class 0680: 10de:0269 (rev a3)
You need to find out what you have and then what kernel module may need to be modprobed so it is recognized.
You might try "sudo /sbin/ifup eth0" in case the device is present but was shutdown with ifdown for some reason.
 
Old 03-18-2008, 04:48 PM   #6
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Sorry about the delay, yesterday my power went out and the computer with XP had lost connection. couldnt get im back up now .

So i did the commands that you were askin for. here were the results.

Quote:
/sbin/lspci -v

01:09.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)


/sbin/lspci -v | sed -n '/01:09.0/,/^$/p'

01:09.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)+
Subsystem: 3Com Corporation 3c905B Fast Etherlink XL 10/100
Flags: bus master, medium devsel, latency 64, IRQ 9
I/O ports at dc00 [size=128]
Memory at ff8ff800 (32-bit, non-prefetchable) [size=128]
Expansion Rom at f6a00000 [disabled] [size=128K]
Capabilities: [dc] Power Management version 1


/sbin/lspci -n | grep '01:09.0'

01:09.0 0200: 10b7:9055 (rev 30)


sudo /sbin/ifup eth0

/sbin/ifup: Configuration for eth0 not found.
Usage: ifup <device name>
 
Old 03-20-2008, 06:01 AM   #7
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
Check if you have the 3c59x kernel driver loaded. Also look at the output of dmesg or your boot log to see if there were any problems indicated. The kernel source has a "vortex.txt" file that lists some options to try in your modprobe.conf configuration.
 
Old 03-20-2008, 06:56 AM   #8
DotHQ
Member
 
Registered: Mar 2006
Location: Ohio, USA
Distribution: Red Hat, Fedora, Knoppix,
Posts: 542

Rep: Reputation: 33
how about posting the output of this command (it will show your setting for eth0)

cat /etc/sysconfig/network-scripts/ifcfg-eth0

This is where you can turn on or off DHCP.

Common settings:
DEVICE=eth0
BOOTPROTO=static (or you can put DHCP here)
BROADCAST=xxx.xxx.xxx.xxx
IPADDR=xxx.xxx.xxx.173
NETMASK=255.255.255.224
NETWORK=xxx.xxx.xxx.160
ONBOOT=yes
TYPE=Ethernet

the x's were put in to hide my IP info.
 
Old 03-20-2008, 03:27 PM   #9
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jschiwal View Post
Check if you have the 3c59x kernel driver loaded. Also look at the output of dmesg or your boot log to see if there were any problems indicated. The kernel source has a "vortex.txt" file that lists some options to try in your modprobe.conf configuration.

i dont know how to do any of that :-/
i looked in the startup for the word dmesg but didnt see it anywhere, and either way didnt notice any errors during startup...
can you please explain how to do it.

and
cat /etc/sysconfig/network-scripts/ifcfg-eth0
says that it doesnt exist. ...

damn
 
Old 03-20-2008, 07:38 PM   #10
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
You can list modules with the "lsmod" command. You can filter the results with grep.
lsmod | grep 3c59

If the module isn't loaded run "sudo /sbin/modprobe 3c59x". Hopefully the 3c59x.ko kernel module exists.

If you are successful loading the module or the module exists, then run your systems Network Device setup program.
 
Old 03-20-2008, 08:32 PM   #11
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Original Poster
Rep: Reputation: 0
lsmod | grep 3c59

3c59x 44649 0
mii 9409 1 3c59x


Does that mean that it is found, but its off?

how do i run the network device setup program
 
Old 03-21-2008, 04:23 AM   #12
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
I think the next step is to run through the network device setup wizard. I don't think that was done.
 
Old 03-21-2008, 03:06 PM   #13
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Original Poster
Rep: Reputation: 0
how do i run the network device setup wizard, i looked everywhere.
the closest thing that i see is in


Place>Network Servers
and that just shows me "Windows network" folder, when i double click that there is nothing inside the folder.
 
Old 03-22-2008, 07:12 AM   #14
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654Reputation: 654
It under "system -> administration -> network".
 
Old 03-22-2008, 01:20 PM   #15
theroot
LQ Newbie
 
Registered: Mar 2008
Posts: 7

Original Poster
Rep: Reputation: 0
Cool

Thank you so much!! lol, when i went to that wizard it showed 2 ethernets inactive. (i still have my old ethernet card that wasnt working on, never took it out when i put the new one in.) so i the good one active (eth1)
and it worked like a charm. Im respondin on my linux box right now. Thanks again man. i know you put in some time in helpin me out an i really appreciate that.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fresh Slack install, no internet!!! DragonM15 Linux - Networking 1 02-24-2006 12:34 AM
Cable Internet won't work with Suse 9.1 Personal Fresh Install RazielX Suse/Novell 6 01-23-2005 12:57 AM
cant connect to internet on fresh install of suse9.1 springdog Linux - Newbie 13 12-27-2004 03:47 PM
Configuring internet again on a fresh Mandrake 10 install, advice needed xxvm1 Mandriva 1 10-31-2004 01:55 PM
fresh install (fresh headache) powadha Slackware 2 03-06-2004 01:03 PM


All times are GMT -5. The time now is 05:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration