LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices



Reply
 
Search this Thread
Old 01-28-2013, 01:21 PM   #1
tadeas
Member
 
Registered: Jul 2008
Location: Prague
Distribution: Opensuse
Posts: 40

Rep: Reputation: 5
Freeze package version


How do I freeze a specific (current) package version? In Debian there is /etc/apt/preferences, in SUSE I can do that in Yast, how do I do this in Red Hat/CentOS 6.3?

To be clear: I need a new kernel (-ml from Elrepo), but I don't want to upgrade it every few days during regular system update. I want just just to stick to 3.7.3 or something..
 
Old 01-28-2013, 01:46 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,279

Rep: Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664Reputation: 2664
Add a line to /etc/yum.conf :

exclude=kernel*

.. Be aware that the wildcard ( * ) is important : kernel*
 
Old 01-28-2013, 01:53 PM   #3
tadeas
Member
 
Registered: Jul 2008
Location: Prague
Distribution: Opensuse
Posts: 40

Original Poster
Rep: Reputation: 5
Ah... yum.conf... Why couldn't I Google it?
Thanks very much!
 
  


Reply

Tags
red hat


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.2506 < version 1.516 for a given package? stf92 General 4 07-11-2012 09:39 PM
[SOLVED] Package requires earlier version of an installed package Doug Hutcheson Linux - Software 3 12-30-2010 10:55 PM
using an earlier version of a package radiodee1 Debian 0 01-08-2008 06:45 PM
Package version twk Linux - Security 2 11-11-2005 10:00 AM
Package Version erva Linux - Newbie 1 09-29-2003 12:10 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration