LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 12-03-2003, 04:03 PM   #1
mahamkali
Member
 
Registered: Oct 2003
Posts: 67

Rep: Reputation: 15
Unhappy file system problem...


Hi,
I am using linux for 2 months and i am a newbie to it. I've got windows xp along with redhat linux 9 on my machine. Recently i've installed NTFS drivers for my linux for accessing the windows partition. The mishap happened when i am trying to copy a file from windows partition to linux. It copied almost all of the file, which is actually 700MB and at the end the system got frozen. I've restarted the system and before booting, the system prompted for file system maintenance that it had found a bad file sector in the /ext2 file system. I've typed 'yes' at the prompt, and then the letter 'y' scrolled all through the screen. This went on for almost a day and i've tried to rebooted the system again which prompted the same thing which happened before. I've tried all the ways and finally ended up reinstalling the entire redhat linux.
Is there a way in linux to prevent copying files with bad sectors? I am scared now for copying anything. Can anyone help me find the exact reason for this?

thanks,
siva
 
Old 12-03-2003, 05:36 PM   #2
jailbait
Guru
 
Registered: Feb 2003
Location: Blue Ridge Mountain
Distribution: Debian Wheezy, Debian Jessie
Posts: 7,508

Rep: Reputation: 176Reputation: 176
"Can anyone help me find the exact reason for this?"

I can only guess. So here are two guesses:

1. When you copy large files all of memory gets filled up with casche buffers. If you do not have swap enabled you can sometimes crash when memory is full. Check to make sure that you have swap set up correctly.

2. It is possible that you ran out of space on the partition that you were copying the file to, which should not result in a crash, but you never know. Use the df command to check the amount of space on all of your partitions.

___________________________________
Be prepared. Create a LifeBoat CD.
http://users.rcn.com/srstites/LifeBo...home.page.html

Steve Stites
 
Old 12-04-2003, 12:24 AM   #3
Ashish Pathak
LQ Newbie
 
Registered: Sep 2003
Location: Pune, India.
Posts: 17

Rep: Reputation: 0
First boot in single user mode with linux single command.
Then try fsck -a /dev/xxxx where xxxx is ur device name.
It will fix bad sectors and mark it as BAD.
Once sector is marked as BAD Linux will not allow to right any data on it.
For fsck umount ur partition first which u wanna check otherwise it will damage ur HDD.

Thanks,
/Ashish/Pathak.
/Pune/India.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
'Read-only file system' problem buehler Linux - Newbie 7 05-09-2006 12:13 AM
problem with file system boot... os2 General 2 07-14-2004 10:51 PM
file system problem.... mahamkali Linux - General 2 12-03-2003 04:28 PM
file system problem... mahamkali Linux - Software 0 12-03-2003 03:09 PM
File system type problem vtd Linux - General 1 04-26-2002 10:35 PM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration