LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 05-25-2012, 07:15 AM   #1
CobusA
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Rep: Reputation: Disabled
Post Error trying to start httpd on RHEL 6


I am trying to start httpd on RHEL 6 and getting this error. I've searched for solutions, but am stuck currently.

Print out of my problem:
[user@server conf]$ sudo service httpd start
[sudo] password for user:
Starting httpd: httpd: Syntax error on line 203 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/mod_auth_memcookie.so into server: libmemcache.so.0: cannot open shared object file: No such file or directory
[FAILED]
[user@server conf]$ ls -ld /etc/httpd/modules/mod_auth_memcookie.so
-rwxr-xr-x. 1 root root 21579 May 25 10:44 /etc/httpd/modules/mod_auth_memcookie.so
[user@server conf]$ ls -ld /etc/httpd/modules/
drwxr-xr-x. 2 root root 4096 Apr 25 03:01 /etc/httpd/modules/
[user@server conf]$ ls -ld /etc/httpd/
drwxr-xr-x. 4 root root 4096 Jul 5 2011 /etc/httpd/
[user@server conf]$ sudo find / -name libmemcache.so.0
[sudo] password for user:
/usr/local/lib/libmemcache.so.0
[user@server conf]$ ls -l /usr/local/lib/libmemcache.so.0
-rwxr-xr-x. 1 root root 70204 May 24 15:15 /usr/local/lib/libmemcache.so.0
[user@server conf]$

Thanks
 
Old 05-25-2012, 07:23 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,397

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
your libmemcache.so.0 is in /usr/local/lib, not /usr/lib. This probably means you installed it from source instead of RPM? I presume that /usr/local/lib isn't on your LD_LIBRARY_PATH variable, but rather than make it so, I would suggest installing the libmemcache0 RPM from yum instead.
 
Old 05-25-2012, 07:29 AM   #3
Ser Olmy
Senior Member
 
Registered: Jan 2012
Distribution: Slackware
Posts: 1,985

Rep: Reputation: Disabled
Could you post line 203 of /etc/httpd/conf/httpd.conf? It's probably a good idea to include lines 202 and 204 as well.

Is /usr/local/lib mentioned in /etc/ld.so.conf?

Have you tried running ldconfig?
 
Old 05-27-2012, 02:58 PM   #4
custangro
Senior Member
 
Registered: Nov 2006
Location: California
Distribution: Fedora , CentOS , Solaris 10, RHEL
Posts: 1,935
Blog Entries: 1

Rep: Reputation: 188Reputation: 188
Quote:
Originally Posted by acid_kewpie View Post
your libmemcache.so.0 is in /usr/local/lib, not /usr/lib. This probably means you installed it from source instead of RPM? I presume that /usr/local/lib isn't on your LD_LIBRARY_PATH variable, but rather than make it so, I would suggest installing the libmemcache0 RPM from yum instead.
^ what he said.

I also want to add...that if you're going to use RHEL; you should stick to thier repos as they probably won't support anyting compiled from source.

--C
 
Old 05-28-2012, 02:17 AM   #5
CobusA
LQ Newbie
 
Registered: Oct 2011
Posts: 4

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Ser Olmy View Post
Could you post line 203 of /etc/httpd/conf/httpd.conf? It's probably a good idea to include lines 202 and 204 as well.

Is /usr/local/lib mentioned in /etc/ld.so.conf?

Have you tried running ldconfig?


I have found file /etc/ld.so.conf.d/local-64.conf does not exist.
I have created it as seen below and then ran ldconfig and now httpd starts. Thanks a lot.

cat /etc/ld.so.conf.d/local-64.conf
/usr/local/lib
 
  


Reply

Tags
httpd


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Httpd service fail to start in rhel ent 6 vikas637 Linux - Newbie 1 06-07-2011 10:37 AM
RHEL 5.1 after installing mod_ssl, httpd server wont start athreyavc Linux - Server 5 04-11-2010 09:52 PM
Unable to start apache on CentOS Linux with error Starting httpd: Syntax error on lin pkumar2533 Linux - Newbie 9 08-26-2009 07:48 AM
Failed to start apache :Starting httpd: Syntax error on line 1027 of /etc/httpd/conf/ payjoe Linux - Newbie 3 09-21-2007 07:24 AM
httpd start error jkmartha Linux - Newbie 3 04-26-2005 03:09 AM


All times are GMT -5. The time now is 03:08 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration