LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   dual boot when linux on 1 drive, win on other drive, both scsi? (http://www.linuxquestions.org/questions/red-hat-31/dual-boot-when-linux-on-1-drive-win-on-other-drive-both-scsi-166710/)

nornad 04-06-2004 12:25 AM

dual boot when linux on 1 drive, win on other drive, both scsi?
 
ok, so i have 2 LVD SCSI hard drives. the "c" drive is running win2k pro, and the second drive formerly known as "d" now has redhat 9. the only problem is that when both hard drives are plugged in it goes directly to windows, and once in windows it doesnt even recognize the second hard drive anymore. what really bugs me though is that as of now i have to unplug the first hard drive to even get to grub. any ideas?

thanks

jailbait 04-06-2004 01:20 PM

"as of now i have to unplug the first hard drive to even get to grub. any ideas?"

Install grub on the MBR of the first hard drive that the BIOS looks at when you boot, i.e. install grub on the other hard drive. You do this by changing /boot/grub/grub.conf and then running grub-install.

To fix grub you will have to get into RH9 with both hard drives plugged in. To do that boot into the RH9 install CD and go to rescue mode. Then mount your / partition (which I am assuming is /dev/scb3 and is an ext3 file system) and chroot:
mkdir /apple
mount -t ext3 /dev/scb3 /apple
chroot /apple

-----------------------
Steve Stites

Gaweph 04-08-2004 08:08 AM

Same problem as I had
 
I had this exact problem.

Placing grub on the /mbr of the master drive will work fine.

ALTERNATIVELLY =

Make sure you have a working boot disk (Just incase)

An alternative if you do not want to go messing with the mbr is to simply enter your bios and tell it to boot off of the slave drive.

This will take you to grub which is installed on the first boot record of that drive (\boot). This method provides usefull if you ever need to format any of the drives, all of the opriginal \mbr's are still intact.

Do not switch the drives around and put windows as slave, it will not boot. For some reason windows will only boot if it isd master

Hope it works out for you

John Micheal 04-08-2004 08:44 AM

hello ,
try what i will say and contact me back .

first boot in your redhat
type ( df -k ) cpmmand to know on which drive the /boot is mounted
say you found it /dev/sdb1

then type ( dd bs=512 count=1 if=/dev/sdb1 of=/win2k )

next mount your floppy disk , take the file win2k on a floppy

then reboot in your xp

copy the file win2k on the c

open the file boot.ini , hidden file , with notepad

add this line (( c:\win2k="linux" ))

then reboot with 2 disks on

it is assumed that you will find the linux option

try it , may it work .


All times are GMT -5. The time now is 01:18 PM.