LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Direct Rendering: No (http://www.linuxquestions.org/questions/red-hat-31/direct-rendering-no-307488/)

MegaByll 03-29-2005 04:11 PM

Direct Rendering: No
 
Hey everyone, I am having a problem getting direct rendering enabled. I am using a GeForce 6800 GT OC and I have installed the latest NVidia drivers. When I do a glxinfo, this is my output:

name of display: :0.0
Xlib: extension "XFree86-DRI" missing on display ":0.0".
display: :0 screen: 0
direct rendering: No
server glx vendor string: NVIDIA Corporation
server glx version string: 1.3
server glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_SGIX_fbconfig,
GLX_SGIX_pbuffer, GLX_SGI_video_sync, GLX_SGI_swap_control,
GLX_ARB_multisample, GLX_NV_float_buffer
client glx vendor string: SGI
client glx version string: 1.2
client glx extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_EXT_import_context
GLX extensions:
GLX_EXT_visual_info, GLX_EXT_visual_rating
OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 6800 GT/PCI/SSE2
OpenGL version string: 1.5.3 NVIDIA 71.67
OpenGL extensions:
GL_ARB_imaging, GL_ARB_multitexture, GL_ARB_texture_border_clamp,
GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
GL_ARB_texture_env_combine, GL_ARB_texture_env_dot3, GL_EXT_abgr,
GL_EXT_blend_color, GL_EXT_blend_minmax, GL_EXT_blend_subtract,
GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias
glu version: 1.3
glu extensions:
GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

visual x bf lv rg d st colorbuffer ax dp st accumbuffer ms cav
id dep cl sp sz l ci b ro r g b a bf th cl r g b a ns b eat
----------------------------------------------------------------------
blah blah blah

My XF86Config looks like this:
XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
#Load "GLcore"
#Load "dri"
EndSection

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "MAG LT530C"
HorizSync 45.0 - 58.0
VertRefresh 57.0 - 63.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
#Driver "vesa"
Driver "nvidia"
#VendorName "Videocard vendor"
#BoardName "VESA driver (generic)"
Option "NvAGP" "1"
Option "AllowGLXWithComposite" "true"
Option "RenderAccel" "true"
Option "RENDER" "Enable"
Option "TwinView" "true"

EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection


Like I said before. my problem is that I need to get direct rendering enabled, but I can't get it enabled. I have checked similar threads, but none of them have completely helped me solve my problem. Maybe someone can help me? Thanks.

huibert.alblas 03-30-2005 03:31 PM

Hmm, you are one of many who did not check the output from GLXINFOcorrectly.

If you do a:
Code:

glxinfo | grep vendor
You should get "NVidida Corp" 3 times, you only have NVidia 2 times, and you GLX_VENDOR is SGI.
This looks like you have a mixed install with NVidia opengl drivers, and the mesa drivers.

Maybe try uninstalling (removing) MESA, and reinstall the NVpackage.

Oh, another thing, maybe you should try to diasble Rendering extensionf first
Code:

Section "Device"
Option "AllowGLXWithComposite" "true"
Option "RenderAccel" "true"
Option "RENDER" "Enable"
Option "TwinView" "true"

For debugging purposes.

ctlphd 04-06-2005 09:11 PM

I have same problem
 
I seem to have mixed install as well. With same commands I get the following:

glxinfo | grep vendor
Xlib: extension "XFree86-DRI" missing on display ":0.0".
server glx vendor string: SGI
client glx vendor string: ATI
OpenGL vendor string: Mesa project: www.mesa3d.org


SO, Now what do I do???? How do I Uninstall Mesa? rpm -e? make uninstall?
And what about SGI? Sorry, I'm still a relative newbie.

huibert.alblas 04-07-2005 02:18 AM

I'm sorry, I cannot help you here.
You have an Ati card, and drivers Installed.
Maybe the Ati drivers depend on SGI / Mesa, I cannot tell you if the output from your glxinfo indicates an error.

It would if you would have a Nvidia card.

wolfger 10-14-2006 10:58 AM

Quote:

Originally Posted by huibert.alblas
If you do a:
Code:

glxinfo | grep vendor
You should get "NVidida Corp" 3 times, you only have NVidia 2 times, and you GLX_VENDOR is SGI.
This looks like you have a mixed install with NVidia opengl drivers, and the mesa drivers.

Maybe try uninstalling (removing) MESA, and reinstall the NVpackage.

I have this same problem. I uninstalled all the mesa packages I could (the libs were required by much of my system, but I uninstalled the xlibs). After I did that, though, I could no longer run glxinfo. So then I quit out of X so that I could re-install the nvidia drivers, and the nvidia installer keeps quitting with an error message saying I don't have the right kernel source (which I am nearly positive is untrue). Help?

wolfger 10-14-2006 10:56 PM

Okay, got my own problem fixed. I recompiled my kernel and then recompiled the nvidia drivers, and everything worked. Which is really odd to me, since I didn't change anything in the kernel...:scratch:

huibert.alblas 10-20-2006 07:44 AM

Kernel recompile fixed it...
 
Hi,

this is a very old thread, but maybe my reply will help you understand better.

The Nvidia installer not only looks for kernle sources and libs.
It must find a kernel source tree from wich the currently runnig kernel is compiled.

Compiling the kernel not only generates a kernel binary, but also a lot of intermediate files, with infomation about the internal kernelstructures in use by the kernel.
Some off these "structures" are assembled at compiletime.

Another thing could be that the kernel your running is not exactly from the sources you have downloaded.

After you recompiled your kernel, the kernel sources really matched the current kernel,
and the nvidia drivers can compile.


The best way to use Nvdidia drivers depends on your kernel.
If you use the stock kernel from your distro, you should use the nvidia drivers-package from your distro.

If you are running a custom kernel, you have to compile the drivers yourself.
Your best bet here ist to use the kernelsources from kernel.org and nvidia drivers directly from nvidia.

YMMV


Happy hacking

Huibert

wolfger 10-20-2006 10:42 AM

Quote:

Originally Posted by huibert.alblas
The Nvidia installer not only looks for kernle sources and libs.
It must find a kernel source tree from wich the currently runnig kernel is compiled.

Compiling the kernel not only generates a kernel binary, but also a lot of intermediate files, with infomation about the internal kernelstructures in use by the kernel.
Some off these "structures" are assembled at compiletime.

Another thing could be that the kernel your running is not exactly from the sources you have downloaded.

Well, this was on a freshly installed system, where the running kernel had been compiled just the previous day. Is it possible that adding the ALSA modules (compiled from source) did something to cause NVIDIA to not recognize the kernel source as being right?

Quote:

Originally Posted by huibert.alblas
The best way to use Nvdidia drivers depends on your kernel.
If you use the stock kernel from your distro, you should use the nvidia drivers-package from your distro.

If you are running a custom kernel, you have to compile the drivers yourself.
Your best bet here ist to use the kernelsources from kernel.org and nvidia drivers directly from nvidia.

I was instructed to use a particular version (7676) of the nvidia driver, and that was not available through my distro, so I took the stock kernel source, copied the config from the stock kernel in /boot, and ran "make oldconfig && make && make modules_install", moved the resulting kernel to /boot, rebooted, then compiled the 7676 driver from nvidia, then compiled the ALSA driver from the ALSA website, rebooted, did some miscellaneous tasks, ran into GL problems, found this thread, and could not recompile nvidia without first recompiling kernel.


All times are GMT -5. The time now is 06:05 AM.