LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 05-08-2011, 03:17 PM   #1
walterbyrd
Member
 
Registered: Apr 2004
Posts: 565

Rep: Reputation: 30
Difficulty installing LibreOffice on Scientific Linux 6.0


AMD 64-bit quad core
Scientific Linux 6.0
Gnome 2.28


I have been trying to install openoffice, or libreoffice, and it's just an awful chore.

I tried using the gui tool. When I searched for libreoffice, I got nothing. When I searched for openoffice, I got a disorganized mess of separate apps, most of which seemed to have nothing to do with any office.

I got openoffice writer installed, then openoffice calc, but calc does not work.

So I downloaded libreoffice, and I am trying to go though the manual chore of getting it installed. But, the old openoffice is conflicting, and uninstalling open office is no easy task.

I went to the gui tool, and uninstalled the openoffice apps. But I when I try to install the desktop-integration RPMs, I keep getting a long series errors like this:

Quote:
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.writer.png from install of libreoffice3.3-redhat-menus-3.3-202.noarch conflicts with file from package openoffice.org-core-1:3.2.1-19.6.el6_0.5.x86_64
file /usr/share/icons/hicolor/16x16/mimetypes/gnome-mime-application-vnd.sun.xml.writer.template.png from install of libreoffice3.3-redhat-menus-3.3-202.noarch conflicts with file from package openoffice.org-core-1:3.2.1-19.6.el6_0.5.x86_64
file /usr/share/icons/hicolor/32x32/mimetypes/gnome-mime-application-vnd.sun.xml.writer.template.png from install of libreoffice3.3-redhat-menus-3.3-202.noarch conflicts with file from package openoffice.org-core-1:3.2.1-19.6.el6_0.5.x86_64
file /usr/share/icons/hicolor/48x48/mimetypes/gnome-mime-application-vnd.sun.xml.writer.template.png from install of libreoffice3.3-redhat-menus-3.3-202.noarch conflicts with file from package openoffice.org-core-1:3.2.1-19.6.el6_0.5.x86_64
When I try to remove these files individually, I get:

Quote:
#rpm -e openoffice.org-core-1:3.2.1-19.6.el6_0.5.x86_64
error: package openoffice.org-core-1:3.2.1-19.6.el6_0.5.x86_64 is not installed
 
Old 05-08-2011, 03:28 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
It looks like just a bunch of errors from conflicting icons, you could use rpm to force the installation of the package.

see
Code:
man rpm
for the exact syntax
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Difficulty installing Java Runtime on Scientific Linux 6.0 walterbyrd Red Hat 2 05-08-2011 01:47 PM
[SOLVED] Installing Scientific Linux 5.5 on DELL XPS 15 subhash.rao Linux - Laptop and Netbook 2 02-12-2011 10:34 AM
Installing Gnumeric in Scientific linux 5.5 Alexvader Red Hat 5 11-02-2010 05:23 PM
HELP installing SCIENTIFIC LINUX erbegu Linux - Newbie 2 11-09-2009 06:50 AM
Removing Scientific Linux and installing Slackware kd5giv Slackware - Installation 15 08-25-2006 05:16 PM


All times are GMT -5. The time now is 07:56 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration