LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   CUPS support for HP Printer (http://www.linuxquestions.org/questions/red-hat-31/cups-support-for-hp-printer-775806/)

basillica 12-15-2009 10:11 AM

CUPS support for HP Printer
 
Hi,
I have a wire network connection to a printer over my Lan. It is an HP 3210 All-in-One series. Can someone tell me whether cups is capable of printing to this printer? Or do I need to use HP's drivers (:::shudder:::)?


Regards,
Dave

p.s. I'll be looking to set this up from RHEL5 and/or fedora 12.

SethsdadtheLinuxer 12-15-2009 11:24 AM

If your printer supports postscript, then you wont need HP specific drivers.

pixellany 12-15-2009 11:31 AM

HP has the best Linux support of any printer vendor. I find that it is best to always install HPLIP and the "foomatic" drivers. (It's not a CUPS issue---it's all about which drivers you install.)

What's wrong with HP drivers?

mianka 12-15-2009 09:49 PM

See http://hplipopensource.com/hplip-web/index.html.

stoggy 12-16-2009 01:33 PM

HP doesn't use hplip anymore. I don't have access to my desktop with my PSC1350 printer but I think it is called hpaio now.


RHEL5 may still only have hplip, you could download it from hp but i don't think they have a repo setup so yum update wont update it. I would stay with hplip in that case. I always forget to update when I get off the norm...

FC12 is the new version, again i think its called hpaio.


Of course it doesn't really matter even in FC12 you could load hplip and it should work, but again then you get off the norm and will have to maintain it yourself.

DrLove73 12-16-2009 05:09 PM

I just checked in CentOS 5.4, There is HP Photosmart 3200 driver, and foomatic name is hpijs. By the way, If you have PPD file, CUPS can print using it.

mianka 12-16-2009 05:23 PM

Stoggy, you are completely wrong! HPLIP is -til today- the official HP driver repository.It is hpaio that has been dropped,years ago.
The printer mentioned is fully supported ,even the network.
http://hplipopensource.com/hplip-web...00_series.html

stoggy 12-17-2009 08:32 AM

Are you literate?


I don't remember the new name but i dont think it is hplip, at the very least it is not the same hplip as it use to be. Maybe even the rpm is called hplip, I don't think so though, but you no longer need the 2 daemons running that made up hplip, hpiod and hpaio.


You can still download a 2.0 kernel too. But you will have to maintain it yourself... What good is a link, sheesh read what I wrote...

I even said you could download hplip but it doesn't come in fedora 12. I think it is what is in RHEL5 though.


Either way, it will work. do something like `yum list hp*` and you will what is required.

basillica 12-18-2009 03:27 AM

Quote:

Originally Posted by pixellany (Post 3792468)

What's wrong with HP drivers?

Nothing against them per se. But my eperience with driver packaging for this printer has been very poor.

Although I'm talking Windows here, HP package the driver along with multi-function apps. To deal with two issues that cropped up with sub-componenets of this monolith I had to manually uninstall after a series of registry edits and other hacks.

Of course, all that meant having to go through the painful experience of dealing with HP support. Avoiding the potential for software products that seem designed to cause grief seems like a sensible idea to me. Then of course, the packaging for Linux is likely to be a lot cleaner.

I take it HP also provide separate packages for multi-function support?

Regards,
Dave


All times are GMT -5. The time now is 11:43 PM.