LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 11-22-2003, 06:43 AM   #1
ilpadrino
Member
 
Registered: Oct 2003
Location: Spain
Distribution: Fedora
Posts: 104

Rep: Reputation: 15
cups, locale settings and printer


Well, I have a Lexmark Z11 printer (unfortunately a Windows printer) and I want to install it on my linux (Red Hat 8.0).

So first of all I get the driver from "linuxprinting" and the PPD file to manage it. So I installed both properly. First I tried to use the print tool that is included in my distro, which use the lpd daemon. All the configuration seems to be OK, but no output on the printer.

So I decided to install cups. So I configure the printer through the web tool, and try to print a test page. The web monitor tools said that job has been completed but neither any output on the printer.

When I edit the "error_log" always says:

perl: warning: Setting locale failed
perl:warning: Please check that your locale settings


LANGUAGE= (unset)
LC_ALL=(unset)
LANG="en"
are supported and installed on your system
perl:warning: Falling back to the standard locale ("C")

LexZ11: No pages printed ! tail process done writing data to STDOUT.


Then I checked my locale settings executing "locale". I have installed and supported all concerning to "EN" and "ES" language parameters. When I execute "export", only the LANG variable is defined as "LANG=es_ES.UTF-8". If I execute "export LANGUAGE="es_ES" LC_ALL="es_ES" ", then I can see the new variables defined after a new export execution command. Then I restart the cupsd daemon and the same error again.

So my question is how can I define the locale settings (LANG, LANGUAGE and LC_ALL) in order to be properly recognized by the cups daemon?

Thank you in advance
 
Old 11-22-2003, 11:04 AM   #2
willcox
Member
 
Registered: May 2003
Location: Mexico
Distribution: FC 4
Posts: 36

Rep: Reputation: 15
Hi my friend! I don't recall where, but I have heard that some HP printers share their unix drivers with lexmark printers. By the way, is your lexmark printer running ok with windz?
Let me recommend you something:
1.- Go here:
http://ayo.freshrpms.net/
2.- Download & install the "apts" needed by your distro.
3.-Type: apt-get update then apt-get upgrade
This software should update all your installed programs icluding CUPS
4.- Uninstall your actual printer's configuration, and try again configuring with your upgraded CUPS
I'm wondering if you read/write italian? spanish?
Have a nice time.
 
Old 11-22-2003, 11:46 AM   #3
RolledOat
Member
 
Registered: Feb 2003
Location: San Antonio
Distribution: Suse 9.0 Professional
Posts: 843

Rep: Reputation: 30
When you converted to CUPS, did you make sure to disable lpd? Redhat 8.0 has both. This may help, when switching from lpd to cups. I checked on my system, the lexmark Z11 cups drivers are installed on my system, so that should not be a problem.

http://wave.prohosting.com/hlrguy/Re...rintercfg.html

R.O.
 
Old 11-22-2003, 01:08 PM   #4
ilpadrino
Member
 
Registered: Oct 2003
Location: Spain
Distribution: Fedora
Posts: 104

Original Poster
Rep: Reputation: 15
For Willcox:

Yes, I am spanish. So I can read and write in that language. English is a little bit difficult for me.
Now I am downloading 245 MB in the upgrading process. But, is there any option to upgrade a specific package (e.g cups) without upgrading the others?. Thanks.


For RollerOat

Yes, I stop lpd daemon before running and start cups daemon.


My question is: where does cups get the LANG parameter, cause in the error_log file said that LANG=en, and my system default language is spanish. That's the reason why the execution of "export" command give the result of LANG="es_ES.UTF-8". But I don,t know where cups get LANG="en" and cannot set LC_ALL and LANGUAGE paremeters.


Thanks both

Last edited by ilpadrino; 11-22-2003 at 01:15 PM.
 
Old 11-23-2003, 05:18 AM   #5
ilpadrino
Member
 
Registered: Oct 2003
Location: Spain
Distribution: Fedora
Posts: 104

Original Poster
Rep: Reputation: 15
I have also tried to add the next line to the filters program (foomatic-rip or cupsomatic):

$ENV {'LANG'}='C';

but I have the same problem with locale settings.

Someone Know where is the log file of "lpd" daemon?

Thanks in advance
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help printer from a samba shared printer from linux (using cups) epod69 Linux - Networking 3 12-04-2005 10:44 PM
perl: warning: Please check that your locale settings: Daredevil Linux - Software 1 05-12-2005 10:47 AM
locale and keyboard settings tiuztux Slackware - Installation 2 03-16-2005 07:22 AM
parrellel printer in CUPS? No parellel printer option... servnov Linux - General 3 10-31-2004 02:08 PM
English / Danish Locale settings TroelsSmit Linux - Newbie 2 05-21-2004 02:26 AM


All times are GMT -5. The time now is 02:02 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration