LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   Creating custom kickstart for Centos 5 and change hard disk from hda to sda (http://www.linuxquestions.org/questions/red-hat-31/creating-custom-kickstart-for-centos-5-and-change-hard-disk-from-hda-to-sda-905759/)

santino83 09-30-2011 06:05 AM

Creating custom kickstart for Centos 5 and change hard disk from hda to sda
 
Hello,

I have created a custom kickstart for my customized centos distribution. It works ok. Now the problem is: with a specific hardware, Centos is not able to understand which driver is needed for the hard disk, and so instead of use the hard disk as sda it uses hda.

When installing, it takes more than one hour and half for formatting, and when then I see a lot of errors in writing on disk.

I've found out the solution: hda=noprobe hda=none in grub.conf, and it works great. Now the issue is only while installing: I'm searching a way to put this commands in my ks, so I hope not to have to wait hours for formatting 250GB of hard disk...

Using a normal centos distro, I could do "linux text hda=noprobe hda=none" and it works, but mine is not a normal distro, and I cannot understand where to put those commands in the ks, as in the documentation I don't find the right option to set

Here is my ks (the most relevant part):

Code:

text
install
cdrom
lang it_IT.UTF-8
timezone Europe/Rome
keyboard it
langsupport --default=it_IT.UTF-8 it_IT.UTF-8
firewall --disabled
selinux --disabled
authconfig --enableshadow --enablemd5
bootloader --location=mbr --append="hda=noprobe hda=none"
clearpart --all
part /boot --fstype ext3 --size=100
part swap --recommended
part pv.2 --size=0 --grow
volgroup vg00 --pesize=32768 pv.2
logvol / --fstype ext3 --name=root --vgname=vg00 --size=8192
logvol /var --fstype ext3 --name=var --vgname=vg00 --size=5120
logvol /vlstorage --fstype ext3 --name=vps --vgname=vg00 --size=1024 --grow
skipx
reboot --eject

thanks for your help

santino83 10-01-2011 06:05 AM

I've found the solution, and it was pretty easy.... Just put hda=noprobe hda=none in the isolinux.cfg

Code:


label mylabel
  kernel vmlinuz
  append initrd=initrd.img ks=cdrom:/images/ks.myks text hda=noprobe hda=none

thanks everybody


All times are GMT -5. The time now is 11:17 AM.