LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 06-02-2006, 05:13 AM   #1
qotsa
LQ Newbie
 
Registered: Jun 2006
Location: Madrid (Spain)
Distribution: Red hat enterprise (kernel 2.6.16)
Posts: 5

Rep: Reputation: 0
coul not upload firmware ("isl3890")


Hi All,

I'm trying to set up my wireless card SMC2835W (made in china, prism54 firmware), on a Linux redhat enterprise (kernel 2.6.16) and Im getting the following error "could not upload firmware ("isl3890")" when trying #ifconfig eth0 up.
The firmware is located in /usr/lib/firmware as it is established on the path of the firmware.agent file. Curiously the card works fine on a SLAX live cd, so what am I doing wrong.

Sorry for my poor english and thank you in advance for your help.

Regards,
qotsa

Last edited by qotsa; 06-02-2006 at 07:55 AM.
 
Old 06-03-2006, 05:31 AM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Wrong location, place (copy) the isl3890 firmware file in /lib/firmware

BTW; Your English is fine.
 
Old 06-03-2006, 09:34 AM   #3
qotsa
LQ Newbie
 
Registered: Jun 2006
Location: Madrid (Spain)
Distribution: Red hat enterprise (kernel 2.6.16)
Posts: 5

Original Poster
Rep: Reputation: 0
Thumbs down coul not upload firmware ("isl3890")

I have placed the isl3890 file into the /lib/firmware directory, but I'm still getting the same error. #dmesg shows the following information

eth0: uploading firmware…
prism54: request_firmware() failed for ‘isl3890’
eth0: could not upload firmware (‘isl3890’)
....
SIOCSIFFLAGS : No such file or directory.

Could be the problem the firmware.agent file? which is the proper location for this file?

Thank you in advance
qotsa

BTW Lenard, thanks for your reply and your kindness. (Your english is good too, hehehe! )

Last edited by qotsa; 06-03-2006 at 09:49 AM.
 
Old 06-03-2006, 12:14 PM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
The location that works with mine is /lib/firmware, but you could also try the /usr/lib/hotplug or /etc/hotplug locations.

$ ls -al /lib/firmware/isl*
-r--r--r-- 1 root root 93996 Nov 3 2005 /lib/firmware/isl3890

$ uname -a
Linux Aspire5000 2.6.16.19 #1 Thu Jun 1 11:27:47 EDT 2006 x86_64 x86_64 x86_64 GNU/Linux
 
Old 06-03-2006, 01:44 PM   #5
qotsa
LQ Newbie
 
Registered: Jun 2006
Location: Madrid (Spain)
Distribution: Red hat enterprise (kernel 2.6.16)
Posts: 5

Original Poster
Rep: Reputation: 0
Question

Finally I came out with the problem, the sys directory wasn't mount. I mounted it in the fstab file as follows:

none /sys sysfs defaults 00

I'm wireless now!!!

but, what's this directory for?

Thank you in advance
qotsa
 
Old 06-03-2006, 05:52 PM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Glad you got it figured out. The /sys[tem] or the 'new' /proc directory.

http://www.developertutorials.com/tu...503/page1.html
 
Old 06-06-2006, 07:59 AM   #7
qotsa
LQ Newbie
 
Registered: Jun 2006
Location: Madrid (Spain)
Distribution: Red hat enterprise (kernel 2.6.16)
Posts: 5

Original Poster
Rep: Reputation: 0
I'm sorry for answering so late (girlfriend time), and thank you for your help and your wisdom.

qotsa

Last edited by qotsa; 06-06-2006 at 08:15 AM.
 
Old 06-06-2006, 03:10 PM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
It is more important to have girlfriend time then to be on the Internet.

You are welcome, glad to help.
 
  


Reply

Tags
firmware, isl3890, prism54


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
upload image to db "php + mysql" ALInux Programming 1 12-15-2005 11:27 AM
"Prevent firmware from being built" safe to uncheck in kernel config? rollo Linux - General 0 10-28-2005 07:16 PM
Creating heavily restricted "upload" accounts Paiway Linux - Security 1 01-23-2005 09:48 PM
SANE has no "firmware files".Where i can get them? zvonSully Debian 5 01-10-2005 03:40 AM
SCSI Device unavailable after firmware download. Redhat or "sg" issue? jrvance Linux - Hardware 2 10-21-2003 01:41 PM


All times are GMT -5. The time now is 10:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration