LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 01-26-2004, 07:47 PM   #1
admanb
Member
 
Registered: Jul 2003
Distribution: Libranet 2.8.1, the best Debian-based distro out there.
Posts: 43

Rep: Reputation: 15
Confused about kernel version - RH9


I'm trying to update my kernel to install ALSA drivers, but I'm getting really confused, here are the ALSA RPMs I installed:

gnome-alsamixer
alsa-utils
xmms-alsa
alsa-lib
alsa-lib-devel
alsa-driver
kernel-module-alsa#0.9.8-1.fr_2.4.20_20.9

Everything installed fine. But none of the modules that were supposed to be installed were, /sbin/modprobe failed on all of them. So I checked my kernel version with uname -a:

Linux localhost.localdomain 2.4.20-8 #1 DATE i686 athlon i386 GNU/Linux

I'm confused, isn't this a RH8 kernel? I tried installing kernel-2.4.20-28.9.src.rpm, but nothing changed, except now, when I do rpm -qa, it stats with:

warning: cannot get shared lock on /var/lib/rpm/Packages

What's going on?
 
Old 01-28-2004, 05:12 AM   #2
ezra143
Member
 
Registered: Aug 2003
Location: NY
Distribution: RH9, RH8, Slack, Vector
Posts: 497

Rep: Reputation: 31
nope, that is the default rh9 kernel.

try running updatedb and then see if it works

also, source rpms are for editing, whereas regular rpm's directly install the binaries.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Regarding distribution + kernel version + gcc version + glib version. JCipriani Linux - General 8 04-19-2008 02:54 PM
SW 10.2 Kernel Version Confused zaimor Slackware - Installation 6 10-30-2005 12:15 AM
want to up grade kernel 2.4.20-8(RH9) to newr version rhaz Linux - Software 3 11-24-2004 05:05 AM
I'm confused. How can I tell which version of Mandrake I have? Ausar Linux - Newbie 1 06-14-2004 01:30 AM
Version 2.6 Kernel for RH9... Alf829 Red Hat 2 02-10-2004 10:20 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration