LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Password
Red Hat This forum is for the discussion of Red Hat Linux.

Notices

Reply
 
Search this Thread
Old 09-01-2005, 05:15 PM   #1
sophiatang
LQ Newbie
 
Registered: Aug 2005
Posts: 2

Rep: Reputation: Disabled
cannot configure: permission denial in '/usr/local/lib/'


Hello, I was not able to install a program into Redhat using 'configure'. I am not sure if I spec the wrong path in the configure file, or b/c I cannot change permission in the /usr/ dir even I used chmod 777.

I got the error msg:
mkdir: cannot create directory `/usr/local/lib/vmd': Permission denied

these are the instructions:
*******************************
1) Edit the file 'configure'; change the values for
the $install_library_dir and $install_bin_dir to a directory in
which vmd data files and executables should be installed, be sure
that you installing into a clean target directory and not overwriting
an existing version of VMD (which would otherwise give problems):

$install_bin_dir is the location of the startup script 'vmd'.
It should be located in the path of users interested in running VMD.

$install_library_dir is the location of all other VMD files.
This included the binary and helper scripts. It should not be
in the path.
2) run ./configure
3) cd src
4) make install
********************************

in the "configure" file, it concludes:
********************************
# Name of shell script used to start program; this is the name used by users
$install_name = "vmd";

# Directory where VMD startup script is installed, should be in users' paths.
$install_bin_dir="/usr/local/bin";

# Directory where VMD files and executables are installed
$install_library_dir="/usr/local/lib/$install_name";
****************************
The path in which I run the program vmd is "/home/sophiagnat/Desktop/Research/MolSim/vmd"

How do I substitude this path in the configure file?
and How do I change permissions in /usr/ and its subsequent dir?

Thank you for your attention, and help.
sophia
 
Old 09-01-2005, 08:29 PM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,414

Rep: Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966Reputation: 1966
you need to run the make install section as root, not a normal user. Under no circumstances whatsoever sould you be setting permissions as 777, things will start breaking sharpish.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Starting httpd: /usr/sbin/httpd: symbol lookup error: /usr/local/lib/libaprutil-0.so. bijuhpd Linux - Newbie 1 10-30-2005 05:07 PM
including usr/local/lib directory Quest101 Linux - Software 3 01-01-2005 04:13 PM
Installing software, /usr/lib directory and /usr/local millertime Linux - Software 2 07-10-2004 09:21 AM
/usr/lib and /usr/local/lib doxxan Slackware 5 06-15-2004 12:58 AM
no php.ini file under /usr/local/lib/ !! jogurt666 Linux - Software 1 12-16-2003 12:06 AM


All times are GMT -5. The time now is 02:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration