LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Red Hat (http://www.linuxquestions.org/questions/red-hat-31/)
-   -   anonymous user can't create a directory on ftp server (http://www.linuxquestions.org/questions/red-hat-31/anonymous-user-cant-create-a-directory-on-ftp-server-785034/)

bharatlalgupta 01-27-2010 05:25 AM

anonymous user can't create a directory on ftp server
 
hello
i'm using ftp server with RHEL-5.1 now i wish to an anonymous user can create and upload some file on my ftp server...
for this i configure the entries in /etc/vsftpd/vsftpd.conf

anonymous_enable=YES
# Uncomment this to allow local users to log in.
local_enable=YES
# Uncomment this to enable any form of FTP write command.
write_enable=YES
#anon_mkdir_write_enable=YES
#anon_upload_enable=YES

and change some boolean value
allow_ftpd_anon_write --> on
allow_ftpd_full_access --> on
ftp_home_dir --> on
ftpd_disable_trans --> on
ftpd_is_daemon --> on
and lastly after this configuration when try to login ftp server following command
[root@server1 media]# ftp 192.168.0.26
Connected to 192.168.0.26.
220 Welcome to blah FTP service.
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (192.168.0.26:root): ftp
331 Please specify the password.
Password:
500 OOPS: vsftpd: refusing to run with writable anonymous root
Login failed.
ftp>
i'm not understand what is the meaning of
500 OOPS: vsftpd: refusing to run with writable anonymous root
and how to make a anonymous successfull login...

dadrunamok 01-27-2010 06:28 AM

I am not an expert in these things, but it looks to me like your problem is these lines:

Quote:

#anon_mkdir_write_enable=YES
#anon_upload_enable=YES
and specifically the hash signs at the beginning, which would turn them into comments and cause them to be ignored.

No doubt somebody will correct my response in a friendly manner if I have steered off into a ditch on this one!

pixellany 01-27-2010 06:44 AM

bharat*;

I strongly recommended removing your phone number and e-mail from your posts/sig. You are inviting unwanted attention.
You have e-mail enabled in your profile, so people can always reach you using the link.

If I were running an FTP server, I would NOT want anonymous users creating or removing directories.

DrLove73 01-27-2010 10:16 AM

I belive dadrunamok is corect, those 2 lines are most likely the culprit. remove "#" sign in front of them to enable those commands. In any unix/linux script or config file "#" means commented line, the one that is skiped.


All times are GMT -5. The time now is 08:33 AM.