Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Distributions > Red Hat
User Name
Red Hat This forum is for the discussion of Red Hat Linux.


  Search this Thread
Old 02-06-2008, 07:09 PM   #1
LQ Newbie
Registered: Feb 2008
Posts: 8

Rep: Reputation: 0
Question "rescue" mode can't mount filesystem w/ LABEL=/ in fstab

Really weird... for some reason when I boot into rescue mode (boot disk -> "linux rescue"), when it tries to mount my current fileysystem, it gives the message "An error occurred trying to mount some or all of your system". Looking in "/mnt/sysimage" I see that only the /boot partition was found & mounted (proc & sys too). After some tinkering, I determined that if I change my /etc/fstab file to use the actual device name instead of using the "LABEL=/", then rescue mode can find & mount the filesystem.

Even when rescue mode gives the error, I can still use e2label and findfs to find the label of the device as well as find the device associated w/ the label. Obviously the rescue mode has to have been able to locate my "/" partition in order to check the /etc/fstab file -- so why give the error instead of mounting it? Anybody have any ideas? This is a pain, because I want to use LABELs in my fstab file, but need rescue mode to auto-mount my system to save me several steps everytime I boot into rescue. I'm trying to understand why it's erroring out here.

I can give system details if needed... not sure which things are pertinent to this problem, though. I am using Logical Volumes if that makes a difference.

Last edited by KipBond; 02-06-2008 at 08:23 PM. Reason: title was messed up


fstab, label, mount, rescue

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
How modify fstab when its 'ro' in "repair filesystem" mode ? emuub Linux - Software 3 03-24-2011 07:46 AM
unclean shutdown causes "Couldn't find matching filesystem: label=" error irnerdette Red Hat 3 06-02-2006 01:44 PM
meaning of LABEL="/" in fstab isaac_linux Linux - General 3 04-04-2004 06:24 AM
Hard disk now displaying "not a valid block device" when booting in rescue mode alphasure Linux - Hardware 4 06-05-2003 07:49 AM
dump + restore to backup linux ; "Couldn't find matching filesystem: LABEL=/" on boot markus1982 Linux - General 4 09-21-2002 01:16 PM

All times are GMT -5. The time now is 09:39 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration