LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Puppy
User Name
Password
Puppy This forum is for the discussion of Puppy Linux.

Notices

Reply
 
Search this Thread
Old 02-03-2011, 02:11 PM   #1
ladyoxana
LQ Newbie
 
Registered: Jan 2011
Posts: 10

Rep: Reputation: 0
Xircom/Intel ethernet card interface disappears suddenly


Hello,

I finally successfully installed frugal Puppy 4.2 onto my 128 RAM, 6GB IBM ThinkPad a20m old laptop. This is the newest possible distro I could use, that sees my HD. Lucid 520 doesn't. That is why I chose 4.2

Everything is great! Love the distro.

However,the ethernet combo card (presume Xircom/Intel as per manuf. manual)only appears for about 5-10 minutes. From this it is clear: not a hardware issue. Card works.

First looks like this:


Ethernet eth0 PCI: Inter Ethernet 100

Stays like that for a while. Then Internet is gone. Back to Network Wizard.

Now looks like this:

Ethernet eth0 PCI:_______________

Nothing, no description for PCI.

I am not sure what module it needs to continue recognizing the card.

I have loaded e1000e-0.4.1.12-k2.6.25.16.pet to, hopefully, update something.Rebooted. Same problem persists.

Tried "wrapping" the manufacturer's WIN driver NET82557.INF to no avail. Even wrapped additional driver for JUST Ethernet part of the combo, and no luck.

What should I do now? What is best? Downgrade to retro version with older kernel to reconfigure an ancient Etherner/56K combo card I have? Or just get an additional kernel? Should I use Wary 500 that promises many kernels and almost all possible modules?

Or to simply use some other OS suitable for my particular PC?

I love Puppy and do not want to part with it. It is light, cute, very functional and easy to figure out. Well, except for the Ethernet card in my case

Any suggestions are WELCOME!!!!
 
Old 02-03-2011, 02:58 PM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
I would make a list of the loaded modules when the Ethernet card is working and another list of the loaded modules when the Ethernet card is not working. Then compare the two lists to see if there are any differences.
Code:
lsmod > module-list-working.txt
lsmod > module-list-broken.txt
I would also look at the system message log immediately after the card malfunctions to see if there are any helpful error messages.
Code:
dmesg
It might also help shed light on the problem if you tried some other live CD distributions just to see if the problem occurs with any of them. You would not have to install them, just run them from the CD.

Last edited by stress_junkie; 02-03-2011 at 03:01 PM.
 
Old 02-04-2011, 08:04 AM   #3
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , MacPup,Linux-Lite 2.0, SaliX
Posts: 2,709
Blog Entries: 18

Rep: Reputation: 870Reputation: 870Reputation: 870Reputation: 870Reputation: 870Reputation: 870Reputation: 870
Try a different Network Manager maybe.

http://www.murga-linux.com/puppy/viewtopic.php?t=64472

I had problems with wireless dropping out till I quit using the default Network manager in Puppy and went with frisbee.

Edit: By the way. I run Puppy 5.2 on my IBM A22m. Wireless is via a PCMCIA Belkin F5D 7010 ver.6. I ran Puppy 4 Dingo and Puppy 5.1.1 on it previously.

Last edited by rokytnji; 02-04-2011 at 08:08 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Xircom ethernet card problem and modules.conf keep changing IsaacHunt Linux - Networking 0 05-21-2004 08:46 AM
I cannot use card pcmcia xircom creditcard ethernet 10/100 on redhat 8.0 lek171 Linux - Laptop and Netbook 10 02-04-2004 12:51 PM
I cannot use card pcmcia xircom creditcard ethernet 10/100 + Modem 56 on redhat 8.0 lek171 Linux - Networking 2 01-31-2004 09:05 AM
I cannot use card pcmcia xircom creditcard ethernet 10/100 on redhat 8.0 lek171 Linux - Hardware 2 01-30-2004 04:33 PM
Need help with Xircom Ethernet Cardbus card Electrode Linux - Hardware 1 12-03-2002 01:47 PM


All times are GMT -5. The time now is 08:39 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration