LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Puppy
User Name
Password
Puppy This forum is for the discussion of Puppy Linux.

Notices

Reply
 
Search this Thread
Old 05-19-2008, 10:41 AM   #1
yosaba
LQ Newbie
 
Registered: May 2008
Posts: 3

Rep: Reputation: 0
Puppy 4 won't save session


Hi,

I have been running Puppy since the 1.x series. I install to the hard drive using something like the "poorman's install" by mounting the iso, copying pup_XXX.sfs and zdrv_XXX to the root of a previously formatted partition and copying vmlinuz, isolinux.* and initrd.gz to an appropriate sub-directory. Then I add a file called
PUPIDE
to the root of the partition so Puppy will know to boot from the hard drive.

Finally, I add an entry to grub like this:

title Puppy 4.0 with pmedia=idehd
rootnoverify (hd0,6)
kernel /puppy40/vmlinuz root=/dev/ram0 PMEDIA=idehd
initrd /puppy40/initrd.gz


This has worked well for several generations of Puppy. When I have installed a new version of Puppy to a partition where I had a previous version, it has picked up my save file. When I have installed to a new partition, it has queried me on the first shut down to create a save file.

Until Puppy 4.0. When I shutdown or reboot, it does not ask me to create a save file and then, understandably, reports Session Not Saved upon exiting.

Given how I have installed, is there something I need to do to trigger the save dialog?

Various forums have mentioned an explicit save icon on the desktop. I examined the desktop and spelunked the menus but haven't seen such an option.

I completely reformatted the disk before installing Puppy (and some other things) so I do not have an old save file to drop into the partition.

Any thoughts?
 
Old 05-19-2008, 08:30 PM   #2
Honeysuckle
Member
 
Registered: Dec 2007
Location: Australia
Distribution: Puppy, debian
Posts: 118

Rep: Reputation: 15
Quote:
Originally Posted by yosaba View Post
Hi,
Any thoughts?
I just booted Puppy 4.0 a while ago and I got the prompt for a save file. Have you tried booting with puppy pfix=ram to see if you get the save prompt then?
 
Old 05-20-2008, 11:55 AM   #3
yosaba
LQ Newbie
 
Registered: May 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Hi,

I tried using pfix=ram but still did not get a prompt to save the session. I located an old pup_save.3fs from a Puppy 1.09 installation and tested putting it in various of my 5 partitions to no avail. I tried using a PHOME kernel option as I believe was needed in Puppy 1.x days, again without success.

I looked at different commands available from the command line, e.g., save2image, but none seemed applicable. Does anyone know the script for getting puppy to save the session? (savesession-dvd would save it to the wrong place.)

I'd appreciate any other ideas.

Thanks!
 
Old 05-20-2008, 12:57 PM   #4
Honeysuckle
Member
 
Registered: Dec 2007
Location: Australia
Distribution: Puppy, debian
Posts: 118

Rep: Reputation: 15
Quote:
Originally Posted by yosaba View Post
Hi,
I tried using pfix=ram
Did you type puppy pfix=ram (the "puppy" is important)? If not, give it another whirl.

I thought before that you might not have been being prompted because it was picking up another save file (ie it thought it was working with a save file) but you say it says that it's not saving the session, so that may not be what's happening.

You don't need isolinux on your hard drive, just the other 4 files.
Also "root=/dev/ram0" is an old thing and doesn't apply to the newer puppies. (But I don't know if either of those things is significant to what's happening).

Rather than putting old pup save files in, I'd be inclined to delete or rename any on you drive, just in case it is "getting confused" in some way. Otherwise, I'm clueless

Last edited by Honeysuckle; 05-20-2008 at 12:58 PM. Reason: grammar/punctuation
 
Old 05-20-2008, 03:09 PM   #5
yosaba
LQ Newbie
 
Registered: May 2008
Posts: 3

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by Honeysuckle View Post
Did you type puppy pfix=ram (the "puppy" is important)?
Hi Honeysuckle,

Thanks for the suggestion. I am booting from the hard drive using the grub entry in my original post. Where should I type "puppy pfix=ram"?

Do I need to boot from the CD to create a save file? (I have not had to do that before.)

Thanks
 
Old 05-20-2008, 09:28 PM   #6
Honeysuckle
Member
 
Registered: Dec 2007
Location: Australia
Distribution: Puppy, debian
Posts: 118

Rep: Reputation: 15
I'm so sorry - I wasn't clear. Yes, try booting from the cd (you might not even need puppy pfix=ram, try it without first). If you don't get the prompt, then type puppy pfix=ram when it stops and says "boot" (ie when you are booting your cd, not booting from the hard drive).
 
Old 06-30-2008, 12:28 AM   #7
kagashe
LQ Newbie
 
Registered: Sep 2005
Distribution: Ubuntu 7.10
Posts: 16

Rep: Reputation: 0
Quote:
Originally Posted by yosaba View Post
Hi,

I have been running Puppy since the 1.x series. I install to the hard drive using something like the "poorman's install" by mounting the iso, copying pup_XXX.sfs and zdrv_XXX to the root of a previously formatted partition and copying vmlinuz, isolinux.* and initrd.gz to an appropriate sub-directory. Then I add a file called
PUPIDE
to the root of the partition so Puppy will know to boot from the hard drive.

Finally, I add an entry to grub like this:

title Puppy 4.0 with pmedia=idehd
rootnoverify (hd0,6)
kernel /puppy40/vmlinuz root=/dev/ram0 PMEDIA=idehd
initrd /puppy40/initrd.gz
Delete root=/dev/ram0 and add psubdir=puppy40 in the kernel line. The changed line will become:
Quote:
kernel /puppy40/vmlinuz pmedia=idehd psubdir=puppy40
kagashe
 
Old 07-20-2008, 03:16 PM   #8
poorman_installer
LQ Newbie
 
Registered: Jul 2008
Distribution: slax
Posts: 11

Rep: Reputation: 0
Hi, I have pretty much the same unexpected behaviour as the one yosaba's reporting.

The issue is identical on my desktop pc, whereas on my laptop all goes well. I am suspecting that this is a pata vs. sata issue.
I mean, my desktop has older IDE (PATA) hard drives, while the laptop has everything SATA. That's what comes to my mind.

I can't remember if the problem reproduces itself with the experimental 6.25 kernel or not.

Anyway, the "bug" triggers, just when you boot from a frugal install on HD, whereas booting orthodoxly from the CD gives no trouble.

Is there an alternate way of preentively make puppy save changes on pup_save.2fs PRIOR system shutdown?

It seems it doesn't suffice to create a formatted ext2 image file and naming it following the scheme.

One should dig into puppy shutdown scripts to see how it structures pup_save files.

Any suggestion?

Thanks,
Marco.
 
Old 07-25-2008, 04:27 AM   #9
vanchutr
LQ Newbie
 
Registered: Aug 2006
Posts: 6

Rep: Reputation: 0
Quote:
Does anyone know the script for getting puppy to save the session? (savesession-dvd would save it to the wrong place.)
The script for getting puppy to save the session is "/etc/rc.d/rc.shutdown"

Puppy 4.00 will not save session (with frugall install). I "trick it" in this manner:

0. Use the "rc.shutdown" of Puppy 3.01 (extract/copy from Puppy 3.01)
1. Before shutdown (in the first time of running Puppy 4.00), copy the rc.shutdown of Puppy 3.01 in to /etc/rc.d (Override the rc.shutdown of Puppy 4.00)
3. Now shutdown or restart Puppy. You will be prompted to save "pup_save.2fs"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Run Puppy via USB mid XP session flotoonie Puppy 2 03-12-2008 12:01 AM
Puppy, trying to save session in Vista cklam Linux - Newbie 2 09-25-2007 09:32 PM
Grafpup Live CD with Puppy 2.0 Save Settings File pixturesk Grafpup 7 06-06-2007 08:23 PM
I cannot reboot with a saves session of Puppy 2.0.2 jolphil Puppy 1 09-08-2006 01:57 PM
xfce4-session fails to save session ! OneManArmy Debian 0 12-10-2004 02:14 PM


All times are GMT -5. The time now is 06:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration