LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Puppy
User Name
Password
Puppy This forum is for the discussion of Puppy Linux.

Notices

Reply
 
Search this Thread
Old 08-05-2008, 11:17 AM   #1
AndyL
LQ Newbie
 
Registered: Aug 2008
Posts: 2

Rep: Reputation: 0
Question Newbie: 'Checking Filesystem' message at start up


I'm really new to Linux (and Puppy of course) so I'm struggling a little . .

I have Puppy loaded to HD, in a new partition formated ext2.

Install went well, and Grub is working fine with Puppy and XP.

I have 2 problems:
1) When Puppy loads I get a msge stating that the filesystem is being checked. Seems to scroll very slowly . . . . . When completed everything seems fine.
2) Having saved a pup_save... file the first time I set this up, I followed the instructions in GRUB to save another pup_save.. file in /puppy400. So now I get asked which one to use at boot up! As I don't seem to be able to find /root to delete the first file, I'm a little stumped.

Any help for an ageing ex-windows user most welcome!

Thanks guys

Andy
 
Old 08-05-2008, 02:00 PM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
I have not run puppy. But I can tell you that the ext2 filesystem should be checked from to time. (The need/desirability of checking journaling filesystems like ext3 can and has been debated.) And checking filesystems (from the MS world, think scandisk) can take a while (depending on size, disk speed, etc.). Hopefully this is not done on every boot. (Something like every 20 to 40 boots or 6 months -- whichever comes first -- is common.) It is also normal to check the filesystem if the computer was not shut down properly; i.e. if the partition was not unmounted (or remounted read only) first.

I am not sure about your mention of "/root." I would expect the command you need to delete the first file to be (run as root):

Code:
rm /puppy200
(or whatever the filename actually was ... I just made up "200" )

You should be able to see everything in your root directory (except "hidden" files, which start with a dot) using:

Code:
ls /

Last edited by blackhole54; 08-05-2008 at 02:03 PM.
 
Old 08-06-2008, 05:44 AM   #3
AndyL
LQ Newbie
 
Registered: Aug 2008
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks for your reply - the Filesystem Check seems to happen everytime I load Puppy - which is a bit of a pain!

Think I need to look at what commands are available to me to sort out the other file problem . . . Still a lot to learn!

Andy
 
Old 08-06-2008, 09:04 AM   #4
Honeysuckle
Member
 
Registered: Dec 2007
Location: Australia
Distribution: Puppy, debian
Posts: 118

Rep: Reputation: 15
Assuming you are using the latest Puppy, your pup_save file (or one of them!) should be in /home/Dingo (could be /mnt/home/Dingo, I can't remember if I've put mine somewhere strange). You can also search for files by using Menu -> Filesystem -> Pfind file finder.
 
Old 08-07-2008, 01:28 AM   #5
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by AndyL View Post
the Filesystem Check seems to happen everytime I load Puppy - which is a bit of a pain!
This post makes it sound like that used to be the default action, but that it has been changed. But that post is quite recent (July 15) so maybe the change hasn't made it down to the released version yet. Or perhaps you don't have the latest.

I would quess that it is controlled in a script somewhere, so it might not be difficult to change the behavior yourself. But that might be a bit much to tackle if you are still new to Linux.
 
Old 09-03-2008, 08:07 PM   #6
davec51
LQ Newbie
 
Registered: Jun 2006
Location: New York
Distribution: Puppy
Posts: 18

Rep: Reputation: 2
My Easy Solution

Change the ext2 filesystem to ext3 and you won't get a tedious file check each time you boot. I don't remember how to do this, but it worked for me. You might check the Puppy forums for the method, or someone here could tell you. It takes only a single command-line command.
 
Old 09-04-2008, 03:26 AM   #7
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by davec51 View Post
Change the ext2 filesystem to ext3 and you won't get a tedious file check each time you boot. I don't remember how to do this, but it worked for me. You might check the Puppy forums for the method, or someone here could tell you. It takes only a single command-line command.
Code:
tune2fs -j /dev/sda1
Replace /dev/sda1 with the name of the actual partition.

You can be more specific by also using the -J option. See the tune2fs man page for more info.
 
Old 09-09-2008, 12:23 AM   #8
vvnslm
LQ Newbie
 
Registered: May 2008
Posts: 17
Blog Entries: 1

Rep: Reputation: 0
Smile

When Puppy loads I get a msge stating that the filesystem is being checked. Seems to scroll very slowly . . . . . When completed everything seems fine.

when windows bootup you only see a screen ,hence what ever is happenning is hidden by that screen..but in linux (puppy) what you see is the booting up of linux ,,,showing what is happening during booting ...
this is not a problem
 
Old 09-10-2008, 05:18 AM   #9
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by vvnslm View Post
when windows bootup you only see a screen ,hence what ever is happenning is hidden by that screen..but in linux (puppy) what you see is the booting up of linux ,,,showing what is happening during booting ...
this is not a problem
It is not a problem per se. But if the filesystem check (fsck) takes very long, occurs on every boot, and if you boot frequently, it can be annoying. This is what I understood to be the OP's complaint. Except after improper shutdowns, it used to be common for Linux distros to only do a filesystem check every 20 something or every 30 something boots (or every 6 months, whichever came first). Now, with journaling file systems, I think some distros, by default, don't check at all at boot time. (It can and has been debated whether that is a good thing).

It also seems to be becoming fashionable with certain Linux distros to hide the boot messages by default, just like MS Windows does. Personally, I like to see the messages scroll by. But then, I also like the command line.




Now that I am revisiting the issue of file system checks, it occurs to me that Puppy might be announcing that it is going to do a filesystem check and then very quickly announce that the filesystem is "clean." If this happens, then it is actually skipping the filesystem check because the filesystem was properly "unmounted" at the previous shutdown and it is not yet time to check it. The fsck program itself determines whether it is time to check.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Checking the integrity of an Ubuntu filesystem silent_n0va Linux - Newbie 1 07-30-2008 05:15 AM
dm-crypted root with filesystem checking /y0shi Slackware 3 02-16-2008 06:55 AM
Problem checking root filesystem when booting Slackware daschaich Slackware 2 09-01-2006 09:55 PM
booting stops at - checking root filesystem varun_saa Mandriva 3 09-29-2005 12:58 AM
RAID 0 Filesystem checking? kennic Red Hat 2 11-12-2004 01:27 AM


All times are GMT -5. The time now is 07:10 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration