LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Puppy
User Name
Password
Puppy This forum is for the discussion of Puppy Linux.

Notices



Reply
 
Search this Thread
Old 02-07-2011, 08:41 PM   #1
ladyoxana
LQ Newbie
 
Registered: Jan 2011
Posts: 10

Rep: Reputation: 0
Ethernet issue narrowed down to DHCP?


Thank you for any possible support.

I am trying to install Puppy on Thinkpad a20m. Everything is great. Easy frugal install and all. However, when connecting to Internet through the router D-Link WBR 2310, I can get online only for about 10 minutes. Then, DHCP cannot get the address. Any idea? I have spent a couple of weeks looking around for another Linux OS that will work on this laptop with 128mb RAM. Want to come back to Puppy. But...without Internet up and running, it won't do for me.
 
Old 02-07-2011, 09:18 PM   #2
Nikosis
Member
 
Registered: Dec 2005
Location: In front of the monitor
Distribution: Slackware
Posts: 312

Rep: Reputation: 59
Can you post your last dhcpcd logs.
 
Old 02-08-2011, 01:47 AM   #3
Wu2wei
Member
 
Registered: Jan 2010
Posts: 60

Rep: Reputation: 26
Try two approaches.

1. Use Network Wizard, not Simple Network Setup. Test eth0, if working click on Auto DHCP and follow the procedure; don't forget to save!

2. If this doesn't work and your router is properly configured (is it? No 10 minute time-out?), then use Static IP instead of Auto DHCP.
Nameservers should be already in, but if they are not, look them up under Menu-System-IPinfo tab DNS.

Much success.

PS: For what it is worth...here is another post re an A20 Laptop.
http://www.linuxquestions.org/questi...ing-hd-861018/

Last edited by Wu2wei; 02-08-2011 at 01:51 AM.
 
Old 02-08-2011, 10:52 PM   #4
Indy452
Member
 
Registered: Jul 2008
Location: Kansan
Distribution: solydK
Posts: 78

Rep: Reputation: 16
Quote:
Originally Posted by ladyoxana View Post
Thank you for any possible support.

I am trying to install Puppy on Thinkpad a20m. Everything is great. Easy frugal install and all. However, when connecting to Internet through the router D-Link WBR 2310, I can get online only for about 10 minutes. Then, DHCP cannot get the address. Any idea? I have spent a couple of weeks looking around for another Linux OS that will work on this laptop with 128mb RAM. Want to come back to Puppy. But...without Internet up and running, it won't do for me.
Just curious, which version of puppy are you able to install to the a20m? I have an a20P I've been having issues with puppy seeing my hard drive...Perhaps I should try the version you are working with..
 
Old 02-09-2011, 08:30 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 12,153

Rep: Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783Reputation: 783
Is this a wired or wireless connection to the router?
How many other computers / devices are connected to the router?
Are they all configured to use DHCP?
If there are other computers on your network and are they still able to get online?
 
Old 02-09-2011, 04:05 PM   #6
ladyoxana
LQ Newbie
 
Registered: Jan 2011
Posts: 10

Original Poster
Rep: Reputation: 0
I installed puppy 4.2 retro kernel 2.6.21.7 with seamonkey. Any versions higher do not automatically see the HDD. I have to do run around, and I do not like it.

I have D-link router WBR 2310. 3 computers on the router. All wired , OS Ubuntu, and all work fine with DHCP. Renew lease is 999 minutes.

I tried Macpup 511. Love it. It is better on the Internet issue, and also sees all drives.


Thanks for replies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DHCP CLIENT Issue w/ ISP DHCP Server itsecx@gmail.com Linux - Networking 1 08-26-2010 10:27 AM
Ethernet problem - IP not detected by DHCP andigeniu Linux - Newbie 10 08-20-2006 09:26 AM
Ethernet and DHCP problem schechtman Mandriva 3 09-05-2004 08:39 PM
ethernet can't autoconfig via DHCP lurp Fedora 5 06-13-2004 07:14 AM
ok... narrowed the problem down madfitz Linux - Newbie 1 06-30-2003 06:32 PM


All times are GMT -5. The time now is 02:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration