LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Puppy (http://www.linuxquestions.org/questions/puppy-71/)
-   -   Can't boot puppy on a troubled SCSI disk system (http://www.linuxquestions.org/questions/puppy-71/cant-boot-puppy-on-a-troubled-scsi-disk-system-475805/)

pofadda 08-21-2006 03:41 AM

Can't boot puppy on a troubled SCSI disk system
 
Small panic here...

A machine acting a file server but running Windows 2000 on a netware Network using a trio of SCSI disks had a partition disaster on disk 0.
The initial BIOS message was:
Ch A ... Start unit request failed
and the SCSI (Ctrl-A) repair utility said when verifying #0:
Host adapter status 00h - No host adapter
Targer status 02h - Check condition
Sense key 02h - Not ready

the others - disks 01 & 02 were all fine.

So I attempted to boot the machine with a Puppy CD ('pfix=ram') but it had a kernel panic saying:
Error: can't find Puppy on idehd boot media
PUPMODE=1 PDEV=
Kernel panic - not syncing. Attempted to kill init!

...and there it stayed.

Was my fundamental error to try to run Puppy even in RAM on a SCSI box? Or will it work on a different boot option?

I hope someone can help!

GuestToo 08-21-2006 03:41 PM

i think the bios is booting the cd properly

then the kernal starts Puppy in the initial ram drive (initrd)

but Puppy can't find it's files

"Error: can't find Puppy on idehd boot media" means that Puppy is looking for it's files on an ide hard drive, but it should be looking on the cd

the cd seems to start with "PMEDIA=idecd" ... i don't know if the Puppy cd can boot properly on a scsi cd drive or not ... i suppose the boot option for a scsi cd drive would be something like "PMEDIA=scsicd"

"PDEV=" shows that it did not find the device where the Puppy files are located

"Kernel panic - not syncing" just means that the kernel is playing it safe and not trying to write anything to the hard drives

i don't know if Puppy will boot from a scsi cd drive or not ... if it can, you would probably have to type in a boot option for PMEDIA=

pofadda 08-21-2006 03:49 PM

Thanks for the response. I tried, in desperation, to use 'scsicd' but it seemed to mean nothing to puppy :-(

_Somebody_ must have got Puppy running on SCSI...

GuestToo 08-22-2006 10:57 AM

Linux usually uses scsi emulation for ide drives anyway, so maybe Puppy should normally just boot from a scsi drive with no problems. I don't really know, i have an ide drive. Actually, I think Linux usually has better driver support for scsi than ide.

the PMEDIA= boot option is just used in the Puppy init script, written by Barry, and that variable was not used in the Puppy 1.x series

you could post your questions on the Puppy forum, where Barry is likely to see it
http://www.murga.org/~puppy/


All times are GMT -5. The time now is 12:18 PM.