LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices



Reply
 
Search this Thread
Old 04-01-2006, 09:00 PM   #1
cmplet-noobie
LQ Newbie
 
Registered: Jan 2006
Posts: 23

Rep: Reputation: 15
Segmentation fault


I'm trying to launch Maya 7.0 on FC4 but when I try to launch the program i get a Segmentation fault. I've posted the error below:

[root@kaleb bin]# ls
apcw fg_copy imgcvt.bin mkmishader
awpcw filePaste imgdiff opa
blur2d filePaste.bin imgdiff.bin plug-ins
blur2d.bin fileStats interlace Render
Cg fileStats.bin interlace.bin rendererDesc
chrome FurRenderer l10n res
components helpTable launchNetscapeHelp stdlib.aws
defaults imconvert maya stdlib.msl
delace imf_copy Maya7.0 toxpm
delace.bin imf_diff maya.bin unsupported
dispatch_maya_render imf_disp mayaClockServer wrl2ma
fcheck imf_info mayald wrl2ma.bin
fcheck.bin imgcvt mayaServerTest xunmapwindow
[root@kaleb bin]# ./maya
Segmentation fault
[root@kaleb bin]# ./Maya7.0
Segmentation fault
 
Old 04-01-2006, 11:24 PM   #2
asgeirss
Member
 
Registered: Aug 2003
Location: Vancouver, Canada
Distribution: RH, SL
Posts: 37

Rep: Reputation: 15
Are you sure that you are using the right binaries for your system?

Generally if the program seg faults, you have either installed the wrong version, or it is not fully installed. From the info you provide here, there is little anyone can do to help you.
 
Old 04-02-2006, 07:05 PM   #3
punit_arya
LQ Newbie
 
Registered: May 2005
Location: Bangalore, India
Distribution: Slackware64 14
Posts: 6

Rep: Reputation: 0
run in background

hi
i had the same problem but with a different software (opera) on a different system (compaq notebook) & different distro(slackware). nevertheless i tried running in background & it worked.
 
Old 04-03-2006, 03:52 AM   #4
cppkid
Member
 
Registered: Jul 2004
Location: Pakistan
Distribution: Ubuntu
Posts: 185

Rep: Reputation: 30
I think the problem is that you are using some wrong binary, also you are using FC4, which is not that much stable and can cause the problem. Segmentation Fault is basically memory error... It doesn't mean that you are out of memory... It means that you are accessing some memory that is not allocated to you... or something like that...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yast segmentation fault, system freezing - nvidia driver at fault? BaltikaTroika Suse/Novell 2 12-02-2005 10:34 AM
segmentation fault lmvent Programming 2 10-20-2005 04:14 PM
why segmentation fault??? andrewnow Programming 8 03-26-2005 07:50 PM
segmentation fault tej Linux - Hardware 1 02-08-2005 01:27 AM
ls segmentation fault sucho Linux - General 1 06-23-2004 07:44 PM


All times are GMT -5. The time now is 02:23 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration