LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Programming (http://www.linuxquestions.org/questions/programming-9/)
-   -   phpinfo display_errors not set to On after value set to On in php.ini (http://www.linuxquestions.org/questions/programming-9/phpinfo-display_errors-not-set-to-on-after-value-set-to-on-in-php-ini-870919/)

famsinyi 03-25-2011 07:47 AM

phpinfo display_errors not set to On after value set to On in php.ini
 
Hi,

I had set the display_errors to On in the php.ini. But the phpinfo() still show it as off. The php.ini file that I wrote to was the one shown in phpinfo(), namely /etc/php.ini. The setting couldn't be reflected even after a reboot. I suspected that the /etc/php.ini was not the one get run so I rename it to php2.ini and reboot. phpinfo() still working and displayed the loaded php.ini file is /etc/php.ini.

can someone help? THANKS

carltm 03-25-2011 08:14 AM

I'm sure that your php is preconfigured to use /etc/php.ini.

Two thing I would check: is /etc/php.ini world readable and
are you sure there are no syntax errors in /etc/php.ini?

See if you can find anything in your apache error log file.

Nominal Animal 03-25-2011 08:38 AM

Also check if your Apache configuration or .htaccess files contain
Code:

php_flag display_errors off
or
Code:

php_admin_flag display_errors off
since these can be used to override the php.ini settings.

famsinyi 03-25-2011 08:39 PM

Quote:

Originally Posted by carltm (Post 4302845)
I'm sure that your php is preconfigured to use /etc/php.ini.

Two thing I would check: is /etc/php.ini world readable and
are you sure there are no syntax errors in /etc/php.ini?

See if you can find anything in your apache error log file.

After reading the apache error log file, I found the php errors logged there. That is my original purpose. I think that's should be the error on phpinfo() couldn't reflect the correct information. Well I leave it as it is since now I can continue php programming. THANK YOU VERY MUCH !!!

famsinyi 03-25-2011 08:41 PM

Quote:

Originally Posted by Nominal Animal (Post 4302876)
Also check if your Apache configuration or .htaccess files contain
Code:

php_flag display_errors off
or
Code:

php_admin_flag display_errors off
since these can be used to override the php.ini settings.

THANK YOU VERY MUCH !!! I'll keep this for future reference.


All times are GMT -5. The time now is 01:53 AM.