LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices

Reply
 
Search this Thread
Old 02-22-2011, 04:22 AM   #1
varunkrishna
LQ Newbie
 
Registered: Apr 2010
Posts: 8

Rep: Reputation: 0
Red face Lam MPI -s option


I am using Lam mpi. The problem I am facing is that, I am not able to use the "-s" option for lam mpi which is used for loading the program from a particular node and then using the nodes in the cluster to execute the program.

Now I have to copy instance of the executable to every node for the program to run in the cluster. Is there anyway to load the program from a particular node and then use the cluster nodes in its execution without manually copying the executable to each and every node in the cluster
 
Old 02-23-2011, 01:38 AM   #2
EricTRA
Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290Reputation: 1290
Hello,

You marked your thread as solved. Would you mind sharing your solution with the community so that others in similar situations can try if it works for them too? Thanks in advance.

Kind regards,

Eric
 
Old 02-23-2011, 11:29 AM   #3
Reuti
Senior Member
 
Registered: Dec 2004
Location: Marburg, Germany
Distribution: openSUSE 13.1
Posts: 1,320

Rep: Reputation: 252Reputation: 252Reputation: 252
I wouldn't recommend to use LAM/MPI any longer nowadays. The follow-up project is Open MPI.
 
Old 02-23-2011, 11:08 PM   #4
varunkrishna
LQ Newbie
 
Registered: Apr 2010
Posts: 8

Original Poster
Rep: Reputation: 0
The format of using -s option is " mpirun -s <Nodeid> N hostfile
 
  


Reply

Tags
cluster


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
MPI vs LAM/MPI vs OpenMPI vs MPICH2 manojg Linux - General 0 11-28-2010 12:37 PM
lamboot problem in LAM/MPI Abhishek Agarwal Linux - General 2 11-07-2006 02:40 AM
lamboot problem in LAM/MPI Abhishek Agarwal Programming 1 11-06-2006 08:04 AM
stupid question on LAM/MPI funkymunky Programming 2 10-17-2003 11:41 AM
Lam/mpi Rex_chaos Linux - General 0 08-29-2001 11:00 AM


All times are GMT -5. The time now is 03:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration