LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Programming (http://www.linuxquestions.org/questions/programming-9/)
-   -   Installation Tutorial Apache 2, PHP 4, MySQL 3.23 (http://www.linuxquestions.org/questions/programming-9/installation-tutorial-apache-2-php-4-mysql-3-23-a-24736/)

freddymio 07-01-2002 10:08 AM

Installation Tutorial Apache 2, PHP 4, MySQL 3.23
 
Hello!
I'm havin' a very hard time installing Apache 2, and PHP 4. Somehow I have installed MySQL and it seems to work (step 1 in an old tutprial, something in the newer versions of Apache and PHP seem to have changed, like PHP 4 does not take the "--with-apache=XXX" switch any longer.
In that tutorial as step 2 there is a first installation phase for Apache, then PHP, and then the 2nd phase for Apache.
Please some help! Thanks in advance.
Freddy

j-ray 07-03-2002 07:04 AM

i donīt know exactly whatīs your problem. i would install mysql first then apache then php. but you need read the INSTALL that comes with the download. apache must be configured --with-shared=`max`or similar flag to enable the use of third party modules. ./configure --help will show you the most important options. you should configure php --with-apxs=/path/apache/bin/apxs and with mysql.
good luck, maybe someonelse knows better
jens

freddymio 07-03-2002 09:40 AM

Thanks j-ray,
As a wrap up of what I've done:

1.- Installed 'MySQL-3.23xxx' normal and 'MySQL-client-3.23xx' otherwise some problems with 'mysqladmin' and passwords. Installed in that order.

2.- Installed Apache 2.0.39. I did read the installation instructions but not all is there. So, I fusioned all the help I got for Apache and PHP from the forums, and configured Apache as follows in one line:
./configure --enable-so --enable-rewrite --enable-module=most --enable-shared=max
Then 'make', then 'make install'. Apache by default installs itself at /usr/local/apache2. Then 'make clean' to free up memory.
Then at the apache default directory, I edited the file ./conf/httpd.conf and changed the 'Servername' to 'localhost'. The DocumentRoot directive I left untouch (directory where your web pages are gonna be executed: './htdocs').

3.-Installed PHP4.2.2 (previous versions with installation bugs!). I used the following command to configure PHP, in one line:
./configure --with-mysql --with-apxs2=/usr/local/apache2/bin/apxs
Pay attention to the second flag of the configuration command!
Then I edited once more the ./conf/httpd.conf file from apache's default directory, as follows:
AddType application/x-httpd-php .phtml
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps

All tests seem to work, so I'll start developing. Thanks to all!


All times are GMT -5. The time now is 01:09 AM.