LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices



Reply
 
Search this Thread
Old 09-30-2008, 09:08 AM   #1
niteshg
LQ Newbie
 
Registered: Nov 2004
Location: NJ
Posts: 29

Rep: Reputation: 15
GDB Dwarf error no debuging symbols found


I have a program written c and am compiling it on SUN systemin gcc which is giving segmentation fault.I am trying to debug the program using gdb but when I run it in gdb promptI get the following output.
GDB Dwarf error : Cannot handle DW_FORM_strp in DWARF reader

(gdb)run

Starting program : /.././ a.out
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.

(gdb)backtrace
0x12d38 in ?? ()
#0 0x12d38 in ?? ()
#1 0x11770 in ?? ()
#2 0x10978 in ?? ()

I am not able to see the place where the segmentation fault occured.
I am compiling the program with the -g option set.
 
Old 10-01-2008, 04:11 AM   #2
cicorino
Member
 
Registered: May 2006
Location: Italy
Distribution: Slackware, Slackware64
Posts: 31

Rep: Reputation: 16
maybe you can try '-ggdb' instead of '-g'
 
Old 10-09-2008, 01:00 PM   #3
niteshg
LQ Newbie
 
Registered: Nov 2004
Location: NJ
Posts: 29

Original Poster
Rep: Reputation: 15
not working with -ggdb .same result.
 
Old 10-10-2008, 03:51 AM   #4
cicorino
Member
 
Registered: May 2006
Location: Italy
Distribution: Slackware, Slackware64
Posts: 31

Rep: Reputation: 16
can we see the full command that you use to compile/link, please?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gdb debugging assembly with no symbols Four Programming 5 10-01-2008 09:47 PM
libpthread external symbols not found BitterB Programming 6 06-27-2008 04:36 PM
Debuging Evgeny Linux - Security 3 02-15-2005 02:52 PM
gdb complains about dwarf error bdc79 Linux - Software 0 09-16-2004 12:09 AM
i have used 'ggdb3' when i compile a software,why gdb didn't find debugging symbols icoming Programming 0 08-30-2004 02:35 PM


All times are GMT -5. The time now is 07:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration