LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices

Reply
 
Search this Thread
Old 04-11-2005, 05:35 AM   #1
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Rep: Reputation: 30
Error With KDevelop


I am using SuSe9.1 with KDE 3.2, I am using also KDevelop 3.0.2
I just wanted to make a simple hellor world application using C++ so I made new project ->C++ ->simple hello world application then when i try to build or compile i get this error
note : I made the project name "John" and placed it in /home/john/

*cd "/home/john/john" && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -f Makefile.cvs && mkdir "/home/john/john/debug" && cd "/home/john/john/debug" && CXXFLAGS="-O0 -g3" "/home/john/john/configure" --enable-debug=full && cd "/home/john/john/debug/src" && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" gmake -k john.lo
**** Exited with status: 2 ***


thanx in advance
 
Old 04-11-2005, 06:32 AM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Have you installed automake version 1.6 or above?

I had this problem, but it was solved by installing automake 1.6 or above.
 
Old 04-11-2005, 06:44 AM   #3
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
I have automake 1.8
 
Old 04-11-2005, 06:49 AM   #4
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Install automake 1.6. It will not conflict with 1.8.

Actually I installed all the versions available and it worked. I guess it's looking specifically for automake 1.6.

Last edited by vharishankar; 04-11-2005 at 06:50 AM.
 
Old 04-11-2005, 06:59 AM   #5
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
and where can I find the automake 1.6 ?

it is not available on the CD's of SuSe9.1
 
Old 04-11-2005, 10:22 AM   #6
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
If you cannot find pre-packaged binaries for SuSE (try YaST) you could also download source tarball here and compile it:

http://ftp.gnu.org/gnu/automake/
 
Old 04-11-2005, 11:38 AM   #7
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
when i tried Yast i only found the 1.8

but it is really strange that a newer version can't make it work !!
 
Old 04-11-2005, 09:00 PM   #8
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
No. It is more likely a configuration issue, but I haven't been able to work that out. Did you try that download sources which I pointed to?
 
Old 04-12-2005, 04:36 PM   #9
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
I will try them and tell u

thx for the help
 
Old 04-13-2005, 04:15 AM   #10
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
I downloaded these sources and made the following commands (i am not an expert in dealing with sources)

./configure
make
make install

but yet the same problem exist
 
Old 04-14-2005, 05:40 PM   #11
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
I also downloaded KDevelop 3.2 but the same error exists

can someone tell me what to do ?? I have a project to deliver and I don't want to work on the Visual Studio again

this is the error I get

cd '/home/john/iiii' && gmake -f Makefile.cvs && cd '/home/john/iiii' && "/home/john/iiii/configure" && cd '/home/john/iiii/src' && gmake -k -j1 iiii.lo
*** Exited with status: 2 ***

I am really dissapointed as this is my first trial with KDevelop

Last edited by John_Emad; 04-14-2005 at 05:50 PM.
 
Old 04-14-2005, 06:00 PM   #12
John_Emad
Member
 
Registered: Dec 2004
Posts: 196

Original Poster
Rep: Reputation: 30
I finally managed to make it work

I downloaded the libtool from http://www.gnu.org/software/libtool/news.html and it worked thank GOD

thx alot for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kdevelop Makefile Error Chryzmo Programming 4 08-22-2010 03:19 PM
linking error using kdevelop 3.1 gunslinger77 Programming 2 11-24-2004 02:13 PM
Error building kdevelop danielg Linux - Software 1 11-22-2004 07:37 PM
kdevelop: not jumping to error location when clicking on error. sudheernair Linux - Software 0 05-13-2004 07:41 AM
Kdevelop 2.15, QT error paulten Linux - Software 2 03-10-2003 03:54 PM


All times are GMT -5. The time now is 09:49 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration