LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices



Reply
 
Search this Thread
Old 09-04-2004, 10:16 AM   #1
theonebeyond
Member
 
Registered: Aug 2004
Location: Germany
Distribution: Slackware 10.0
Posts: 258

Rep: Reputation: 30
DDD doesn't work


Hi people!

I havea serious problem with DDD ...

When I try to debug my little Qt-Programm, I try to open it inside DDD.

But only an message appears that tells me

"/home/user/init.c: No such file or directory"

When I click on help then, another dialog tells me:

"The given source file could not be loaded. Please check the GDB search path via Edit (R) GDB settings"

Ahh .. yeah ... ok ...

I don't know what that all means ... could someone tell me what exactly I have to do,... because I don't know what path I should set to which value ... and I don't know what is up with this init.c file....

It's the first time I really need a debugger... so I am relatively new to all this... GDB itself works...

I have Slack 10.0 installed DDD is 3.3.8

Thanks a lot!

Greeting, Sascha
 
Old 09-05-2004, 05:34 PM   #2
dakensta
Member
 
Registered: Jun 2003
Location: SEUK
Distribution: Debian & OS X
Posts: 194

Rep: Reputation: 35
Have you turned on debugging when you compile your program (-g or -g<qualifier>)?
 
Old 09-06-2004, 12:38 AM   #3
theonebeyond
Member
 
Registered: Aug 2004
Location: Germany
Distribution: Slackware 10.0
Posts: 258

Original Poster
Rep: Reputation: 30
Hi!

Do I have to? Thought that would only be needed if I want some extra-information in debugging mode? ...

Well I know about the -g option, but did not turn it on myself. I compile a Qt-Programm using a prgramm.pro from Designer and to make it qmake && make ...

Where or how could I turn debugging on in this way?

Thanks for your time!

Greetings, Sascha
 
Old 09-06-2004, 01:33 AM   #4
cppkid
Member
 
Registered: Jul 2004
Location: Pakistan
Distribution: Ubuntu
Posts: 185

Rep: Reputation: 30
Well you must have -g aurguments if you want to debug your application. I never compile QT apps directly, i use kdevelope and i have to enable debug mode in the kdevelope options so there must be some debug mode options in your QT designer somewhere in configurations. well if you didn't find any you can edit the make file and locate the command where it is making the program add -g aurgument in it.
 
Old 09-06-2004, 02:10 AM   #5
theonebeyond
Member
 
Registered: Aug 2004
Location: Germany
Distribution: Slackware 10.0
Posts: 258

Original Poster
Rep: Reputation: 30
Hmm... I don't know how I could tell Designer to use debug option....

I tried it by adding -g to the Makefile that qmake creates ... it works .. it's not the finest way ... but hey! It WORKS!!! :-)

Thanks a lot!

Greeting and Thanks again, Sascha
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
install ddd ohade Mandriva 1 08-15-2005 02:55 AM
DDD parameters`? jnusa Linux - Software 0 12-06-2004 03:52 AM
DDD doesn't work well with KDE? richardsclin Linux - Software 0 09-19-2003 03:23 AM
Ddd Zarnce Slackware 1 07-05-2003 11:02 PM
ddd Tommi Linux - Hardware 0 07-04-2003 01:49 PM


All times are GMT -5. The time now is 12:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration