LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices

Closed Thread
 
Search this Thread
Old 05-12-2012, 08:21 AM   #1
Khaled ELmishad
LQ Newbie
 
Registered: May 2012
Posts: 10

Rep: Reputation: Disabled
crcn ns2 add channel GUI nam throughput problem


Help me on CRCN patch problems:

1.crcn GUI (more than 1 channel) after clicking on start sim
it says:
num_nodes is set 10
Process exitValue: 1
Instead of (0 and starting simulation).
(i.e. nam tr files are empty)

2.Related to 1 add-channel when typing ns test.tcl created by CRCN gui

invoked from within
"_o3 cmd add-channel 0 _o13"
invoked from within
"catch "$self cmd $args" ret"
invoked from within
"if [catch "$self cmd $args" ret] {
set cls [$self info class]
global errorInfo
set savedInfo $errorInfo
error "error when calling class $cls: $args" $..."
(procedure "_o3" line 2)
(SplitObject unknown line 2)
invoked from within
"$ns_ add-channel $i $chan_($i)"
("for" body line 2)
invoked from within
"for {set i 0} {$i < $val(channum) } {incr i} {
$ns_ add-channel $i $chan_($i)
}"
(file "test.tcl" line 43)

3.While running nam file it keeps telling me: node i not defined (i is nodes of connections i is 1 or 2 ..)

4.Installed gnuplot but throughput can not be displayed
 
Old 05-12-2012, 08:37 AM   #2
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,398

Rep: Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963Reputation: 1963
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place. This thread is being closed because it is a duplicate.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to display throughput in CRCN GUI humairaafzal73 Linux - Software 13 05-30-2014 05:11 AM
CRCN ns2 add channel GUI nam throughput problem Khaled ELmishad Linux - Software 37 12-05-2013 02:23 AM
problem in displaying throughput in crcn patch in ns2 humairaafzal73 Linux - Software 0 02-07-2012 04:37 AM
[SOLVED] NS2 Nam Issue atb2010 Linux - Newbie 2 03-17-2011 09:52 AM
problem with opening nam in ns2 MLinux Linux - General 1 11-16-2010 04:01 AM


All times are GMT -5. The time now is 03:36 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration