LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > Programming
User Name
Password
Programming This forum is for all programming questions.
The question does not have to be directly related to Linux and any language is fair game.

Notices

Reply
 
Search this Thread
Old 05-25-2012, 06:05 AM   #1
hcx23
LQ Newbie
 
Registered: May 2012
Posts: 8

Rep: Reputation: Disabled
airprobe/gsm-receiver ./gsm.cc no such file or directory no input data


Hi fellows,

I am trying to compile airprobe/gsm-receiver following this German HOWTO:
http://www.ccc-mannheim.de/wiki/DVB-...n_der_Software

like this: cd airprobe
-gsm-receiver
cd gsm-receiver
./bootstrap
./configure
make
make install

make gives back an error-message that ./gsm.cc does not exist so i put that file into the gsm-receiver path

~/osmocom/airprobe/gsm-receiver

but without success gcc doesn't find this file: http://pastebin.com/9Xt3i05U

How can I fix that problem? Oh by the way I am not a programmer.

Kind regards and many thanks in advance

hcx
 
Old 06-01-2012, 03:15 PM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,143

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
Welcome to LQ.

Assume a gnuradio, that was built with e.g. :
./configure --enable-dependency-tracking --enable-python \
--enable-dot --enable-volk --enable-gruel --enable-gnuradio-core \
--enable-gr-msdd6000 --enable-gr-audio --enable-gr-atsc \
--enable-gr-cvsd-vocoder --enable-gr-gpio --enable-gr-uhd \
--enable-gr-gsm-fr-vocoder --enable-gr-noaa --enable-gr-pager \
--enable-gr-radar-pager --enable-gr-radar-mono --enable-gr-radio-astronomy \
--enable-gr-trellis --enable-gr-video-sdl --enable-gr-wxgui \
--enable-gr-sounder --enable-gr-utils --enable-gnuradio-examples \
--enable-grc

... Then you will have the file(s), that helps generate gsm.cc in gsm-receiver/src/lib :
/usr/local/include/gruel/swig/ gr_intrusive_ptr.i gruel_common.i pmt_swig_doc.i pmt_swig.i

A simple (temporary) workarrond : cd /usr/local/include/
# ln -s gruel/swig/* .
.... where the period ( . ) means the current directory.

( './configure CFLAGS=-I/usr/local/include/gruel/swig/' : No luck.)
And :
I don't see the file gruel_common.i in any of the packages suggested in your link.
( 'apt-get install gnuradio gnuradio-companion' etc.)

.

Last edited by knudfl; 06-01-2012 at 06:29 PM.
 
Old 06-02-2012, 10:31 AM   #3
hcx23
LQ Newbie
 
Registered: May 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
build Gnuradio and gsm.cc error

Hi Knudfl,

I put gnuradio from git git clone git://gnuradio.org/gnuradio. But there is no configure script in the git repository:
AUTHORS docs gr-audio gr-fcd gr-pager gruel gr-vocoder README.building-boost
cmake dtools grc gr-fft gr-qtgui gr-uhd gr-wavelet README.hacking
CMakeLists.txt gnuradio-core gr-comedi gr-howto-write-a-block gr-shd gr-utils gr-wxgui README-win32-mingw-short.txt
COPYING gr-atsc gr-digital gr-noaa gr-trellis gr-video-sdl README volk

so following the buildguide http://gnuradio.org/redmine/projects...iki/BuildGuide
I build gnuradio with cmake like that: mkdir build
$ cd build
$ cmake ../
$ make && make test
$ sudo make install

and I got one error: CMakeFiles/gnuradio-atsc.dir/atsci_viterbi_decoder.cc.o: file not recognized: File truncated

Then I swichted to gr-osmosdr one level above and did: cmake . -DGRUEL_INCLUDE_DIRS="/usr/local/include/gruel/swig"
make
sudo make install

next steps were
cmake . -DGRUEL_INCLUDE_DIRS="/usr/local/include/gruel/swig"
make
sudo make install

export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"
echo 'export LD_LIBRARY_PATH="/usr/local/lib:$LD_LIBRARY_PATH"' > ~./profile

gsm.cc has not been build in /airpriobe/gsm-receiver/src/lib

so I downloaded it from the projects website and copied it manually into the path

Now make brings me a couple of errors:
gsm.cc:7226: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7226: error: ‘arg1’ was not declared in this scope
gsm.cc:7226: error: ‘boost’ has not been declared
gsm.cc:7226: error: expected primary-expression before ‘)’ token
gsm.cc:7226: error: expected ‘;’ before numeric constant
gsm.cc:7240: error: expected type-specifier before ‘boost’
gsm.cc:7240: error: expected ‘>’ before ‘boost’
gsm.cc:7240: error: expected ‘(’ before ‘boost’
gsm.cc:7240: error: ‘boost’ has not been declared
gsm.cc:7240: error: expected primary-expression before ‘>’ token
gsm.cc:7240: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_d_total_count_get(PyObject*, PyObject*)’:
gsm.cc:7256: error: ‘boost’ has not been declared
gsm.cc:7256: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7256: error: ‘arg1’ was not declared in this scope
gsm.cc:7256: error: ‘boost’ has not been declared
gsm.cc:7256: error: expected primary-expression before ‘)’ token
gsm.cc:7256: error: expected ‘;’ before numeric constant
gsm.cc:7267: error: expected type-specifier before ‘boost’
gsm.cc:7267: error: expected ‘>’ before ‘boost’
gsm.cc:7267: error: expected ‘(’ before ‘boost’
gsm.cc:7267: error: ‘boost’ has not been declared
gsm.cc:7267: error: expected primary-expression before ‘>’ token
gsm.cc:7267: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_next_arfcn_set(PyObject*, PyObject*)’:
gsm.cc:7278: error: ‘boost’ has not been declared
gsm.cc:7278: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7278: error: ‘arg1’ was not declared in this scope
gsm.cc:7278: error: ‘boost’ has not been declared
gsm.cc:7278: error: expected primary-expression before ‘)’ token
gsm.cc:7278: error: expected ‘;’ before numeric constant
gsm.cc:7292: error: expected type-specifier before ‘boost’
gsm.cc:7292: error: expected ‘>’ before ‘boost’
gsm.cc:7292: error: expected ‘(’ before ‘boost’
gsm.cc:7292: error: ‘boost’ has not been declared
gsm.cc:7292: error: expected primary-expression before ‘>’ token
gsm.cc:7292: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_next_arfcn_get(PyObject*, PyObject*)’:
gsm.cc:7308: error: ‘boost’ has not been declared
gsm.cc:7308: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7308: error: ‘arg1’ was not declared in this scope
gsm.cc:7308: error: ‘boost’ has not been declared
gsm.cc:7308: error: expected primary-expression before ‘)’ token
gsm.cc:7308: error: expected ‘;’ before numeric constant
gsm.cc:7319: error: expected type-specifier before ‘boost’
gsm.cc:7319: error: expected ‘>’ before ‘boost’
gsm.cc:7319: error: expected ‘(’ before ‘boost’
gsm.cc:7319: error: ‘boost’ has not been declared
gsm.cc:7319: error: expected primary-expression before ‘>’ token
gsm.cc:7319: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_d_hop_good_arfcn_set(PyObject*, PyObject*)’:
gsm.cc:7330: error: ‘boost’ has not been declared
gsm.cc:7330: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7330: error: ‘arg1’ was not declared in this scope
gsm.cc:7330: error: ‘boost’ has not been declared
gsm.cc:7330: error: expected primary-expression before ‘)’ token
gsm.cc:7330: error: expected ‘;’ before numeric constant
gsm.cc:7344: error: expected type-specifier before ‘boost’
gsm.cc:7344: error: expected ‘>’ before ‘boost’
gsm.cc:7344: error: expected ‘(’ before ‘boost’
gsm.cc:7344: error: ‘boost’ has not been declared
gsm.cc:7344: error: expected primary-expression before ‘>’ token
gsm.cc:7344: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_d_hop_good_arfcn_get(PyObject*, PyObject*)’:
gsm.cc:7360: error: ‘boost’ has not been declared
gsm.cc:7360: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7360: error: ‘arg1’ was not declared in this scope
gsm.cc:7360: error: ‘boost’ has not been declared
gsm.cc:7360: error: expected primary-expression before ‘)’ token
gsm.cc:7360: error: expected ‘;’ before numeric constant
gsm.cc:7371: error: expected type-specifier before ‘boost’
gsm.cc:7371: error: expected ‘>’ before ‘boost’
gsm.cc:7371: error: expected ‘(’ before ‘boost’
gsm.cc:7371: error: ‘boost’ has not been declared
gsm.cc:7371: error: expected primary-expression before ‘>’ token
gsm.cc:7371: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_d_hop_bad_arfcn_set(PyObject*, PyObject*)’:
gsm.cc:7382: error: ‘boost’ has not been declared
gsm.cc:7382: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7382: error: ‘arg1’ was not declared in this scope
gsm.cc:7382: error: ‘boost’ has not been declared
gsm.cc:7382: error: expected primary-expression before ‘)’ token
gsm.cc:7382: error: expected ‘;’ before numeric constant
gsm.cc:7396: error: expected type-specifier before ‘boost’
gsm.cc:7396: error: expected ‘>’ before ‘boost’
gsm.cc:7396: error: expected ‘(’ before ‘boost’
gsm.cc:7396: error: ‘boost’ has not been declared
gsm.cc:7396: error: expected primary-expression before ‘>’ token
gsm.cc:7396: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_d_hop_bad_arfcn_get(PyObject*, PyObject*)’:
gsm.cc:7412: error: ‘boost’ has not been declared
gsm.cc:7412: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7412: error: ‘arg1’ was not declared in this scope
gsm.cc:7412: error: ‘boost’ has not been declared
gsm.cc:7412: error: expected primary-expression before ‘)’ token
gsm.cc:7412: error: expected ‘;’ before numeric constant
gsm.cc:7423: error: expected type-specifier before ‘boost’
gsm.cc:7423: error: expected ‘>’ before ‘boost’
gsm.cc:7423: error: expected ‘(’ before ‘boost’
gsm.cc:7423: error: ‘boost’ has not been declared
gsm.cc:7423: error: expected primary-expression before ‘>’ token
gsm.cc:7423: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_sync_state(PyObject*, PyObject*)’:
gsm.cc:7434: error: ‘boost’ has not been declared
gsm.cc:7434: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7434: error: ‘arg1’ was not declared in this scope
gsm.cc:7434: error: ‘boost’ has not been declared
gsm.cc:7434: error: expected primary-expression before ‘)’ token
gsm.cc:7434: error: expected ‘;’ before numeric constant
gsm.cc:7445: error: expected type-specifier before ‘boost’
gsm.cc:7445: error: expected ‘>’ before ‘boost’
gsm.cc:7445: error: expected ‘(’ before ‘boost’
gsm.cc:7445: error: ‘boost’ has not been declared
gsm.cc:7445: error: expected primary-expression before ‘>’ token
gsm.cc:7445: error: expected ‘)’ before ‘;’ token
gsm.cc: In function ‘PyObject* _wrap_gsm_burst_cf_sptr_last_freq_offset(PyObject*, PyObject*)’:
gsm.cc:7456: error: ‘boost’ has not been declared
gsm.cc:7456: error: ‘gsm_burst_cf’ was not declared in this scope
gsm.cc:7456: error: ‘arg1’ was not declared in this scope
gsm.cc:7456: error: ‘boost’ has not been declared
gsm.cc:7456: error: expected primary-expression before ‘)’ token
gsm.cc:7456: error: expected ‘;’ before numeric constant
gsm.cc:7467: error: expected type-specifier before ‘boost’
gsm.cc:7467: error: expected ‘>’ before ‘boost’
gsm.cc:7467: error: expected ‘(’ before ‘boost’

What do you suggest to fix this?

Thanks in advance

hcx23
 
Old 06-02-2012, 11:09 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,143

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
I used a tested? version of gnuradio : gnuradio-3.5.3.1.tar.gz.

Got it from : gnuradio-3.5.3.1-1.fc17.src.rpm
http://dl.fedoraproject.org/pub/fedo...1.fc17.src.rpm
.. to have the right configure options, etc. : The file gnuradio.spec .

Quote:
gsm.cc has not been build in /airpriobe/gsm-receiver/src/lib

so I downloaded it from the projects website and copied it manually into the path
Not sure you can use an "alien" file.
There's a reason why it's supposed to be build "on location".

.
 
Old 06-03-2012, 01:53 PM   #5
hcx23
LQ Newbie
 
Registered: May 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
gnuradio compiler error

Hi Knudfi,

well I tried to compile gnuradio the way you recommended but make brings me this error message: libtool: link: `atsc_derandomizer.lo' is not a valid libtool object
make[6]: *** [libgnuradio-atsc.la] Error 1
make[6]: Leaving directory `/home/hcx/osmocom/gnuradio-3.5.3.1/gr-atsc/src/lib'
make[5]: *** [all] Error 2


libgruel0 and libgruel-dev are installed further swig and swig1.3

Google couldn't help me to fix that error any suggestions what to do?

Kind regards & many thanks in advance

hcx
 
Old 06-03-2012, 04:35 PM   #6
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,143

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
Did you use gnuradio-3.5.3.1 ? ?

And : Which Linux OS are you using ? Name and version, please.
 
Old 06-04-2012, 05:13 AM   #7
hcx23
LQ Newbie
 
Registered: May 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi knudfi,

yes I did use gnuradio-3.5.3.1 as you recommended. My Distro is Backtrack5.1 on Kernel 2.6.39.4

Kind regards,

hcx23
 
Old 06-04-2012, 07:38 AM   #8
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,143

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
Backtrack 5, gnuradio-3.5.3.1. The configure option --enable-gr-uhd was omitted,
to avoid installing uhd.
Code:
./configure --enable-dependency-tracking --enable-python --enable-dot --enable-volk --enable-gruel --enable-gnuradio-core --enable-gr-msdd6000 --enable-gr-audio --enable-gr-atsc --enable-gr-cvsd-vocoder --enable-gr-gpio --enable-gr-gsm-fr-vocoder --enable-gr-noaa --enable-gr-pager --enable-gr-radar-pager --enable-gr-radar-mono --enable-gr-radio-astronomy --enable-gr-trellis --enable-gr-video-sdl --enable-gr-wxgui --enable-gr-sounder --enable-gr-utils --enable-gnuradio-examples --enable-grc
Only packages stopping 'configure' were installed.
# make : No errors.
The Backtrack5 files /usr/local/include/gruel/ are attached.
.
Attached Files
File Type: txt gruel.tar.bz2.txt (15.2 KB, 23 views)

Last edited by knudfl; 06-04-2012 at 07:45 AM.
 
Old 06-04-2012, 10:04 AM   #9
hcx23
LQ Newbie
 
Registered: May 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi knudfi,

sorry but same result as before:

./configure --enable-dependency-tracking --enable-python --enable-dot --enable-volk --enable-gruel --enable-gnuradio-core --enable-gr-msdd6000 --enable-gr-audio --enable-gr-atsc --enable-gr-cvsd-vocoder --enable-gr-gpio --enable-gr-gsm-fr-vocoder --enable-gr-noaa --enable-gr-pager --enable-gr-radar-pager --enable-gr-radar-mono --enable-gr-radio-astronomy --enable-gr-trellis --enable-gr-video-sdl --enable-gr-wxgui --enable-gr-sounder --enable-gr-utils --enable-gnuradio-examples --enable-grc

libtool: link: `atsc_derandomizer.lo' is not a valid libtool object
make[6]: *** [libgnuradio-atsc.la] Error 1
make[6]: Leaving directory `/home/hcx/osmocom/gnuradio-3.5.3.1/gr-atsc/src/lib'
make[5]: *** [all] Error 2


gruel is attached:

/usr/local/include/gruel$ ls -la
total 116
drwxr-xr-x 3 root root 4096 2012-05-12 17:18 .
drwxr-xr-x 21 root root 4096 2012-06-03 18:55 ..
-rw-r--r-- 1 root root 1037 2012-05-12 16:18 api.h
-rw-r--r-- 1 root root 3074 2012-05-12 16:18 attributes.h
-rw-r--r-- 1 root root 4654 2012-05-12 16:18 high_res_timer.h
-rw-r--r-- 1 root root 3355 2012-05-12 16:39 inet.h
-rw-r--r-- 1 root root 1567 2012-05-12 16:18 msg_accepter.h
-rw-r--r-- 1 root root 1453 2012-05-12 16:18 msg_accepter_msgq.h
-rw-r--r-- 1 root root 3171 2012-05-12 16:18 msg_passing.h
-rw-r--r-- 1 root root 2530 2012-05-12 16:18 msg_queue.h
-rw-r--r-- 1 root root 29659 2012-05-12 16:18 pmt.h
-rw-r--r-- 1 root root 2253 2012-05-12 16:18 pmt_pool.h
-rw-r--r-- 1 root root 1718 2012-05-12 16:45 pmt_serial_tags.h
-rw-r--r-- 1 root root 4108 2012-05-12 16:18 pmt_sugar.h
-rw-r--r-- 1 root root 2874 2012-05-12 16:18 realtime.h
drwxr-xr-x 2 root root 4096 2012-05-12 17:18 swig
-rw-r--r-- 1 root root 1348 2012-05-12 16:18 sys_pri.h
-rw-r--r-- 1 root root 1683 2012-05-12 16:18 thread_body_wrapper.h
-rw-r--r-- 1 root root 1120 2012-05-12 16:18 thread_group.h
-rw-r--r-- 1 root root 1343 2012-05-12 16:18 thread.h


Any Ideas?

kind regards,

hcx23
 
Old 06-04-2012, 12:19 PM   #10
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,143

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
# 9.
Quote:
/usr/local/include/gruel$ ls -la
The files you need for 'gsm-receiver' will show up with :
ls -R /usr/local/include/gruel
Code:
/usr/local/include/gruel:
api.h         high_res_timer.h  msg_accepter.h       msg_passing.h  pmt.h       pmt_serial_tags.h  realtime.h  sys_pri.h              thread_group.h
attributes.h  inet.h            msg_accepter_msgq.h  msg_queue.h    pmt_pool.h  pmt_sugar.h        swig/       thread_body_wrapper.h  thread.h

/usr/local/include/gruel/swig:
gr_intrusive_ptr.i  gruel_common.i  pmt_swig_doc.i  pmt_swig.i

Last edited by knudfl; 06-04-2012 at 12:20 PM.
 
Old 06-04-2012, 01:28 PM   #11
hcx23
LQ Newbie
 
Registered: May 2012
Posts: 8

Original Poster
Rep: Reputation: Disabled
Hi knudfi,

Thanks for your help so far so goog I found all of them but what about this

`atsc_derandomizer.lo' is not a valid libtool object?

Kind regards,

hcx23
 
Old 06-04-2012, 02:10 PM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen, DK
Distribution: pclos2014.08, Slack14.1 DebWheezy, +50+ other Linux OS, for test only.
Posts: 14,143

Rep: Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642Reputation: 2642
# 11. The errors : I don't know. I'm using the first release of BT 5.
Version 1 have some updates, I guess. And I never updated anything.
( Updates can cause new errors. And I will probably use this OS only twice a year.)


More general info : Buiding 'gsm-receiver' in Backtrack 5 :
cd /usr/include/ && ln -s /usr/local/include/gruel/swig/gruel_common.i

This may be a lot easier ...
dpkg -i gnuradio-3.5.3.1.bt5_i386.deb gsm-receiver-1.git.bt5_i386.deb

gnuradio https://docs.google.com/open?id=0B7S...kUtd3pFenJOYjg
( The package installs to /usr/local/ ).
gsm-receiver https://docs.google.com/open?id=0B7S...jJkUGpaSm9Ka00

.

Last edited by knudfl; 06-04-2012 at 02:24 PM.
 
Old 09-20-2013, 06:14 AM   #13
speedfenix
LQ Newbie
 
Registered: Sep 2013
Posts: 2

Rep: Reputation: Disabled
Heelp!!!

I am trying to compile airprobe to decode GSM signals with gnuradio radio and wireshark following the stepsof this web: http://www.rtl-sdr.com/rtl-sdr-tutor.../#comment-3227 The problem is when I compile the gsm-receiver with the command make, the error I get is the next one:

compilation terminated. make[5]: * [cch.lo] Error 1 make[5]: se sale del directorio «/home/usuari/Documentos/SDR/airprobe/airprobe/gsm-receiver/src/lib/decoder» make[4]: [all-recursive] Error 1 make[4]: se sale del directorio «/home/usuari/Documentos/SDR/airprobe/airprobe/gsm-receiver/src/lib/decoder» make[3]: [all-recursive] Error 1 make[3]: se sale del directorio «/home/usuari/Documentos/SDR/airprobe/airprobe/gsm-receiver/src/lib» make[2]: [all-recursive] Error 1 make[2]: se sale del directorio «/home/usuari/Documentos/SDR/airprobe/airprobe/gsm-receiver/src» make[1]: [all-recursive] Error 1 make[1]: se sale del directorio «/home/usuari/Documentos/SDR/airprobe/airprobe/gsm-receiver» make: * [all] Error 2

And then when I try to test the application i get another error:

Traceback (most recent call last): File “./gsm_receive_rtl.py”, line 16, in from gnuradio import gr, gru, eng_notation, blks2, optfir File “/usr/local/lib/python2.7/dist-packages/gnuradio/blks2/init.py”, line 37, in exec “from gnuradio.blks2impl.%s import *” % (f,) File “”, line 1, in File “/usr/local/lib/python2.7/dist-packages/gnuradio/blks2impl/pfb_interpolator.py”, line 23, in from gnuradio import gr, optfir File “/usr/local/lib/python2.7/dist-packages/gnuradio/optfir.py”, line 33, in remez = gr.remez AttributeError: ‘module’ object has no attribute ‘remez’

I think that the problem comes from some kind of version incompatibility of python but I’m not sure, can someone help me please?

Lots of thanks!!!
 
Old 09-20-2013, 06:47 AM   #14
crabboy
Moderator
 
Registered: Feb 2001
Location: Atlanta, GA
Distribution: Slackware
Posts: 1,823

Rep: Reputation: 120Reputation: 120
Please post your thread in only one forum. Posting a single thread in the most relevant forum will make it easier for members to help you and will keep the discussion in one place.

http://www.linuxquestions.org/questi...ts-4175477845/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
airprobe/gsm-receiver ./gsm.cc no such file or directory no input data hcx23 Programming 1 06-01-2012 09:50 AM
Gsm antena / Gsm / Wifi / Bluetooh dangerous? level of energy, all you should know frenchn00b General 8 07-08-2009 04:06 PM
playing GSM audio file format Murdock1979 Linux - Software 3 12-17-2008 10:06 AM
LXer: Telsasoft, a Telecommunications Service Assurance Software Company Based in Minneapolis, Minnesota Received Order for a Set of GSM CDR (Call Detail Record) Reports from a Regional GSM Network Service LXer Syndicated Linux News 0 01-03-2006 10:46 PM
"gsm cellular phones data connectivity" nksundaram Linux - General 1 08-23-2001 01:58 AM


All times are GMT -5. The time now is 05:38 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration