LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > Other *NIX
User Name
Password
Other *NIX This forum is for the discussion of any UNIX platform that does not have its own forum. Examples would include HP-UX, IRIX, Darwin, Tru64 and OS X.

Notices

Reply
 
Search this Thread
Old 07-24-2009, 02:08 PM   #1
deadbug
Member
 
Registered: Oct 2002
Location: San Antonio, Texas
Distribution: MDK 8.0, 9.0; RH 7.2, 8.0, 9.0, FC3, FC4, FC5
Posts: 355

Rep: Reputation: 30
OS-X and Linux ext4 file system


I have a triple-boot computer: OS-X, Windows 7 and FC 11. I predominantly use OS-X, which doesn't understand Fedora's ext4 file format. Everytime I boot up I am greeted with a window telling me OS-X couldn't mount the disk and asking if I want to Initialize, Ignore or Eject the disk!

Obviously, I don't want it to initialize my Linux drive, so I've been taking turns ignoring and ejecting. What I'm looking for is a way to permanently tell OS-X to ignore the drive.

Thanks in advance for any suggestions.
 
Old 07-24-2009, 02:51 PM   #2
linus72
Guru
 
Registered: Jan 2009
Location: Gordonsville-AKA Mayberry-Virginia
Distribution: PocketWriter/MinimalX
Posts: 5,084

Rep: Reputation: 336Reputation: 336Reputation: 336Reputation: 336
Well, gues what
Fedora 11's ext4 is also making my debian stuff, including the livecd I was working on, not work either
If i try to use "persistent" feature
it finds fed11 ext4 on hda4 and freaks out.

That sucks huh?
I was thinking about moving fed11 from hd to usb


how are you going to fix it deadbug?
 
Old 07-24-2009, 04:39 PM   #3
deadbug
Member
 
Registered: Oct 2002
Location: San Antonio, Texas
Distribution: MDK 8.0, 9.0; RH 7.2, 8.0, 9.0, FC3, FC4, FC5
Posts: 355

Original Poster
Rep: Reputation: 30
I'm hoping someone knows more about OS-X than I do and can tell me how to configure OS-X to ignore my FC11 drive.

I have no problem with ext4 otherwise. FC11 understands and uses it seamlessly. It is simply not a format Apple has decided to tell is OS about.

Nothing has stopped working; it is just an annoying message I'm greeted with every time I start my computer. It has a BSD core; there has to be a way to do this; I just haven't found it yet.
 
Old 07-25-2009, 07:11 AM   #4
jay73
Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 130Reputation: 130
Don't know, on linux you would edit /etc/fstab and you would use the noauto option to prevent the running OS from mounting this or that specific partition when it boots up. Somewhere OS X must have a similar file but not being an OS X user, I could not tell where, what it is named and whether it supports customization at all.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: The Ext4 Linux file system LXer Syndicated Linux News 0 05-29-2009 06:51 PM
LXer: ext4 File System: Introduction and Benchmarks LXer Syndicated Linux News 0 03-30-2009 08:10 PM
Ext4 File System - Out or Not?? QueenZ Linux - Newbie 12 02-12-2009 05:52 AM
LXer: Migrating to the Newest Linux File System ext4 LXer Syndicated Linux News 0 05-07-2008 03:40 AM
LXer: First benchmarks of the ext4 file system LXer Syndicated Linux News 0 10-21-2006 09:54 PM


All times are GMT -5. The time now is 04:01 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration