LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > MEPIS
User Name
Password
MEPIS This forum is for the discussion of MEPIS Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-04-2006, 01:58 PM   #1
bliss4one
LQ Newbie
 
Registered: Dec 2006
Location: Denver, CO
Distribution: Debian Lenny 5.0
Posts: 23

Rep: Reputation: 15
Post US Robotics 56K Internal Modem:Intstalled no dialtone or connection to the Net!!!


Using a new distribution from MepisLinux magazine (LXFSO8A/09/06)I've set-up most of my hardware with a bit of time and trial. I'm a new user of Linux and glad to have a GUI to help in the installation. My first attempt at installation using a Debian distribution from a Linux Bible had me wiping out my entire Windows OS and all the data on the hard drive!!!! Fortunately I had another older Windows system to do the homework on the Net.

I'm having trouble getting a dial tone and a connection to the internet from my modem. Through moving the options in the kppp configuration I found the location of the modem and the ATI Query confirmed my location. From there when I click "connection" I get the dialog box indicating "activating modem...initializing modem" and then nothing!!???? I located an initialization string through the internet and entered into one of the location for an init-strg and the modem didn't go to the initialization mode at all????

The modem I'm using is the US Robotics 56K FAX INT OEM V.S.22.70 Product number: USR2973. With this number I retrieve the initialization string(s) and a driver for the modem. I could not find a program on my Linux Mephis distribution that would open the file the driver was on. Is this driver needed.

In the last two hours of reading through various threads I've located more information suggesting ways to solve my problems. One of which is entering the common line mode and trying a long line of commands that "should" start the dialing of the phone. Before I try any of this I thought I'd join and post my query specifically with the Linux Mepis forum.

If you need anymore information from me, feel free to contact me at bliss4one@yahoo.com

Blessings and thanks,
Maillo
 
Old 12-05-2006, 02:29 PM   #2
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
Hi bliss4one,

I used kppp for several years before I finally got a cable
line....just a few things...

Is the US Robotics 2973 an external modem? I.E., not a pci
card but a separate box? A separate box will have led
indicators that can help you troubleshoot the connection.

Please don't be insulted...but have you checked the phone line's
physical connection to the modem? (If you hook it to a phone is there a dialtone?)

In kppp have you checked the "show logs" box on the connection
dialog? If so, perhaps you could post those results.

Also,something I once ran into...is your phone connection a
standard pulse tone line or a legacy rotary line?
...beep, beep, beep;or clikity, clikity, clikity...
They each have different codes to dial out.

Since your modem is detected this is should be OK,
but the output of:
$v /dev/modem
will describe where the symbolic link points and the
permissions and groups involved.

Finally, did you check the "use lock file box" when you were
setting up the modem? That particular option once puzzled me
for a good long while. (try it un-checked)

I hope this helps
--Lawrence
 
Old 12-06-2006, 12:06 AM   #3
bliss4one
LQ Newbie
 
Registered: Dec 2006
Location: Denver, CO
Distribution: Debian Lenny 5.0
Posts: 23

Original Poster
Rep: Reputation: 15
Dear Lawrence,

I'm bliss4one or Maillo.
I've checked the obvious phone line connection...hint this Windows based CPU uses the same phoneline to allow this message to be generated. I switch the phoneline from unit to unit to make this session possible. The US Robotics modem is internal. I've put a check in the "show log" box and when I click on connection, the log message appears along with the window indicating that the modem is being initialized...the two window sit with no change for about 30 seconds with no change and then disappear.
How do I know the difference between a standard pulse tone line or a legacy rotary line??? The same line works for the system I'm typing on now...do I need to enter codes somewhere in my system for the different lines and where??

the command line code you share above should be entered where???? in a Konsole window? I will look for the "use lock file box" option and see if it's checked or unchecked.

Thanks for the imformation. I will post the results of my exploration.

Maillo
 
Old 12-06-2006, 11:57 AM   #4
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
Quote:
the command line code you share above should be entered where???? in a Konsole window?
Yes, a console window should work. For instance on my machine--

let01@ark:~$ v /dev/modem
lrwxrwxrwx 1 root root 5 2006-10-31 16:51 /dev/modem -> ttyS1

The first group of letters is the file's permissions..then owner(root),
then group(root),file size(5),date created, and finally that
/dev/modem is a sym link to the port ttyS1.
Where "ttyS1" is the Linux name for com2 in Dos/Windows.
humm.. since you have two modems are you sure the 2973 is the
one being used?

And one other thought..have you used the 2973 under Windows?
(I wouldn't spend much time on this i.e., downloading win
drivers , changing bios etc.), but if you already know, that
would mean the problem is the kppp setup for sure.

The command line function $lspci -v can show what's going on,
or if you prefer a gui approach...in KDE
Main Menu->System->KinfoCenter In KinfoCenter click on PCI
in the list on the left.

For example, I no longer use the motherboard modem that this
box has--but for me at a root shell I get:


root@ark:/#lspci -v | less
.
.
.
02:01.0 Communication controller: Conexant HSF 56k Data/Fax/Voice/Spkp Modem (rev 01)
Subsystem: GVC Corporation Unknown device 0219
Flags: bus master, medium devsel, latency 64, IRQ 11
Memory at ff9f0000 (32-bit, non-prefetchable) [size=64K]
I/O ports at dc00 [size=8]
Capabilities: [40] Power Management version 2
.
.
.
Where the "| less" is a better form of the Dos pipe "|more"
and allows you to scroll to the part of the output that's interesting.
Since you have two modems on the bus you should
get info on both.

In the US, a telephone ordinarily transmits the number you dial as
tones to the exchange..you hear the tones when you dial Legacy lines
use a old technology that simulates a rotary phone...when you dial
you hear click click.. for each digit instead of tones. If you have
a legacy line, the codes are entered in the kppp modem setup under
modem commands, but since you are working in windows without having
to deal with this, you almost certainly have a dtmf(dual-tone-multiple-frequency) line.

Last edited by letitgo; 12-06-2006 at 12:17 PM.
 
Old 12-06-2006, 12:17 PM   #5
bliss4one
LQ Newbie
 
Registered: Dec 2006
Location: Denver, CO
Distribution: Debian Lenny 5.0
Posts: 23

Original Poster
Rep: Reputation: 15
Misunderstanding: There are two separate machines I use. One is a Windows 98 older unit and the other was the Windows ME system that I erase ALL the programs and data from accidentally when I tried to install Debian on it. I purchased the hardware modem and removed the original winmoderm from the motherboard. I've considered putting the other modem in but there's no way to get any software to run it since I can't get on-line. The second unit is the one I've installed Mepis on and will try you're command lines and see what happens.

It's 1:17pm on Wednesday and I haven't tried anything since your first letter and will switch the monitor to the other unit now and see what happens.

Thanks again,
Maillo
 
Old 12-16-2006, 12:47 PM   #6
bliss4one
LQ Newbie
 
Registered: Dec 2006
Location: Denver, CO
Distribution: Debian Lenny 5.0
Posts: 23

Original Poster
Rep: Reputation: 15
Days later, I'm still not any closer to solving the internet problem with my Linux Mephis based computer. I've tried the command line offered by Lawrence and I see that the system recognizes the modem, but still no dialtone or connection to the Net. This is the second time I've installed the Mephis software and I still can't seem to locate the problem.

I see that 170 people have viewed the problem and no one seems to have anything else to offer?? Is it time for install a different Linux program that will have the ppp connection kernal present and functional. Recommendations?

Maillo
 
Old 12-16-2006, 06:50 PM   #7
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
I sorry this has taken so long...but referring to your original post
Quote:
I retrieve the initialization string(s) and a driver for the modem.
I could not find a program on my Linux Mephis distribution that would
open the file the driver was on. Is this driver needed.
The obvious question if not this driver, which driver are you
using? This got me curious so I goggled for awhile and found
a PDF manual for this modem and a specification sheet that
advertises it as "linux compatible" I.E.,not a "win-modem"
But since this is a pci card I think you will still need a
driver...just not one like say setserial for an external
modem. Was there any documentation with the card? I saw that
it's a OEM card so probably came with few extras
hummm..I'm going to poke around the web for awhile and see
what I can find... But meanwhile would you post the results
of the modem description of

root@ark:/#lspci -v | less

And to answer you question, if you need a driver you will need
it with whatever distribution you use--unless someone has a
modem driver included in the distro...but I know of none like
that.
--let
 
Old 12-16-2006, 08:06 PM   #8
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
oops... if i'm reading correctly setserial may well work with your modem... but you'll need some info from lspci -v
This is taken from

http://www.math.sunysb.edu/~comech/tools/PCImodems.html

Quote:
You need to find the IRQ and first I/O address of the device from the /proc/pci file and then use setserial to configure the serial port:

# cat /proc/pci

Bus 0, device 10, function 0:
Communication controller: PCI device 151f:0000 (TOPIC SEMICONDUCTOR Corp) (rev 0).
IRQ 12.
I/O at 0xbc00 [0xbc07].

# cd /dev; test -c ttyS3 || ./MAKEDEV ttyS3; chmod 666 /dev/ttyS3
# setserial /dev/ttyS3 uart 16550A port 0xbc00 irq 12 baud_base 115200 spd_vhi skip_test
# ln -sf /dev/ttyS3 /dev/modem

You can use any other ttyS? device as well. Make sure that the setserial command is issued each time upon the boot-up, making a necessary addition somewhere in /etc/init.d/ or /etc/rc.d/, depending upon your distribution.
This may well work for your modem. Note that the command cat /proc/pci will print out to your monitor the contents of the file /proc/pci and can be used at a non-root console unlike "lspci -v | less" which needs root privileges. I'm
not familiar with the permissions and ownerships in MEPIS
but it looks like you'll need to be root to chmod /dev/ttS3.
Also, you should see if there is already a symbolic link to /dev/modem and if so, remove it before setting a new one with the "ln" command.

Last edited by letitgo; 12-16-2006 at 08:13 PM.
 
Old 12-19-2006, 09:54 AM   #9
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
Just an update if you are still following this thread

A querry to the manufacture brought this reply:
Quote:
Thank you for contacting USRobotics.



To configure the modem in linux, perform the following:

1. Turn off the computer. Insert the modem into a pci slot. If your system has an agp slot, choose any pci slot except the one closest to the agp slot. The pci slot closest to the agp slot shares resources with the agp slot and this may cause difficulty.

2. Restart the computer and login as root. You can verify that you are currently root with the command 'whoami'.

3. Open up a terminal window and type the following commands, (Note: excluding the apostrophes
"which setserial', This will verify that you have the setserial command. If it gives file not found instead of a path (like /usr/bin/setserial), then this program is not installed on your system. You will need to either install setserial, or configure the modem using a custom hardware configuration program that ships with your distribution (like harddrake in Mandrake Linux).

'rm /dev/modem' - This will remove any previous modem devices.

'cd /proc' - To change to the /proc directory.

'cat pci' - This will display a list of all pci devices detected. Search for a "Serial Controller" section. Record the values you seen under the "Serial Controller" section for both the irq (ex. "9") and the I/O information (ex. "0xfff0") If the "Serial Controller" section is not here, try shutting the system off and reseating the modem. Also make sure that your system's bios has plug and play features turned on.

'setserial /dev/ttyS*' - This should list the active serial ports on your system. This command, and the commands that follows are case sensitive, so make sure to capitalize S in ttyS1. Check to see if one of these ports match the values you found in the 'cat pci' command. If so, skip to the ln command. If not, run the following command:

'setserial /dev/ttyS5 irq # port 0x#### autoconfig'

If /dev/ttyS5 already exits, choose a different ttyS* port that does not, like /dev/ttyS6.

The number "#" after irq is the value you found under the "Serial Controller" section of 'cat pci'. The port information is also found under the I/O section "Serial Controller". Make sure that there are no spaces in the port values, example: "port 0xfff0 autoconfig" or, in more detail "port<space>0xfff0<space>autoconfig". A complete example of this command would be:

'setserial /dev/ttyS5 irq 9 port 0xfff0 autoconfig'

- If the above command gives you an error about not being able to create the file, or file not found, try running the following and then repeat the above command:

'mknod -m 666 /dev/ttyS5 c 4 64'

'ln -s /dev/ttyS# /dev/modem', where the ttyS# is the either the serial port that matches the modem's setting that you found in 'cat pci', or the new ttyS5 that you have created. ex: 'ln -s /dev/ttyS5 /dev/modem'

4. Then test your modem through a modem application, such as minicom or kppp.

Newer versions of setserial should save these settings so it works upon reboot. If yours does not, consider updating setserial, or look at the following link for further information: http://www.ibiblio.org/mdw/HOWTO/Serial-HOWTO-10.html

Your customer number is 300872668
Please refer to case # 301418773 if you have any further questions.

If you need further assistance, you can also reach us online at www.usr.com/support
Please include all previous replies when/if responding to this message.


Best Regards,
Franklyn M. at Technical Support
USR Technical Support
-----------------------
Date 19 December 2006
 
Old 12-19-2006, 02:48 PM   #10
tytower
Member
 
Registered: Jun 2006
Location: Oz
Distribution: Mandriva 10.0,10.1,10.2,2006,Mepis 6.0,Opensuse10.2,Puppy 2.14
Posts: 250

Rep: Reputation: 30
careful with the above its a bit old
which setserial, cat pci don't work on my 6.0 distro

Last edited by tytower; 12-20-2006 at 03:23 PM.
 
Old 12-20-2006, 08:55 PM   #11
bliss4one
LQ Newbie
 
Registered: Dec 2006
Location: Denver, CO
Distribution: Debian Lenny 5.0
Posts: 23

Original Poster
Rep: Reputation: 15
Okay, the learning curve is bending again. All of the above technical info with regards to setserial, cat pci didn't work on the distro I'm using: Simply Mephis 6.0. So I've learned that the first commands I learned here: lspci -v produced the listing of all the pci located on the computer. Not sure what to do with the information than to note that the modem was identified.

When back to the first thing I was told to look for: an intialization string for the modem. I re-entered the initialization string in the first location in the modem settings: AT& FI& B1&D& H1&ID&KI&M457=60 and then added to the second location for a string: AT&FI

This actually worked and I heard the modem functioning, in the log window it displayed the 1st string, then the modem number '5601' and then was a pause, a recorded message faintly played twice and then a hang-up and loud disconnection tones, like a phone off the hook. Then in the log window: NO CARRIER was displayed???? I never hear the computer generate the fax-like tone that I believe signals the computer that there's a connection being requested. I entered the DNS number for the ISP, checked the phone number for the ISP added a different one, but still no connection to the Net. I sense I'm so close to solving this problem!!!???? I wondering what else to look for here? This was the first time I actually heard the modem working and I know there's something very small I'm missing.

Maillo
 
Old 12-20-2006, 11:03 PM   #12
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
The problem you're describing sounds like you got a wrong number, a time out
with the phone receiver off the hook, or a wrong authentication. (For example
pap/chap when something else is required.) Only your ISP what the auth should be.
Are you using the Kppp wizard or a manual setup? If one try the other. But for
a manual setup the modem command page should be full of commands....If I recall correctly the wizard queries the modem and sets those up for you, but it has been awhile since I've done this...

Last edited by letitgo; 12-20-2006 at 11:05 PM.
 
Old 12-21-2006, 02:05 AM   #13
tytower
Member
 
Registered: Jun 2006
Location: Oz
Distribution: Mandriva 10.0,10.1,10.2,2006,Mepis 6.0,Opensuse10.2,Puppy 2.14
Posts: 250

Rep: Reputation: 30
I reckon you have a wrong number also . do you have an area code ? or some other number that should be added?
check the number that is actually being sent. I hav'nt done this for a long time either but there should be a log file to check in with the kppp files or in /var/log
 
Old 12-21-2006, 08:34 AM   #14
bliss4one
LQ Newbie
 
Registered: Dec 2006
Location: Denver, CO
Distribution: Debian Lenny 5.0
Posts: 23

Original Poster
Rep: Reputation: 15
Rule out the wrong phone number, because i use the exact phone number on the windows machine that this unit sits on! So I know I have that information set up right for this area.

In setting up the internet account the wizard doesn't allow for the USA as a location to set up the account or modem, so there has to be a manual set-up process. When one gets to the modem command page of the twenty lines of commands, only four of them had pre-set commands: 1. Pre_init delay line 4.Post-init delay line 5.Dialing speed and line 19. Guard time....I added the initialization strings I located on-line for the modem to lines 2 and 3...this produced the first sounds of activity since I started. Where to I get the rest of the modem commands to get this system connecting????

Maillo
 
Old 12-21-2006, 12:53 PM   #15
letitgo
Member
 
Registered: Jul 2003
Location: New Orleans
Distribution: Slackware 13.0
Posts: 111
Blog Entries: 1

Rep: Reputation: 15
hi,
I found this at:

http://www.mepis.org/node/11278

Using the Live SM disk, I was able to copy all the information filled out in the KPPP Modem Commands fields. (These were mostly blank with installed SM.) Rebooted into installed SM, and manually added each field:
30
ATZ
(blank)
30
70
OK
ATX3
ATDT
CONNECT
BUSY
NO CARRIER
NO DIALTONE
+++ATH
OK
ATA
RING
CONNECT
DIGITAL LINE DETECTED
+++
OK
50
M0L0 M1L1 M1L3
I rebooted computer and the settings were still there.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Robotics 56K Fax Internal Modem (ISA) Problem Snabber Linux - Hardware 3 04-06-2007 09:05 AM
US ROBOTICS 56K V.92 Internal PCI Faxmodem Linux Driver needed dudeguy9001 Linux - Software 2 12-23-2004 01:14 PM
56k External Serial Modem Problems with Linux No Dialtone cylob Linux - Hardware 3 04-22-2004 09:43 PM
Slow Connection US Robotics 56K V.92 External. chrispaz Linux - Hardware 0 02-03-2004 01:00 PM
Us Robotics 56k Voive Internal mhd_Ahmed Linux - Newbie 8 05-18-2003 10:49 AM


All times are GMT -5. The time now is 03:23 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration