LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   MEPIS (http://www.linuxquestions.org/questions/mepis-64/)
-   -   no internet detection unlike others distros (http://www.linuxquestions.org/questions/mepis-64/no-internet-detection-unlike-others-distros-587738/)

le1 09-27-2007 10:12 AM

no internet detection unlike others distros
 
I tried many distros ubuntu,mint,elive,dreamlinux,mandrivia,zenwalk,freespire,knoppix from all those only MEPIS didn't detect my internet connection at the start.
I kind of gave up on the idea of having it since I'm not a linux master and didn't know how to fix it but can you tell me why all those other distros have no problem at all with detecting connection and this on has. Just curiosity. Is this linux build different or sth ?

Larry Webb 09-27-2007 12:07 PM

Most distros especially the live ones are designed with drivers current with the time they are developed. The live cds can only have a certain number of drivers do to the room on the cd. This is one of the reasons you can ask a dozen different people the best distro and nine chances out of ten 3/4 of them will a have different answer. Once you become more familiar with Linux, finding drivers and installing becomes a challenge and fun.

archtoad6 09-28-2007 09:33 AM

What are your hardware specs, esp. your NIC's?

I've been running SimplyMEPIS since 2004.04, & never had trouble w/ it finding the 'net.

Slick666 09-28-2007 09:41 AM

I think the question that needs to be asked here is when you say "didn't find the internet" do you mean that you do not have an interface or you do not have a connection?

if you are unsure use the command "ifconfig" it will show you your network connections. You should see a connection named lo or loop but you should also see eth0 or etho0. If it show that you have an eth* connection you just need to configure your network settings. If there is no eth* device it means that your distro could not setup that interface and you likely need a driver to setup it correctly.

Please post the output of you ifconfig if you can.

le1 09-30-2007 12:33 AM

if you culd help with figuring out what's coing on that'd be great
 
First of all thanks guys for paying attention to my problem.

It's probably something minor but my computer skills are not good enough to fix it and when I read "eth0 or etho0" or "lo or loop" it's like listening to Chinese (no offence).

Ok so when i boot LiveCD with (k)ubuntu, elive, freespire or dreamlinux after everything is loaded i just start ff or opera and i can surf online without doing anything.

When i boot up MEPIS i get Kweather error with no internet connection available (or sth close to it)

as for your other question:

Marvell Technology Group Ltd. 88E8038 PCI-E Fast Ethernet Controller (rev 14)

as for ipconfig is it safe for me to give you all the details ?

archtoad6 09-30-2007 11:45 AM

How many lines? -- If it just shows lo, & eth0 & maybe eth1, why not?

Please remember that most of us find it easier to read if it's put in a "Code" block.

If you're really worried about size, you could always put it on pastebin.ca, & only put the link to it here.

Slick666 10-01-2007 02:16 PM

I don't think ifconfig is going to reveal anything about your location as I would suspect your behind a router and have a private ip address (usually 192.168.1.*). As an example I will show mine.

eth0 Link encap:Ethernet HWaddr 00:09:6B:A7:3D:1A
inet addr:192.168.1.10 Bcast:255.255.255.255 Mask:255.255.252.0
inet6 addr: fe80::209:6bff:fea7:3d1a/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1009499 errors:0 dropped:0 overruns:0 frame:0
TX packets:323592 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:412180418 (393.0 MiB) TX bytes:21727699 (20.7 MiB)
Base address:0x9000 Memory:f5000000-f5020000

eth1 Link encap:Ethernet HWaddr 00:10:60:E0:81:F5
inet addr:192.168.1.11 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::210:60ff:fee0:81f5/64 Scope:Link
UP BROADCAST MULTICAST MTU:1540 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:16 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:180 (180.0 b) TX bytes:1896 (1.8 KiB)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:5 errors:0 dropped:0 overruns:0 frame:0
TX packets:5 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:261 (261.0 b) TX bytes:261 (261.0 b)

Now before your eyes go crossed let me show you the info that you yeally need to know.

eth0 is the name for my Ethernet connection number0
eth1 is the name for my Ethernet connection number1
(I got two ethernet cards :))
ignore lo

Both ethernet connections have an address (192.168.1.10, 192.168.1.11). This shows that they are connected and have and address and thusly I'm on the internet.

If your ifconfig shows that you have an eth(whatever) with no address it mean all you have to do is take an extra step to configure it and you online. if there is no eth(whatever) then that means that there is a driver issue and you will have to take a different approach.

I hope this is not to techy and brings you up to speed.

elcartero 10-03-2007 12:21 PM

Quote:

Originally Posted by le1 (Post 2905425)
I tried many distros ubuntu,mint,elive,dreamlinux,mandrivia,zenwalk,freespire,knoppix from all those only MEPIS didn't detect my internet connection at the start.
I kind of gave up on the idea of having it since I'm not a linux master and didn't know how to fix it but can you tell me why all those other distros have no problem at all with detecting connection and this on has. Just curiosity. Is this linux build different or sth ?

Try.....

Start/System/MEPIS/MEPIS Network Assistant then under the GENERAL tab select Automatic (NetworkManager) then hit apply and OK...that should do it. (You will only have to do this once)

If you continue to have problems try forums on mepislovers.org but do stick with Mepis I'm sure you won't regret it.

masinick 10-08-2007 12:34 PM

Another way (for the more curious)
 
As elcartero suggested, you can use the MEPIS Network Assistant to start any interfaces that, for whatever reason, do not start up. That will get the vast majority of network interfaces up and running without any problems at all. That is most likely to work since many other systems work for you. As mentioned by elcartero, use the Start button on the task bar, then select System, MEPIS, and finally MEPIS Network Assistant to use the tool, then select the GENERAL tab. Beneath that tab, select the Automatic method (which is the NetworkManager). Click the Apply button, followed by the OK button, and in most cases, that will enable your network interface.

Just to discuss what goes on beneath this interface, this application detects which interface or interfaces are available, then activates the selected interfaces. To find out the same information on your own, using a console terminal and invoking privileged access will give you the same information. You will be prompted for a root account, which is the system administrator's access, during the process.

A console terminal (called Konsole in KDE) is usually a black icon that looks like a display monitor, found on the task bar. Click it once to start a console terminal.

Then type in
Code:

sudo ifconfig
to find out which network interfaces are available. Type in
Code:

ifdown eth0
to ensure that the first Ethernet interface is deactivated, then type in
Code:

ifup eth0
to activate the interface. If the output from ifconfig indicates that you have some other interface, use that instead. Note that from the console, you press Enter after typing in each command.

The only time these commands do not work for me is when the software actually does not properly recognize the network interfaces at all, which is quite rare on my systems.


All times are GMT -5. The time now is 04:17 PM.