LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   MEPIS (http://www.linuxquestions.org/questions/mepis-64/)
-   -   lost my cd/dvd in upgrade...? (http://www.linuxquestions.org/questions/mepis-64/lost-my-cd-dvd-in-upgrade-419283/)

lenny45 02-24-2006 09:17 PM

lost my cd/dvd in upgrade...?
 
i upgraded to the Mepis 3.5.1 package and the only problem i had was losing my cd/dvd player. i go to the KDE control module and it's listed. i apply and it claims it can't find the device.

then i go into mount partitions and there is no dev/hdc. ok, i'm still a noob. so do i need to install the "setcd" package in synaptic? that's the only thing i can think of to make it work. (the warning said that "setcd" was testing)

thx (where are u satinet):p

satinet 02-25-2006 04:10 PM

here lenny. yes i had a similar problem... lol.

one mine i had the wrong version of HAL.

maybe you can try doing "apt-get install hal" on mine that removed on verison and put a different one on that worked.

that was after i updated the repositories as mentioned in the mepis wiki.

done that lenny?

lenny45 02-25-2006 06:15 PM

Quote:

Originally Posted by satinet
here lenny. yes i had a similar problem... lol.

one mine i had the wrong version of HAL.

maybe you can try doing "apt-get install hal" on mine that removed on verison and put a different one on that worked.

that was after i updated the repositories as mentioned in the mepis wiki.

done that lenny?

yup, got this....after i updated the repository!

apt-get install hal
E: Could not open lock file /var/lib/apt/lists/lock - open (13 Permission denied)
E: Unable to lock the list directory

satinet 02-25-2006 06:21 PM

you must still be synaptic when you're doing it...

exit the app and try again....

and you need to be root

lenny45 02-25-2006 06:45 PM

Quote:

Originally Posted by satinet
you must still be synaptic when you're doing it...

exit the app and try again....

and you need to be root

ahhh, thanks again Satinet.....i get this now

root@5[~]# apt-get install hal
Reading package lists... Done
Building dependency tree... Done
The following extra packages will be installed:
bluez-pin bluez-utils dbus libavahi-compat-howl0 libdbus-glib-1-2 libgnomevfs2-0 libgnomevfs2-common pmount
Suggested packages:
python-gtk2 bluez-firmware python2.2 hal-device-manager libgnomevfs2-bin
Recommended packages:
libgnomevfs2-extra gamin fam
The following packages will be REMOVED:
dbus-1 dbus-glib-1 libhal-storage0 libhal0
The following NEW packages will be installed:
dbus libavahi-compat-howl0 libdbus-glib-1-2
The following packages will be upgraded:
bluez-pin bluez-utils hal libgnomevfs2-0 libgnomevfs2-common pmount
6 upgraded, 3 newly installed, 4 to remove and 374 not upgraded.
Need to get 2688kB of archives.
After unpacking 871kB of additional disk space will be used.
Do you want to continue [Y/n]?

-------------------------------------------

since it don't work i guess i'll go for it.... stay tuna

satinet 02-25-2006 06:50 PM

that's exactly what happened for me and it cured the problem for me....

btw, synaptic uses "apt" whenever you are using apt, it create a lock file so that you can't run two apts at once - for obvious reasons - upgrading the same packages at the same time for instance....

i'm going to be now lenny. hope it works for u.... and the cat's sake too.

lenny45 02-25-2006 06:59 PM

Quote:

Originally Posted by satinet
that's exactly what happened for me and it cured the problem for me....

btw, synaptic uses "apt" whenever you are using apt, it create a lock file so that you can't run two apts at once - for obvious reasons - upgrading the same packages at the same time for instance....

i'm going to be now lenny. hope it works for u.... and the cat's sake too.

thanks Satinet----it is working after a re-boot! of course logging into root helped also.:cry: i'll have to pay you tutoring costs before it's over---you accept Peso's?:D

your quite helpful buddy.....;) i hope to return the favor. need any guitar lessons? :)

satinet 02-26-2006 07:35 AM

hi lenny.

glad to help. i just wrote this howto:

http://www.linuxquestions.org/questi...d.php?t=419680

maybe you can vote on it for me (excellent please :-D).

if you wanna get ssh working it could help.

i'm visiting an old friend in OK soon. how's the weather in your part of the globe???

p.s i only accept pounds stirling. i believe 1 = about $1.85 usd. lol. glad to help...

Wp2 03-08-2006 11:53 AM

every time I install a distro there is some issue I have to plug away at...helps me learn about linux. This time a reinstall of mepis gives me a device doesn't exist error for cdrom1 and a bad fs error when I try playing a cd. Previous installs have recognized my dvd and cdwriter. I've tried HAL and still no...?


All times are GMT -5. The time now is 12:42 PM.