LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   MEPIS (http://www.linuxquestions.org/questions/mepis-64/)
-   -   It Won't Let Me Go Root (http://www.linuxquestions.org/questions/mepis-64/it-wont-let-me-go-root-842491/)

th1bill 11-05-2010 02:38 AM

It Won't Let Me Go Root
 
After having tested a number of other distros i have loaded Mepis 8.0 onto my backup computer. My problem is in this quote;
Quote:


th1bill@home:~$ rsync -r /home/th1bill/* th1bil:<my PW>@mepis:/home/th1bill/Backups
ssh: Could not resolve hostname th1bil: Name or service not known
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(601) [sender=3.0.7]
th1bill@home:~$ rsync -r /home/th1bill/* th1bill:<my PW>@mepis:/home/th1bill/Backups
ssh: Could not resolve hostname th1bill: Name or service not known
rsync: connection unexpectedly closed (0 bytes received so far) [sender]
rsync error: unexplained error (code 255) at io.c(601) [sender=3.0.7]
th1bill@home:~$
My main computer runs Ubuntu 10.04 but my older unit also built by me, is a single core Athlon 64 and I cannot get ubuntu to install, requiring me to use the *.0 Mepis distro. If I ping from the mepis to home it does great. Tonight I have managed to change something on the Guard Dog to allow mw to ping from home to mepis but it will not allow rsync nor ssh.

Right after the install i had the option to log in as Root but that has disappeared. If I do the terminal and sudo su it tells me I have no permission.

Can anybody help?

btncix 11-05-2010 01:33 PM

I recommend you first disable Guarddog and then try to get rsync and ssh working. Afterwards, try to get rsync and ssh working with Guarddog enabled. This will help you isolate the problems in your setup.

If you can run sudo on Ubuntu, you don't need to be root user. Regardless, if you want to become root user via su,
see this.

th1bill 11-05-2010 03:31 PM

Quote:

Originally Posted by btncix (Post 4150335)
I recommend you first disable Guarddog and then try to get rsync and ssh working. Afterwards, try to get rsync and ssh working with Guarddog enabled. This will help you isolate the problems in your setup.

If you can run sudo on Ubuntu, you don't need to be root user. Regardless, if you want to become root user via su,
see this.

thanks for the reply but I managed to get ubuntu on the second machine and problem solved.


All times are GMT -5. The time now is 03:48 AM.